GFABASIC killing the environment

GFA BASIC-related articles in here please

Moderators: simonsunnyboy, Mug UK, Zorro 2, Moderator Team

ThorstenOtto
Atari God
Atari God
Posts: 1109
Joined: Sun Aug 03, 2014 5:54 pm

Re: GFABASIC killing the environment

Post by ThorstenOtto »

Edit: seems to be the interpreter that changes the directory again:

Code: Select all

pid  13 (gbe): create_process: d_setpath C:\devtools\gbe\
pid  13 (gbe): Dsetpath(C:\devtools\gbe\)
pid  14 (ro_68k): Dsetpath(\devtools\gbe\system)

User avatar
lp
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2490
Joined: Wed Nov 12, 2003 11:09 pm
Location: GFA Headquarters
Contact:

Re: GFABASIC killing the environment

Post by lp »

I didn't allocate enough space for the two shorts in that structure, but since the corresponding bits are not set it should still work? I was not aware that XaXES extended this structure. I will adjust it accordingly in my current build just in case.

The interpreter can be installed on the desktop and "passed a full" path. This allows running of *.gfa files as if they are standalone apps. The interpreter does set the path. I will have a look at it.

ThorstenOtto
Atari God
Atari God
Posts: 1109
Joined: Sun Aug 03, 2014 5:54 pm

Re: GFABASIC killing the environment

Post by ThorstenOtto »

lp wrote:I didn't allocate enough space for the two shorts in that structure
That's no problem, as long as the corresponding bits in the mode parameter are not set, those members aren't accessed. They aren't even documented yet in tos.hyp, so i guess that was an extension added later.
The interpreter does set the path. I will have a look at it.
I got the traces by adding printfs in the XaAES kernel (just before create_process is called there in shel_write), and in sys_d_setpath0 in the mint kernel. The first message comes from XaAES, the 2nd from create_process calling sys_d_setpath0 because the defdir element was set, and the last one from the interpreter.

You can also try with litchi.gfa, it complains that the resource file cannot be found.

User avatar
lp
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2490
Joined: Wed Nov 12, 2003 11:09 pm
Location: GFA Headquarters
Contact:

Re: GFABASIC killing the environment

Post by lp »

Initially litchi.gfa complained about the rsc file not found then I noticed he didn't put the rsc in the source code archive. After correcting that it works here. I think I discovered this same issue recently and fixed it. Indeed the version of GBE you have is passing the wrong path. I will create a fresh archive as most of the components have been updated since that release. I'll let you know when it's live on my server.

ThorstenOtto
Atari God
Atari God
Posts: 1109
Joined: Sun Aug 03, 2014 5:54 pm

Re: GFABASIC killing the environment

Post by ThorstenOtto »

Just found out that the new fields are already documented in the mt_gem.h of gemlib. Also noticed that there is a slight conflict between XaAES and MagiC6: in MagiC, these two short fields at the end are used for flags. But again, as long as the bit is not set, that should not matter.

Post Reply

Return to “GFA BASIC”