Bluescsi help on Mega STE

Hardware, coding, music, graphic and various applications

Moderators: Mug UK, lp, moondog/.tSCc., [ProToS], Moderator Team

User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 821
Joined: Wed Mar 23, 2016 2:46 am
Location: Mississauga, ON, Canada

Re: Bluescsi help on Mega STE

Post by Bikerbob »

Mikerochip wrote: Wed Jun 19, 2024 1:08 pm
Bikerbob wrote: Wed Jun 19, 2024 1:56 am ANYONE have a tOri interface working with a bluescsi or another modern solution?
James
I have an AdSCSI Micro, and it doesn't work with BlueSCSI v1, but it does work with SCSI2SD v5.0a.

I raised a ticked on the BlueSCSI v1 Git, and installed the debug firmware.
(v1 needs a separate firmware, for logging, unlike v2 BlueSCSI)

The only thing the log output shows is

Code: Select all

CMD:
then the BlueSCSI locks up.
So, the AdSCSI Micro definitely works. I have it connected to the DMA pin header on my mATX ST v1.1 from x_angel.

Github comment: https://github.com/erichelgeson/BlueSCS ... ssions/268

It seems to have been ignored after that.
Ok, so you are in the exact same boat as me then with the bluescsi on these. I also have piscsi, so I will try that. But this rabbit hole into scsi devices might not have been my wisest choice.

The real way to fix all this is to knock off the Link 2 . but seems no one that CAN do it has the appetite to do so.

James
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
Mikerochip
Captain Atari
Captain Atari
Posts: 469
Joined: Sat Feb 07, 2015 11:22 am
Location: Ireland

Re: Bluescsi help on Mega STE

Post by Mikerochip »

Bikerbob wrote: Wed Jun 19, 2024 1:39 pm
Mikerochip wrote: Wed Jun 19, 2024 1:08 pm
Bikerbob wrote: Wed Jun 19, 2024 1:56 am ANYONE have a tOri interface working with a bluescsi or another modern solution?
James
I have an AdSCSI Micro, and it doesn't work with BlueSCSI v1, but it does work with SCSI2SD v5.0a.

I raised a ticked on the BlueSCSI v1 Git, and installed the debug firmware.
(v1 needs a separate firmware, for logging, unlike v2 BlueSCSI)

The only thing the log output shows is

Code: Select all

CMD:
then the BlueSCSI locks up.
So, the AdSCSI Micro definitely works. I have it connected to the DMA pin header on my mATX ST v1.1 from x_angel.

Github comment: https://github.com/erichelgeson/BlueSCS ... ssions/268

It seems to have been ignored after that.
Ok, so you are in the exact same boat as me then with the bluescsi on these. I also have piscsi, so I will try that. But this rabbit hole into scsi devices might not have been my wisest choice.

The real way to fix all this is to knock off the Link 2 . but seems no one that CAN do it has the appetite to do so.

James
Not sure if the link etc would help us. We'd still need some scsi device to connect to it, and, there's no telling if the BlueSCSI would be compatible with the link and it's variants, either!
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 821
Joined: Wed Mar 23, 2016 2:46 am
Location: Mississauga, ON, Canada

Re: Bluescsi help on Mega STE

Post by Bikerbob »

I think the link 2 updates things quite a bit. Things noted on articles of the ADSCSI ST PLUS is that these devices are really SCSI 1 specific. They lack some features that bluescsi assumes is there.. but more important I think that ICD cut a corner on something else, that with ACSI which is a mix of SASI and SCSI the atari at that time did not use, but that Atari's own interface did not neglect. It is the only way I see that the original Atari MegaSTE interface works with bluescsi but the ICD does not. I do not have LInk 97 or Link 2 - so unless we can find someone with one to test.. wont know.

James
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 2572
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Bluescsi help on Mega STE

Post by frank.lukas »

Have you try a new SD card in a fat32 format with fat16 dos images with masterboot record on it, see my picture ...?

No config file and no txt file on the SD card. The new fat16 image must you partition with hddriver on the Atari. For a first test make the fat16 image 500MB not bigger.

You can build a fat16 image on Windows, ask google ...
You do not have the required permissions to view the files attached to this post.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
User avatar
Bikerbob
Atari Super Hero
Atari Super Hero
Posts: 821
Joined: Wed Mar 23, 2016 2:46 am
Location: Mississauga, ON, Canada

Re: Bluescsi help on Mega STE

Post by Bikerbob »

I have never made a .IMG in a different format than the media, but I will give it a try Frank.

James

Finding it hard to see a way currently to make an .img file period in windows. The ways that I do find, it does not give me an option of setting up a file system. I can create a VHD.. then maybe format it on the PC in FAT16.. rename it to .img? will that work. I dont know.

There is a program called DISKJOCKEY.. which I could create any size .HDA file, rename that.. not sure how to format a IMG file. without being in some kind of EMU software.

James
TT030 - Light/Storm/Thun 256mb TT ram 10mb ST ram card(Lynxman) Nova(frank lukus) Mach32 2mb. 250gb SSD
MegaSTE - monSTer (alanH) RGB2HDMI(pixelk) 68kHC cpu - IDE CF 8gb internal.
MegaST - ICD ADspeed & Compatibility Plus
Phoenix ST - Exxos remake board - Lightning Storm Cloudy.
1088XEL, 800 incognito, 800xl U1mb.
Post Reply

Return to “Professionals”