CosmosEx v1/v2 - Update

News, questions and bugs reports about CosmosEx by Jookie. Now we have a Raspberry Pi in our machines!

Moderators: Jookie, Moderator Team

Post Reply
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

CosmosEx v1/v2 - Update

Post by Cyprian »

Anyone have tested that this year?
I read somewhere that one of the latest update has bricked CosmosEx v1.

I have old SW/FW in both versions, I guess I have to download full SD card first.
20190718_225624.jpg
20190718_205516.jpg
You do not have the required permissions to view the files attached to this post.
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
scsilord
Retro freak
Retro freak
Posts: 15
Joined: Mon Feb 05, 2018 5:24 pm
Location: Netherlands

Re: CosmosEx v1/v2 - Update

Post by scsilord »

I had issues with upgrading to the latest version on a CosmosEx V1. The raspbian and yocto releases were all breaking when updating.
My fix to get the latest software/firmware on a V1?
Follow jookies guide on: http://joo.kie.sk/?page_id=518 , after running this on a clean yocto distro i'm now all up to date.
I know it's sortof a debrick guide, but it updates with the latest software.
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: CosmosEx v1/v2 - Update

Post by Cyprian »

thanks,
It seems there is something wrong with that script.
I'll try to grab the SD card image .

CosmosEx v1:
CosmoACSI # ./ce_update.sh
cesuper.sh is not running, so not stopping it
/ce/ce_stop.sh: 17: [: 261: unexpected operator
Stopping cosmosex...
-e
Updating CosmosEx from internet, this will take a while
DO NOT POWER OFF THE DEVICE!!!


>>> Downloading the update from web...
--2019-07-19 17:21:34-- http://joo.kie.sk/cosmosex/update/ce_update.zip
Resolving joo.kie.sk (joo.kie.sk)... 92.240.253.107
Connecting to joo.kie.sk (joo.kie.sk)|92.240.253.107|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-07-19 17:21:34 ERROR 404: Not Found.

File /tmp/ce_update.zip not found, did the download fail?
CosmoACSI #
CosmosEx v2:
root@ce:/ce# ./ce_update.sh
Stoping cesuper.sh ...
Stopping cosmosex...

Updating CosmosEx from internet, this will take a while
DO NOT POWER OFF THE DEVICE!!!

\n>>> Downloading the update from web...
Connecting to joo.kie.sk (92.240.253.107:80)
wget: server returned error: HTTP/1.1 404 Not Found
File /tmp/ce_update.zip not found, did the download fail?
root@ce:/ce#
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
scsilord
Retro freak
Retro freak
Posts: 15
Joined: Mon Feb 05, 2018 5:24 pm
Location: Netherlands

Re: CosmosEx v1/v2 - Update

Post by scsilord »

Looks like the update zip is not on the website right now (404). Maybe the update is getting updated.
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: CosmosEx v1/v2 - Update

Post by Cyprian »

I've upgraded both RPI's SD card with ce_raspbian_stretch_2018-05-10.img from Jookie's site. And after that CosmosEx V2 works fine.
Unfortunately there is something wrong with V1. LAN (both WiFi and cable) is not recognized, translated SD isn't mounted.
Raspbian shows following error: "[FAILED] Failed to start dhspcpd on all interfaces. See 'systemctl status dhcpcd.service' for details".
USB (cable) keyboard doesn't work, therefore I can't login.
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
scsilord
Retro freak
Retro freak
Posts: 15
Joined: Mon Feb 05, 2018 5:24 pm
Location: Netherlands

Re: CosmosEx v1/v2 - Update

Post by scsilord »

From my experience the ce_raspbian_stretch_2018-05-10.img release had issues with the usb hub on the V1.
For the v1 i used the yocto distro and used the script to get it up to date. I prefered rpi-ce-run-real over ce_raspbian_2017-01-03, because it boots faster.
Bad news is that you have to wait until the update zip is back online again.
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: CosmosEx v1/v2 - Update

Post by Cyprian »

ok, fortunately v2 works fine.
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1252
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

Re: CosmosEx v1/v2 - Update

Post by Jookie »

Hello,

I'm changing the way the update is done on device - it was one zip file with all the 3 binaries for distros (yocto, jessie, stretch), it was more work to do the release when a only a minor thing changed. Now it should work using git downloading only new files, for specific distro only, so releases will be simpler. But as the yocto doesn't have git client on it and the wget contained in that image doesn't support https (while github doesn't let you download without https), the next update of yocto might not be easily possible through internet or might even be the last update. The USB update on yocto still might work, but if you don't have to - just don't update Yocto.

The new features will probably not be built, added and tested on Yocto, but only on Raspbian Stretch (and possibly older Jessie), as testing and building for 3 platforms instead of 1 is time consuming and annoying. So ideally we should use the latest distro everywhere (if it works - I've seen the mentioned issues with USB or something).

Regards,
Jookie
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: CosmosEx v1/v2 - Update

Post by Cyprian »

If there is no objections agaist CosmosEx v1 and Raspbian, then lets try to use it together
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1252
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

Re: CosmosEx v1/v2 - Update

Post by Jookie »

If something is not broken in Raspbian that would prevent it from running on older Raspberry Pi (officially there shouldn't be such thing), then using Raspbian Stretch image on the v1 device would be the way to go. But do make a back-up of your SD card before writing new image - just in case you would want to go back.
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: CosmosEx v1/v2 - Update

Post by Cyprian »

Jookie wrote:But do make a back-up of your SD card before writing new image - just in case you would want to go back.
too late :)
overwritten with mentioned ce_raspbian_stretch_2018-05-10.img
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 403
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: CosmosEx v1/v2 - Update

Post by Bikerbob »

OK so I have Micro Cosmos.. what is the verdict? do I upgrade or what?

OR.. I would think I am running Jessie, so should I download Stretch and then write it to the SD card?

My wifi dongle seems to work just fine on its end.. but within my network trying to shh or get to the webpage.. it either times out or is dog slow.

James
User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1252
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

Re: CosmosEx v1/v2 - Update

Post by Jookie »

There was a bug on Stretch and Jessie which caused the USB + ethernet to be turned off on RPi 1, this should be now fine with the Stretch image. So Stretch should work on RPi 1, 2, 3, and thus all CosmosEx devices just fine.
MicroCosmos it running on RPi 2 or later, so updating that one should be fine, too (or writing the Stretch image and then doing update).
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: CosmosEx v1/v2 - Update

Post by Cyprian »

Thanks Jookie, I was watching your discussion on Github.
I'll check that update this evening and I let you know.
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: CosmosEx v1/v2 - Update

Post by Cyprian »

Jookie image "stretch_2019-07-24.img" works fine on both CosmosEx v1 and v2. They are are online (I have an access via web browser), translated drive is visible from ST
There is one thing, they have different "Status":
20190802_001453.jpg
20190802_013722.jpg
You do not have the required permissions to view the files attached to this post.
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1252
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

Re: CosmosEx v1/v2 - Update

Post by Jookie »

- I've (probably) fixed the 'not reading the xilinx version from new version file' (000000), but I need to test it on real device once I get home from vacation.

- I've also added checking and flashing of chips firmware before linux app start, so when you write new SD image, you will also get the chips flashed (currently they won't get flashed until you get next update).

Both will need to be tested and released, once I get home from vacation, in about a week.
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 403
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: CosmosEx v1/v2 - Update

Post by Bikerbob »

Ok.. Ill leave you to have fun .. and ask questions in about a week! :)

james
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 403
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: CosmosEx v1/v2 - Update

Post by Bikerbob »

Jookie, I downloaded the latest rasbian image for my micocosmos

When I go to update.. it says update available. I try and update.. go through various countdowns - There is something that goes by so fast after it finishes I cannot read it.. but nothing changes.. What is the status of this for the microcosmosex?

thanks
James
tuf
Atariator
Atariator
Posts: 26
Joined: Wed Jun 18, 2008 7:43 pm

Re: CosmosEx v1/v2 - Update

Post by tuf »

Ugh I just bricked my v1 trying to online update. I'll follow the steps here and see if I can fix it.
tuf
Atariator
Atariator
Posts: 26
Joined: Wed Jun 18, 2008 7:43 pm

Re: CosmosEx v1/v2 - Update

Post by tuf »

Unbricked it by downloading the old Yocto release from Github and manually flashing Hanz, Franz and the Xilinx. The update script is very broken, at least on my original device. Everything is working again but I'm sure I can never update it automatically again in this state.
CosmosEx_Configuration.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1958
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: CosmosEx v1/v2 - Update

Post by Cyprian »

did you test "stretch_2019-07-24.img"?
Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / Lynx Multi Card / LDW Super 2000 / XCA12 / SkunkBoard / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/
Sowden
Atari freak
Atari freak
Posts: 74
Joined: Mon Mar 17, 2014 6:15 pm

Re: CosmosEx v1/v2 - Update

Post by Sowden »

Hey there. Well, with the social distancing I have to do, this is the perfect opportunity to try to update my CosmosEx v1. I have wanted to do so since this thread opened. So I've spent all day going through the three different systems and found that all at max update brakes the floppy emulation. Everything else seems to work fine (USB thumbstick, internet, USB mouse) but every update past 2019-07-22 breaks the floppy drive. And thats across all systems (Yacto, Jessie and Stretch). I can mount a floppy by double clicking on the .st file, but it seems to mount instantly. Usually it has to take 5 seconds or so to "*****" and then mount it. So I hit reset and boot the machine, boot from A:. It loads the floppy, I can open a program, hit past one screen, and it says "Data on the disk in drive A: may be damaged." Its weird because I can load a different game on that same floppy, and it runs fine. It seems as if it only loads half of the disk. Another disk it gives me that message right out of the gate. I've also opened the new CE_FDD program to mount the floppies, but I get the same results. I have some backups of working images. I have Yacto working at 2018-05-16 and Jessie working at 2017-04-13. Stretch I can't get a working version at all. I also understand that these v1's are on their way out. Has anyone else had this problem?
User avatar
Gaiyan
Hardware Guru
Hardware Guru
Posts: 517
Joined: Tue Jun 29, 2004 3:39 pm
Contact:

Re: CosmosEx v1/v2 - Update

Post by Gaiyan »

Sowden wrote:Hey there. Well, with the social distancing I have to do, this is the perfect opportunity to try to update my CosmosEx v1. I have wanted to do so since this thread opened. So I've spent all day going through the three different systems and found that all at max update brakes the floppy emulation. Everything else seems to work fine (USB thumbstick, internet, USB mouse) but every update past 2019-07-22 breaks the floppy drive. And thats across all systems (Yacto, Jessie and Stretch). I can mount a floppy by double clicking on the .st file, but it seems to mount instantly. Usually it has to take 5 seconds or so to "*****" and then mount it. So I hit reset and boot the machine, boot from A:. It loads the floppy, I can open a program, hit past one screen, and it says "Data on the disk in drive A: may be damaged." Its weird because I can load a different game on that same floppy, and it runs fine. It seems as if it only loads half of the disk. Another disk it gives me that message right out of the gate. I've also opened the new CE_FDD program to mount the floppies, but I get the same results. I have some backups of working images. I have Yacto working at 2018-05-16 and Jessie working at 2017-04-13. Stretch I can't get a working version at all. I also understand that these v1's are on their way out. Has anyone else had this problem?
Yes, same problem. Using Stretch on v 2. Using web client works most of the time.
Image
Post Reply

Return to “CosmosEx”