Page 1 of 1

HxC inside 520ST (not 520STF!)

Posted: Mon Mar 17, 2014 10:51 am
by zzarko
I have bought a 520ST (model without an internal floppy) with internal 512K upgrade (total 1MB) and I would like to connect HxC internally. This machine doesn't have an internal floppy connector. Is it possible to connect HxC just by making a cable that is soldered to external floppy connector contacts, or should there be some additional electronics involved? Did anyone did this? Is there maybe a schematics for this?

Re: HxC inside 520ST (not 520STF!)

Posted: Mon Mar 17, 2014 1:12 pm
by Dal

Re: HxC inside 520ST (not 520STF!)

Posted: Mon Mar 17, 2014 10:21 pm
by tenox
Also check out SLIM SD: http://www.lotharek.pl/category.php?kid=25 it may fit inside better than the standard HxC.

Re: HxC inside 520ST (not 520STF!)

Posted: Tue Mar 18, 2014 10:47 am
by zzarko
That is an very nice external solution! If I understood correctly, you have directly connected pins on HxC to pins on external floppy connector on Atari ST, no additional electronics required? If that is the case, I guess I could just use your scheme and solder a floppy cable directly to pins on 520st floppy connector for internal mount. I already have a HxC with a detachable LCD screen, so I will use that for my project. Thanks!

Re: HxC inside 520ST (not 520STF!)

Posted: Tue Mar 18, 2014 1:08 pm
by Dal
Yes you got it. For the 520ST then there is no need to do the Floppy A/B switch mod as the external port is already mapped to Drive A (or DS0 to use its correct name).

So just wire up directly from the 34pin IDC header on the HxC to the 14pin DIN connector and you're good to go. If you want a completely internal solution (and you're able to desolder without destroying boards), you might consider removing the 14pin connector and wiring directly to the board or keep the connector in place but tap back to find a suitable place to take each line from.

It would be great to see your finished solution. Have fun and take it slowly!

Re: HxC inside 520ST (not 520STF!)

Posted: Wed Mar 19, 2014 4:17 pm
by zzarko
Dal wrote:It would be great to see your finished solution. Have fun and take it slowly!
I intend to take it very slowly, and to consult my friend who is much better with soldering than me. I will post pictures when I'm finished. Thanks again for advices! Atari-Forum is a great community :)

Re: HxC inside 520ST (not 520STF!)

Posted: Wed Mar 19, 2014 10:05 pm
by troed
Dal wrote:Yes you got it. For the 520ST then there is no need to do the Floppy A/B switch mod as the external port is already mapped to Drive A (or DS0 to use its correct name).

So just wire up directly from the 34pin IDC header on the HxC to the 14pin DIN connector and you're good to go. If you want a completely internal solution (and you're able to desolder without destroying boards), you might consider removing the 14pin connector and wiring directly to the board or keep the connector in place but tap back to find a suitable place to take each line from.
Jookie┬┤s CosmosEx has me wondering whether I should change plans for this system - but currently the above is what I intend to do (on an STE). Removing the external floppy port altogether, wire it up to an internally mounted HxC SD and installing an A<->B switch.

Re: HxC inside 520ST (not 520STF!)

Posted: Fri Mar 21, 2014 12:46 pm
by zzarko
After gathering all the info I needed, I have made connections diagram. And after soldering, everything worked the first time! Now, I need to decide how will I mount HxC inside Atari. Thanks again for advices!

Re: HxC inside 520ST (not 520STF!)

Posted: Sun Apr 13, 2014 5:47 pm
by zzarko
Here it is, the finished machine:
ST3.jpg
A mobile telephone joystick is used for navigation, it is connected to HxC buttons internally.

On the back, there are added S-Video and Composite video outputs, SD card slot and two Audio outputs:
ST2.jpg
A friend of mine has made me a RGB-to-S-Video converter (with this circuit: http://www.cpcwiki.eu/index.php/RGB_SVideo).

Everything works fine :)

Dots on screen

Posted: Wed Apr 16, 2014 7:08 am
by zzarko
The machine I have modified had a problem with displaying black dots on Atari desktop while moving the mouse (before I started to modify it). Here is how its desktop looks like after driving a mouse for a while:
IMG_20140415_165806.jpg
When i bought it, I found that it had a 1MB piggyback memory expansion:
520ST2.JPG
Could it be that maybe some of the memory chips are malfunctioned, or should I try to look elsewhere?

If you know something about this problem, please answer! Thanks!

Re: HxC inside 520ST (not 520STF!)

Posted: Wed Apr 16, 2014 12:16 pm
by MasterOfGizmo
This is exactly how ram problems look like. Your problem occurs exactly every 16 pixels. So only a single ram seems to be affected. You should be able to disable the extra layer by tying one of the control signals to vcc. That way you can test that its really the ram update without soldering too much on the machine.

I'd check for bad solder conections on the update first.

Gesendet von meinem GT-I8190 mit Tapatalk

Re: HxC inside 520ST (not 520STF!)

Posted: Wed Apr 16, 2014 8:29 pm
by zzarko
MasterOfGizmo, thank you very much for advice! I'll try to check what you suggested.

Re: HxC inside 520ST (not 520STF!)

Posted: Sun Sep 03, 2017 8:55 am
by saulot
I'm doing similar mod myself (internal HxC) and I have one question, how internal +5DC is sourced from inside? I've read somewhere that standard psu isn't enough and you have to provide addtional power supply. Is this true?
And after connecting device and sourcing +5dc from internal power port I have problems with autobooting hfe image with selector (two bombs at random during startup image load).

Re: HxC inside 520ST (not 520STF!)

Posted: Tue Sep 05, 2017 11:18 am
by Jeff_HxC2001
saulot wrote:... I've read somewhere that standard psu isn't enough and you have to provide addtional power supply. Is this true?
No this is not true for the HxC hardware. This is maybe true for something else...