Newer Sierra games, no sound

A section to cover all the different problems encountered by running game x on system y! Whether it's as simple as a non-STE compatible game through to h/drive installable games. Discuss them all in here.

Moderator: Moderator Team

Post Reply
User avatar
tjlazer
Atari Super Hero
Atari Super Hero
Posts: 646
Joined: Mon Feb 02, 2004 4:00 am
Location: Tacoma, WA USA
Contact:

Newer Sierra games, no sound

Post by tjlazer »

Been having a weird issue on my ST's. Some newer Sierra games, like Leisure Suit Larry 2, Conquest of Camelot do not play any sound or music. Works on STEEM. Same TOS versions and RAM. Tried on real hardware: 1040STf, 1040STE, and Mega ST4. No sound.
Atari Computer Collector since 1984

From the 8-bit Atari 400 to the 32-bit Atari TT030!

Fletch
Atari maniac
Atari maniac
Posts: 88
Joined: Fri Sep 12, 2008 1:11 am

Re: Newer Sierra games, no sound

Post by Fletch »

Is the ATARISND.DRV selected in the MUSIC.PRG? I'm betting that you have the MT32 selected.

User avatar
tjlazer
Atari Super Hero
Atari Super Hero
Posts: 646
Joined: Mon Feb 02, 2004 4:00 am
Location: Tacoma, WA USA
Contact:

Re: Newer Sierra games, no sound

Post by tjlazer »

I had checked the MUSIC program and the ST sound was selected. But I went ahead and selected it again, the did the INSTALL and it saved the config. NOW IT WORKS! Thanks!
Atari Computer Collector since 1984

From the 8-bit Atari 400 to the 32-bit Atari TT030!

User avatar
leech
Atari God
Atari God
Posts: 1288
Joined: Tue Dec 01, 2015 3:26 pm

Re: Newer Sierra games, no sound

Post by leech »

One of these days I need to test my MT-32 with these on the ST.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)

Post Reply

Return to “Games - Compatibility Issues etc.”