new Nova drivers

Latest news in the Atari world

Moderators: Mug UK, Silver Surfer, Moderator Team

User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 488
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

I have mach32 in my TT030 .

I was trying to get a MegaST 4 with PAC030 up and running with a panther and the ET4000 I have. But I have not been able to get the PAK030 stable.

I have lost contact with those that were helping me, and at the moment It is not looking likely that I will be able to get this done. Seems 90% of the issue is good connections, but when your tower of cards is now reaching 20cm tall, its hard to keep everything connected and grounded. I wish for this I was somewhere over in the Germany euro area, where I could enjoy learning how to get this work with so many of the great hobbyists over there.

Loving my Mach32 on franks nova on my TT.

I have managed to get 1024x762x32k @60mhz - in the menu.. Is there a program that will confirm the colour depth when running? Also when I then go into miNT it seems to move it back to 256 colours. is that right? or should I be able to use miNT in 32k colour depth?

James
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 2120
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: new Nova drivers

Post by frank.lukas »

MiNT/XaAES can run in any color depth.
Bikerbob wrote: Sun Feb 28, 2021 8:15 pm ... when I then go into miNT it seems to move it back to 256 colours.
MiNT or XaAES not move anything back.

Sysinfo (sinf502e) -> https://sites.google.com/site/stnonesse ... edirects=0
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
Rustynutt
Atari God
Atari God
Posts: 1386
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: new Nova drivers

Post by Rustynutt »

Without going back too far in the thread, you need to edit the XaAES.cnf file. Load it in QED, search for "video".
There you will find an area of the file where various setting are (Abit confusing for me) available. Tried to make sense of it, having a Super Videl made it easier, I used it's setup feature to override the AES settings :)
That's how I understand it as change mode doesn't work as it does under TOS afaik.
Last I'd set up a MACH64 with the old NOVA drivers was under NAES and Ease, where change mode is kind of sorta integrated and works more like a resolution change under TOS does.
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 2120
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: new Nova drivers

Post by frank.lukas »

Video mode select is system video and Atari Falcon only I think. It has nothing to do with nova driver ...
  • ## video mode select
    # -----------------
    #
    # Selects the video mode that XaAES will boot into. If not set mode = 1
    # will be used, e.g. use current/default video mode.
    #
    # If you don't have a Falcon <mode> can be:
    # -----------------------------------------
    # - 2 = 320*200, 16 colour (ST-Low)
    # - 3 = 640*200, 4 colour (ST-Medium)
    # - 4 = 640*400, 2 colour (ST-High)
    # - 6 = 640*480, 16 colour (TT Medium)
    # - 8 = 1280*960, 2 colour (TT High)
    # - 9 = 320*480, 256 colour (TT Low)
    #
    # All other values are ignored!
    #
    # If you have a Falcon <mode> is the same argument as to the
    # VsetMode() OS call:
    # ---------------------------------------------------------
    # BIT Name Meaning
    #
    # 0-2 BPS Number of bitplanes:
    # - 000 = 2colour
    # - 001 = 4colour
    # - 010 = 16colour
    # - 011 = 256colour
    # - 100 = 16bits/pixel (True colour)
    #
    # 3 COL Number of columns
    # - 0 = 40
    # - 1 = 80
    #
    # 4 VGA Monitor select
    # - 0 = TV mode
    # - 1 = VGA mode
    #
    # 5 TVSEL TV standard select
    # - 0 = NTSC
    # - 1 = PAL
    #
    # 6 OVERSCN Overscan flag (not valid for VGA)
    # - 0 = don't overscan
    # - 1 = overscan
    #
    # 7 STMODES ST Compatibility mode
    # - 0 = Standard VGA video modes
    # - 1 = ST Compatible Video modes
    #
    # 8 VERTFLAG Vertical mode
    # - VGA: 0 = standard
    # 1 = line doubling (half res)
    # - TV: 0 = standard
    # 1 = Interlace (double res!!!)
    #
    # 9-14 unused
    #
    # 15 Additive mode bit for non standard resolutions
    # If set, use the default screen resolution as preset by
    # CentScreen.
    #
    # For example:
    #
    # video = 26 will select 640*480*16colour VGA mode.
    # video = 0x801a will select 16 colour VGA mode in
    # the resolution preset by centscreen.
    # Note:
    # When you use a screenexpander like Screenblaster, you have to use
    # the video option as well. This will make the Screenblaster-Software
    # to show up the resolution-selection-menu.
    #
    #video = <mode>
    #video = 4
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
Rustynutt
Atari God
Atari God
Posts: 1386
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: new Nova drivers

Post by Rustynutt »

Thank you :)
Wasn't thinking.
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 488
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

frank.lukas wrote: Sun Feb 28, 2021 9:15 pm MiNT/XaAES can run in any color depth.
Bikerbob wrote: Sun Feb 28, 2021 8:15 pm ... when I then go into miNT it seems to move it back to 256 colours.
MiNT or XaAES not move anything back.

Sysinfo (sinf502e) -> https://sites.google.com/site/stnonesse ... edirects=0
Thankyou frank. I will look at that SYSinfo.. I assume you sent it because it will tell me what colour depth I am running.

Cool. SO I am still having issues with NVDI and NOVA drivers. This is nothing I can find in any threads or manual, but it might be the way it works and I am missing something. in my Xboot I have NVDI booting with the Nova drivers.. they can be before, but seem to run again after. the xboot or something else is renaming nvdi.prg to nvdi.pr I have seen xboot rename things prx.. but not just removing the last letter.

SO the issue is.. I do not seem to have gdos, nvdi running? I dont get fonts etc.. QED sees no GDOS printer.. SO I need to understand what I am doing wrong in my drivers .. do I do output to NOVA and GDOS? NOVA without GDOS (which is what I am doing now) IF I change it to NOVA with.. it crashes the screen.

I am sorry if this seems basic to most, but I am missing something here and could really use some help figuring out what I am doing wrong.

James
stormy
Atari God
Atari God
Posts: 1048
Joined: Tue Jan 26, 2016 12:39 pm

Re: new Nova drivers

Post by stormy »

James in the NOVA menu there is an option that says 'GDOS' and you type NVDI.PRG and then save. This is what I do. I always run NVDI *after* Nova VDI. Mint will automatically boot to whatever res you set in the Nova menu.
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 488
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

frank.lukas wrote: Mon Mar 01, 2021 7:58 am Video mode select is system video and Atari Falcon only I think. It has nothing to do with nova driver ...
  • ## video mode select
    # -----------------
    #
    # Selects the video mode that XaAES will boot into. If not set mode = 1
    # will be used, e.g. use current/default video mode.
    #
Thats the way I read it as well frank, though of course I was not sure if falcon also ment TT.. but I assumed as it says that it should use current mode.

which for my mach32 2mb is 1024x768x32k - but in miNT (sparemint full unix) I am only getting 256 colour as far as I can tell.

James
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 488
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

stormy wrote: Mon Mar 01, 2021 2:06 pm James in the NOVA menu there is an option that says 'GDOS' and you type NVDI.PRG and then save. This is what I do. I always run NVDI *after* Nova VDI. Mint will automatically boot to whatever res you set in the Nova menu.
Yes I have it set to GDOS name nvdi.prg and I have it running after EMU and VDI_STA once on the desktop if I look at the AUTO folder NVDI.pr is sitting there.. Is this unique for me? I can do pictures or a video if anyone is interested?

James
stormy
Atari God
Atari God
Posts: 1048
Joined: Tue Jan 26, 2016 12:39 pm

Re: new Nova drivers

Post by stormy »

Perhaps you could temporarily rename xboot.prg to xboot.prx, just to make sure it isn't doing anything strange. Then rename nvdi.pr to nvdi.prg. Then reboot and see what happens.
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 2120
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: new Nova drivers

Post by frank.lukas »

Bikerbob wrote: Mon Mar 01, 2021 2:07 pm ... but in miNT (sparemint full unix) I am only getting 256 colour as far as I can tell.
That is not right. The Color CPX can only display 256 Colors but there are more. Sysinfo tell you the color depth.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
joska
Hardware Guru
Hardware Guru
Posts: 5068
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: new Nova drivers

Post by joska »

frank.lukas wrote: Mon Mar 01, 2021 7:58 am Video mode select is system video and Atari Falcon only I think.
It supports all original Atari video (ST, TT, Falcon). If you use a graphics card you must *not* have a "video"-setting in xaaes.cnf.
Jo Even

VanillaMiNT - Falcon060 - Milan060 - Falcon040 - MIST - Mega STE - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 488
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

Thanks for the input. Not figured out why nvdi is not working but I think I will make an auto folder with just what I need for mint no xboot. See what happens

James
User avatar
Idek Tramielski
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 126
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

new drivers (untested!)

- STGA_ET4000T3_V301
- Mega4000_ET4000T3_V301

feedback welcome so that I can drop the 'untested' status.
retired - so long, and thanks for all the fish
User avatar
dhedberg
Atari God
Atari God
Posts: 1316
Joined: Mon Aug 30, 2010 8:36 am
Contact:

Re: new Nova drivers

Post by dhedberg »

Idek Tramielski wrote: Tue Oct 05, 2021 3:00 pm new drivers (untested!)

- STGA_ET4000T3_V301
- Mega4000_ET4000T3_V301

feedback welcome so that I can drop the 'untested' status.
So glad to see that you're still spending time developing the drivers Wolfgang! I'd have tested them right away if I'd only had the hardware needed. Hopefully somebody with the proper hardware will step in and help out!
Daniel, New Beat - http://newbeat.atari.org.
Like demos? Have a look at our new Falcon030 demo It's that time of the year again, or click here to feel the JOY.
User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1812
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: new Nova drivers

Post by TheNameOfTheGame »

Yes, thanks Idek. I hope someone can test these. I would but I don't have the device they are targeted to.
User avatar
leech
Atari God
Atari God
Posts: 1380
Joined: Tue Dec 01, 2015 3:26 pm

Re: new Nova drivers

Post by leech »

I would test, but my desk is currently covered in TT030, Amiga 4000 and other parts. I'll see if I can sort that out this weekend and give them a shot.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)
User avatar
Idek Tramielski
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 126
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

No rush...it would just be nice to be able to drop the untested at some point
retired - so long, and thanks for all the fish
Rustynutt
Atari God
Atari God
Posts: 1386
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon

Re: new Nova drivers

Post by Rustynutt »

Thank you :)
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 2120
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: new Nova drivers

Post by frank.lukas »

Idek Tramielski wrote: Tue Oct 05, 2021 3:00 pm new drivers (untested!)

- STGA_ET4000T3_V301
- Mega4000_ET4000T3_V301

feedback welcome so that I can drop the 'untested' status.
I can not do tests because I have not a Mega4000 Adapter and no T3 ET4000 card. I have left only T0 and T8 cards ...
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
User avatar
Idek Tramielski
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 126
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

Update: I was able to test the STGA driver myself.

- STGA_ET4000T3_V301 - tested
- Mega4000_ET4000T3_V301 - still untested
retired - so long, and thanks for all the fish
User avatar
Idek Tramielski
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 126
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

Update: I found an unpopulated Mega4000 pcb that Frank (thanks @frank.lukas) gave me years ago and populated it (very painful process!). This enabled me to test the Mega4000T3 driver myself.
Mega4000s.jpg
- STGA_ET4000T3_V301 - tested
- Mega4000_ET4000T3_V301 - tested
You do not have the required permissions to view the files attached to this post.
retired - so long, and thanks for all the fish
User avatar
dhedberg
Atari God
Atari God
Posts: 1316
Joined: Mon Aug 30, 2010 8:36 am
Contact:

Re: new Nova drivers

Post by dhedberg »

Idek Tramielski wrote: Thu Oct 07, 2021 1:36 pm Update: I found an unpopulated Mega4000 pcb that Frank (thanks @frank.lukas) gave me years ago and populated it (very painful process!). This enabled me to test the Mega4000T3 driver myself.
Wow, yes, that does indeed sound painful! :-)
Daniel, New Beat - http://newbeat.atari.org.
Like demos? Have a look at our new Falcon030 demo It's that time of the year again, or click here to feel the JOY.
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 488
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

Thanks so much Idek, I echo others in saying glad you found it hard to walk away from tinkering with the Atari stuff! ;)

James
User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1812
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: new Nova drivers

Post by TheNameOfTheGame »

Yes, nice work Idek. I'm looking at that large QFP chip on that pcb and thinking pain haha.
Post Reply

Return to “News & Announcements”