new Nova drivers

Latest news in the Atari world

Moderators: Mug UK, Silver Surfer, Moderator Team

User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 403
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

These are the NOVA drivers .. see the beginning of the thread. Idek Tramielski is the author.

James
fenarinarsa
Atari freak
Atari freak
Posts: 55
Joined: Sat Mar 15, 2014 11:23 pm

Re: new Nova drivers

Post by fenarinarsa »

Bikerbob wrote:These are the NOVA drivers .. see the beginning of the thread. Idek Tramielski is the author.
Oh, okay, I thought that they were old drivers that Idek recently rebuilt. My bad. There is not a lot of information on the website, it's actually quite hard to find out who's doing what :)
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1960
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: new Nova drivers

Post by frank.lukas »

Bikerbob wrote:I appreciate your help frank, but I have been doing that.. If NVDI runs.. I get no resolutions that were set in the drivers.. depending on which one I pick.. I might get 640 x 480 x 2 or some messed up one.. x 2 but none with colour.

I can post a video if that will help. It is running just as you said.. option a - no gdos program in xmenu.

James

Delete your c:\gemsys folder and run a new install from NVDI5 with the option NOVA ...
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 403
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

Ahhh ok .. I think your on to something there frank, when I did the reinstall last time I installed over.. I did not delete the gemsys folder.
Will try today.

James
User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 403
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: new Nova drivers

Post by Bikerbob »

So, I just deleted c:\gemsys, and that did not fix it, I was getting frustrated, so I backed up the C: drive and started again.

Copied over the nova pkg, only - ran that .. worked. Installed NVDI 5 only setup as per frank - no gdos device or name.. just NOVA in menu. Runs perferct.

So something was messing. I will now add xboot. Possability it was the running order? no idea.

Thanks Frank, it really does not take that much time as this point in getting things working to try again from scratch, so I will have to remember that is a great way to test things.

James
dimfil
Atari maniac
Atari maniac
Posts: 82
Joined: Sat Feb 11, 2017 7:48 am
Location: Athens, Greece

Re: new Nova drivers

Post by dimfil »

Bikerbob wrote:So, I just deleted c:\gemsys, and that did not fix it, I was getting frustrated, so I backed up the C: drive and started again.

Copied over the nova pkg, only - ran that .. worked. Installed NVDI 5 only setup as per frank - no gdos device or name.. just NOVA in menu. Runs perferct.

So something was messing. I will now add xboot. Possability it was the running order? no idea.

Thanks Frank, it really does not take that much time as this point in getting things working to try again from scratch, so I will have to remember that is a great way to test things.

James
I am happy finally it worked for you!
And, yes, xboot would help a lot at first place. At the moment it's the very first utility I install every time I prepare a disk!
User avatar
Idek Tramielski
Atari maniac
Atari maniac
Posts: 88
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

Atarieterno wrote:Well, if someone translates that German utility, please share it here.
Hi,

I created the english version. You can find it on my server.

Idek
Last edited by Idek Tramielski on Mon Nov 05, 2018 4:51 pm, edited 1 time in total.
User avatar
Idek Tramielski
Atari maniac
Atari maniac
Posts: 88
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

Idek Tramielski wrote:
Atarieterno wrote:Well, if someone translates that German utility, please share it here.
Hi,

I created the English version. You can find it on my server.

Idek
Last edited by Idek Tramielski on Mon Nov 05, 2018 4:51 pm, edited 1 time in total.
dimfil
Atari maniac
Atari maniac
Posts: 82
Joined: Sat Feb 11, 2017 7:48 am
Location: Athens, Greece

Re: new Nova drivers

Post by dimfil »

Idek Tramielski wrote:
Atarieterno wrote:Well, if someone translates that German utility, please share it here.
Hi,

I created the english version. You can find it on my server.

Idek
Great!
It is always better to have a version from a person who knows exactly what every term means!
Thank you for your work!

May I suggest that you prepare a small text for us to use as a starting point in creating resolutions. Especially how the horizontal and vertical display settings should be used.
User avatar
Idek Tramielski
Atari maniac
Atari maniac
Posts: 88
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

dimfil wrote:
Idek Tramielski wrote:
Atarieterno wrote:Well, if someone translates that German utility, please share it here.
Hi,

I created the english version. You can find it on my server.

Idek
Great!
It is always better to have a version from a person who knows exactly what every term means!
Thank you for your work!

May I suggest that you prepare a small text for us to use as a starting point in creating resolutions. Especially how the horizontal and vertical display settings should be used.
Well, it is a quick-and-dirty version. Keep me posted if you find mistakes.

About the manual: My time is very limited, I hardly find time to use my ATARI stuff. Maybe somebody else (Frank?) wants to do this?
You could also start checking out the following links:
http://wiki.osdev.org/Video_Signals_And_Timing
https://www.xfree86.org/3.3.6/fbdev6.html
http://martin.hinner.info/vga/timing.html
Last edited by Idek Tramielski on Mon Nov 05, 2018 4:50 pm, edited 1 time in total.
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1960
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: new Nova drivers

Post by frank.lukas »

There are the german manual for the Nova Graphiccards -> http://www.dev-docs.org/docs/files/Nova ... s_Card.pdf

May be someone translate it to english. In the mean time use the google translator ...

Video timings -> http://tinyvga.com/vga-timing
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
dimfil
Atari maniac
Atari maniac
Posts: 82
Joined: Sat Feb 11, 2017 7:48 am
Location: Athens, Greece

Re: new Nova drivers

Post by dimfil »

frank.lukas wrote:There are the german manual for the Nova Graphiccards -> http://www.dev-docs.org/docs/files/Nova ... s_Card.pdf

May be someone translate it to english. In the mean time use the google translator ...

Video timings -> http://tinyvga.com/vga-timing
I know about this manual. Actually, this is what I used to understand a little better how things work.

I was talking about a relative small text like a guide about how each option affects the result and maybe some "rules" that someone should follow.

Of course everyone understands that your time is little and precious. But if sometime you would be able to do it, that would be of great help for all of us who have your adapter and use Idek's drivers!
tuxie
Atari freak
Atari freak
Posts: 60
Joined: Wed Mar 07, 2007 3:39 pm

Re: new Nova drivers

Post by tuxie »

Bikerbob wrote:So, I just deleted c:\gemsys, and that did not fix it, I was getting frustrated, so I backed up the C: drive and started again.

Copied over the nova pkg, only - ran that .. worked. Installed NVDI 5 only setup as per frank - no gdos device or name.. just NOVA in menu. Runs perferct.

So something was messing. I will now add xboot. Possability it was the running order? no idea.

Thanks Frank, it really does not take that much time as this point in getting things working to try again from scratch, so I will have to remember that is a great way to test things.

James
You have to delete the assign.sys in the root of your Bootdrive, this is a Textfile where the configuration for nvdi is set. You dont need to delete the gemsys folder... the problem is, you have to disable the Graphicsdriver inside assign.sys because nova brings there own driver. (STA_VDI)
User avatar
Idek Tramielski
Atari maniac
Atari maniac
Posts: 88
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

corrected version of MENU.PRG on server.
- reduced size
- some spelling
Last edited by Idek Tramielski on Mon Nov 05, 2018 4:50 pm, edited 1 time in total.
piotrk
Atari nerd
Atari nerd
Posts: 46
Joined: Sat Dec 09, 2017 10:59 am

Re: new Nova drivers

Post by piotrk »

Hi @Idek !

How to totally disable screensaver in this driver?

I've checked that screen saver is enabled by default. Inside TOS I can press any key and back to the screen. In Cubase I think that screen saver blanks the screen after few minutes and I could not back to the display anymore.

Best,
Peter
User avatar
Idek Tramielski
Atari maniac
Atari maniac
Posts: 88
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

rename to STA_VDI.INF and place in AUTO
You can change the settings within the file
You do not have the required permissions to view the files attached to this post.
piotrk
Atari nerd
Atari nerd
Posts: 46
Joined: Sat Dec 09, 2017 10:59 am

Re: new Nova drivers

Post by piotrk »

Hi @idek!

I've tried. After 2-3 minutes screen saver blank screen in TOS. Display can be turned on by mouse or the key, but this behavior doesn't work under Cubase. Is possible in the next driver release add the option to completely disable screen saver ?

I'm using:
NOVA-VDI Version 2.67 68000/10 resident installiert *MHG*
MSTE/M32 compiled by Idek 2017/02/15
(129432 bytes)
User avatar
Idek Tramielski
Atari maniac
Atari maniac
Posts: 88
Joined: Thu Oct 25, 2007 6:25 pm

Re: new Nova drivers

Post by Idek Tramielski »

piotrk wrote:Hi @idek!

I've tried. After 2-3 minutes screen saver blank screen in TOS. Display can be turned on by mouse or the key, but this behavior doesn't work under Cubase. Is possible in the next driver release add the option to completely disable screen saver ?

I'm using:
NOVA-VDI Version 2.67 68000/10 resident installiert *MHG*
MSTE/M32 compiled by Idek 2017/02/15
(129432 bytes)
Did you try changing the STA_VDI.INF file to SLEEP = OFF ?
I could create a special version, but I am not sure it is necessary.
piotrk
Atari nerd
Atari nerd
Posts: 46
Joined: Sat Dec 09, 2017 10:59 am

Re: new Nova drivers

Post by piotrk »

OK, I'll try with SLEEP=OFF...
piotrk
Atari nerd
Atari nerd
Posts: 46
Joined: Sat Dec 09, 2017 10:59 am

Re: new Nova drivers

Post by piotrk »

Doesn't work. Well.. I think that this option is important. Some users want to use Atari with music software and Cubase is important one. I've seen that other thinks works. I also tried to set active corner for "not sleeping" but is it crazy to every time when you are not active move the cursor to that corner.
piotrk
Atari nerd
Atari nerd
Posts: 46
Joined: Sat Dec 09, 2017 10:59 am

Re: new Nova drivers

Post by piotrk »

@Idek Tramielski

IM_COL.ACC solved the problem. Even works perfectly on my ATI Mach 32:
http://www.mediafire.com/file/ngqexb3dd ... IM_COL.ACC

There is option inside to disable screensaver. Cubase now works like a charm.
piotrk
Atari nerd
Atari nerd
Posts: 46
Joined: Sat Dec 09, 2017 10:59 am

Re: new Nova drivers

Post by piotrk »

Update...

IM_COL.ACC works, but also STA_VDI.INF is necessary. It should contains "SLEEP = OFF" to disable active screen corners that could enable screen server. If corner disable screen during working Cubase there is no exit until reboot.
User avatar
edingacic
Captain Atari
Captain Atari
Posts: 262
Joined: Mon Sep 07, 2015 5:16 pm
Location: Austria
Contact:

Re: new Nova drivers

Post by edingacic »

wow nice Piotrk... so what resolutions did you test with the ATI Mach 32 card? Did you try Cubase Score 2.0 r7? Would love to see some pictures & video! Thanks! time to hunt for ATI Mach card...do you think 64 version would work also? What card exactly do you have version?
mikro
Hardware Guru
Hardware Guru
Posts: 2233
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: new Nova drivers

Post by mikro »

wongck wrote:My current site is here. Contents for the Nova are the same.
FYI, the two links provided there are pointing to the same place: https://sites.google.com/site/probehous ... edirects=0 (I guess vme8 should point somewhere else?)
User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12943
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: new Nova drivers

Post by wongck »

mikro wrote: FYI, the two links provided there are pointing to the same place: https://sites.google.com/site/probehous ... edirects=0 (I guess vme8 should point somewhere else?)
Thanks Mikro, Fixed.
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list
Post Reply

Return to “News & Announcements”