Problem with SCSI adapter 68/ 50 pins

Hardware, coding, music, graphic and various applications

Moderators: Mug UK, [ProToS], lp, moondog/.tSCc., Moderator Team

Post Reply
User avatar
Kroll
Atari Super Hero
Atari Super Hero
Posts: 535
Joined: Fri Mar 09, 2012 10:07 am

Problem with SCSI adapter 68/ 50 pins

Post by Kroll »

Recently I bought a SCSI adapter from 68 to 50 pins to connect a SCSI 68 Pin disk to a 50 Pin ribbon cable and connect it to Atari TT, Hades or Falcon. This is the adapter

https://www.ebay.co.uk/itm/SCSI-68Pin-6 ... SwkFZcIFce

Unfortunately, I use another similar adapter (but not the same, all is built in plastic) and the disk is visible, but only after changing the adapter with the same hardware configuration, the disk is completely invisible.

I bought two items and they both behave the same. is it true that not all SCSI adapters will work properly, it's probably just a passive adapter.
Has anyone encountered such a problem?

Does anyone have any idea what to do. Are there different types of adapters?
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1944
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Problem with SCSI adapter 68/ 50 pins

Post by frank.lukas »

Buy from partsdata.de ...

Unused 8bit from the 16bit terminated or complete terminated
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
smisekm
Atarian
Atarian
Posts: 4
Joined: Wed Feb 12, 2014 11:45 am

Re: Problem with SCSI adapter 68/ 50 pins

Post by smisekm »

this works correctly in my TT:
http://krup.cz/?cls=stoitem&stiid=1092
Post Reply

Return to “Professionals”