Compo software dual tos 1.62 / 2.06 rom images - where to find?

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

tzok
Captain Atari
Captain Atari
Posts: 252
Joined: Fri Jun 30, 2017 7:22 pm
Location: Bielsko-Biala, PL
Contact:

Re: Compo software dual tos 1.62 / 2.06 rom images - where to find?

Post by tzok »

...but why are you doing this? Just combine both even and bots odd files from the command line, like it was written. Or you may use my program (CartMan) to do that. Where is the problem?

Ehhh... here you have it:
You do not have the required permissions to view the files attached to this post.
siriushardware
Atari Super Hero
Atari Super Hero
Posts: 552
Joined: Thu Aug 21, 2014 7:55 pm
Location: UK

Re: Compo software dual tos 1.62 / 2.06 rom images - where to find?

Post by siriushardware »

OK, that 'Move Data' tool is what you need.

Load in the TOS 2.06 code

Go into 'Move Data (A to B) and specify
A address = 00000
B address = 20000
Size = 20000

Click on 'Move A to B' button below the A address / B address / size boxes. This copies the code at 00000-1FFFF to 20000-3FFFF.

Load in the TOS 1.62 code, which will overwrite the low copy of the TOS 2.06 code leaving the high copy at 20000-3FFFF.

At this point the buffer has TOS 1.62 code in the low half and TOS2.06 code in the high half.

Program the EPROM.

See how you get on with that.

Edit: Or use the combined TOS images which tzok appears to have provided while I was writing this...
siriushardware
Atari Super Hero
Atari Super Hero
Posts: 552
Joined: Thu Aug 21, 2014 7:55 pm
Location: UK

Re: Compo software dual tos 1.62 / 2.06 rom images - where to find?

Post by siriushardware »

Just one thing, tzok, you've called those images 'high' and 'low'. Should that be 'Odd' and 'Even'?
tzok
Captain Atari
Captain Atari
Posts: 252
Joined: Fri Jun 30, 2017 7:22 pm
Location: Bielsko-Biala, PL
Contact:

Re: Compo software dual tos 1.62 / 2.06 rom images - where to find?

Post by tzok »

Yes, but I don't remember which is which. If it won't boot, just swap the chips... but the silkscreen on the STe board says HI/LO and I guess I have named the files according to that.

Hi/Lo are more Intel, while O/E is more Motorola naming convention. But what is hi-byte for Intel is a lo-byte for Motorola...
Chandler
Atari God
Atari God
Posts: 1415
Joined: Tue Feb 14, 2006 12:15 am

Re: Compo software dual tos 1.62 / 2.06 rom images - where to find?

Post by Chandler »

OK well i followed exactly as said by Siriushardware but sadly it didn't work fully, the TOS 1.62 worked but not 2.06, just a black screen on high res or white screen on TV with the TOS 2.06 switch flipped

However!

I downloaded the files provided by tzok and copied them to a pair of roms and it works again!

So great! it's all back to working again now :0)

So a big thankyou for siriushardware for your help and patience and tzok for making it all so easy! and everyone else who helped :0)
siriushardware
Atari Super Hero
Atari Super Hero
Posts: 552
Joined: Thu Aug 21, 2014 7:55 pm
Location: UK

Re: Compo software dual tos 1.62 / 2.06 rom images - where to find?

Post by siriushardware »

Hmm, not sure what went wrong there - I admit I took the suggested offsets etc from information you supplied earlier in the thread, so maybe there was something out of whack there. I have only done this myself with a six-chip TOS where each chip contains smaller pieces of TOS so of course the offsets are different - no matter as tzok very kindly came to your rescue, glad you have it working.
Post Reply

Return to “Hardware”