Mega STE Mobo repair - small fault with cartridge port

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

Post Reply
Chandler
Atari God
Atari God
Posts: 1397
Joined: Tue Feb 14, 2006 12:15 am

Mega STE Mobo repair - small fault with cartridge port

Post by Chandler »

The last mega ste for now. Almost there!

It now works to desktop but when I insert the test cart (original Atari type)

It hangs just before it goes to the menu and makes a constant tone

The F1 fuse is new for the cartridge port

Here is a screen shot of the error

Any ideas what it could be?

Image
User avatar
Timnaber
Atari maniac
Atari maniac
Posts: 88
Joined: Fri Sep 21, 2018 3:12 pm

Re: Mega STE Mobo repair - small fault with cartridge port

Post by Timnaber »

First clean the port and cart using at least 91% isopropyl alcohol, 99% is better (and do not get any on you). Test.

Next, open it up and re-seat all removeable chips. Test.

Beyond that I have no technical expertise, but those two things should be always be done first.
ST: TT030 10/32m; Falcon 030 14m(2); MSTe 4m; MST 4m(3); MST 4m AdSpeed; 1040STf 4m(4); ST 4m(2); MF 44 w/SCSI2SD(3); MF 30(3); MF30 w/Drem

8-Bit: 320XE w/Ultraspeed+/FIXXL; 320XE; 130XE w/Ultimate 1m; 600XL w/Ultimate 1m; 800XL w/Omnimon XL/Boss XL/Omniview XL; 800 w/Incognito; 800 48K; Black Box Enhanced(3); 1050 Super Archiver II; 1050 Happy(2); XF551 360K(2); XF551 720K; HD Tower 480m
susher
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 128
Joined: Sat Oct 03, 2015 7:06 pm

Re: Mega STE Mobo repair - small fault with cartridge port

Post by susher »

For cleaning the contacts without damaging them or pushing them too far apart I find printer paper folded twice to be about the correct thickness. Soaking this in a bit of IPA (not ale :-) ) and gently and repeatedly pushing the flat paper edge into the slot will gently wear off any oxidation without wearing down the metal.

This is how I cleaned my TT's cartridge port.
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

I have the same fault and no idea what it could be ...
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
Chandler
Atari God
Atari God
Posts: 1397
Joined: Tue Feb 14, 2006 12:15 am

Re: Mega STE Mobo repair - small fault with cartridge port

Post by Chandler »

Thanks guys

Yes I've already done the obvious cleaning

Cart and Cart port is fine with no corrossion

Cartridge works ok on the other mobos

Seen this issue one time before but no idea what it could be..
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

Please check all Data and Address lines plus /LDS, /UDS, ROM3 and ROM4 at the cartridge port ...
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

on my motherboard was a battery leaked I think and some tracks and vias are faulty. /LDS was no longer connected to the romport but this was not the problem.
nullmodem3.png
You do not have the required permissions to view the files attached to this post.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

... no one any idea what the problem could be?
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
Chandler
Atari God
Atari God
Posts: 1397
Joined: Tue Feb 14, 2006 12:15 am

Re: Mega STE Mobo repair - small fault with cartridge port

Post by Chandler »

Well i've traced every track by sight and can see no breaks

This is the 3rd time i have seen this problem so it cannot be chance, there must be a reason why like a failed part
czietz
Hardware Guru
Hardware Guru
Posts: 1246
Joined: Tue May 24, 2016 6:47 pm

Re: Mega STE Mobo repair - small fault with cartridge port

Post by czietz »

Note, though, that Frank's and Chandler's MegaSTEs hang at different points. Chandler's stops at "Testing MFP, Glue timing, Video" which is the step after "Checking Bus error handing". Frank's doesn't get to "Testing MFP, Glue timing, Video". So you're probably seeing two unrelated errors.
Chandler
Atari God
Atari God
Posts: 1397
Joined: Tue Feb 14, 2006 12:15 am

Re: Mega STE Mobo repair - small fault with cartridge port

Post by Chandler »

Repaired! Traced some tracks to chips U4 and U5 (bottom left far corner) and changed them both and now the test cartridge works ok! :0)

Still 1 problem though, now i can test the board with the test cartridge i have found that the midi ports don't work!
Chandler
Atari God
Atari God
Posts: 1397
Joined: Tue Feb 14, 2006 12:15 am

Re: Mega STE Mobo repair - small fault with cartridge port

Post by Chandler »

Have changed U303, U302 and U301 as per repair manual but still no midi
User avatar
saulot
Captain Atari
Captain Atari
Posts: 228
Joined: Sat Sep 18, 2004 9:09 pm
Location: Warszawa
Contact:

Re: Mega STE Mobo repair - small fault with cartridge port

Post by saulot »

Chandler wrote:Have changed U303, U302 and U301 as per repair manual but still no midi
Hey, do you have repair manual for mste? I would be interested in scan. I have still unresolved cache hang issues.

Regards,
PG
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

saulot wrote:
Chandler wrote:unresolved cache hang issues.
I had also hangs when I switch the cache on. I replace U008 and U009 and it works again.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
User avatar
Arne
Atari Super Hero
Atari Super Hero
Posts: 648
Joined: Thu Nov 01, 2007 10:01 am

Re: Mega STE Mobo repair - small fault with cartridge port

Post by Arne »

saulot wrote:Hey, do you have repair manual for mste?
The original Atari manuals are called "Service manual". You may download them from my HP.
Image
User avatar
saulot
Captain Atari
Captain Atari
Posts: 228
Joined: Sat Sep 18, 2004 9:09 pm
Location: Warszawa
Contact:

Re: Mega STE Mobo repair - small fault with cartridge port

Post by saulot »

I thought there was something else, so I've seen it(,but not sure which revision).. thanks.
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

My screen are the same as the one from chandler. Over nullmodem there are missing the "Testing MFP, Glue timing, Video" message.

I swap U004 and U005 for new ones but the fault are the same.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

What the error message mean ?
test_cartridge11.jpg
You do not have the required permissions to view the files attached to this post.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
Chandler
Atari God
Atari God
Posts: 1397
Joined: Tue Feb 14, 2006 12:15 am

Re: Mega STE Mobo repair - small fault with cartridge port

Post by Chandler »

Look at the mega ste service manual and those codes are in there

https://www.google.co.uk/url?sa=t&sourc ... 7WvKOV8XoP
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

EB = Bus error. Generated internally by the 68000 or externally by GSTMCU. Usually caused by device not responding. Displays the address of the device being accessed.

E9 = Bad Instruction Fetch.


EB what device is not reponding? 01FFFC PC: FA3760

What E9 error mean?
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
czietz
Hardware Guru
Hardware Guru
Posts: 1246
Joined: Tue May 24, 2016 6:47 pm

Re: Mega STE Mobo repair - small fault with cartridge port

Post by czietz »

frank.lukas wrote: E9 = Bad Instruction Fetch.
What E9 error mean?
Just another name for an "Illegal instruction" exception. Means that the CPU attempted to execute something that was not an instruction. Can have a lot of different reasons, too many to list them.
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

More than 20 loops with GemBench6. I think the Board is stable. I can run programs from Floppy or Harddisk.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
Chandler
Atari God
Atari God
Posts: 1397
Joined: Tue Feb 14, 2006 12:15 am

Re: Mega STE Mobo repair - small fault with cartridge port

Post by Chandler »

Have you checked the fuse for the catridge port Frank?
User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1948
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Mega STE Mobo repair - small fault with cartridge port

Post by frank.lukas »

yes
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
Post Reply

Return to “Hardware”