My new, compact Atari -> VGA adapter.

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

Post Reply
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2709
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by spiny »

possibly obvious question, but you don'ty have a hard drive connected do you ? it sounds like something is trying to force low res and crashing when in hi.
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

Sounds like you should have a look at the PSU as well. I'm thinking it reboots due to low power when the drive motor starts spinning.
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
trecool
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 133
Joined: Sat Jun 04, 2016 2:49 pm
Location: Greece

Re: My new, compact Atari -> VGA adapter.

Post by trecool »

spiny wrote:it sounds like something is trying to force low res and crashing when in hi.
Yes, this is what it does.

No hard disk on. Also my psu is recapped and works fine under load.
The floppy drive started making funny noises thats why I hope maybe its just the floppy that failed.
But still, maybe its the controller that gives this strange behavior. I guess I have to check all possible senarios.
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

If this is the case, seems like a really bad code since if one would boot the program with a SM124 connected you'd get the same behaviour.
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
User avatar
leech
Atari God
Atari God
Posts: 1311
Joined: Tue Dec 01, 2015 3:26 pm

Re: My new, compact Atari -> VGA adapter.

Post by leech »

trecool wrote:It's a uk stfm system by the way.
It is too bad it wasn't a uuniversal modulator. Then it would be the STFUM. :p

On a more serious note, I should probably get a working STfm at some point, since mine has some serious video issues.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

Come to think about it.. If you disconnect the drive, there will be no icons on the desktop, right? If so, it might be your drive that failed. With that description of sounds and rebooting..
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
trecool
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 133
Joined: Sat Jun 04, 2016 2:49 pm
Location: Greece

Re: My new, compact Atari -> VGA adapter.

Post by trecool »

I did find my custom made vga cables, both mono and multisync, and i have a crystal bright screen in low and hi res using those cables. It boots in 2 secs I guess thats because no disk drive found. I didn't have the time to unplug it, that will be done tomorrow.
Menus are working, no disk icons but all seems to be ok!
Now, using the adapter, the first thing that i have noticed is some noise on the screen and some very faint jail bars. It boots in hi res and after some seconds it reboots like forever. Also some glitches here and there.
Pressing the push button constantly, it reboots at some point to low res and by that time it keeps on rebooting like before.
User avatar
DarkLord
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4466
Joined: Mon Aug 16, 2004 12:06 pm
Location: Prestonsburg, KY - USA
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by DarkLord »

Usually, if there is no disk drive connected to an ST, TOS searches for
the floppy drive much longer than 2 seconds...
Welcome To DarkForce! http://www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS - Telnet:darkforce-bbs.dyndns.org 520
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

Jailbars, adjust the contrast. Or you could adjust the potentiometers, to get rid of it. I'd say green could be a possible offender from my own testing.

But the rebooting.. That should *not* happen. Checking my notes; could be a bad connection on the ATtiny's pins 4 and/or 8 (GND and +5V). Do you have a soldering iron? If so, could you try and re-flow those pins?

If you'd like I'll send you a new one.
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
User avatar
DarkLord
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4466
Joined: Mon Aug 16, 2004 12:06 pm
Location: Prestonsburg, KY - USA
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by DarkLord »

Ube, there are *many* of us who are waiting for a new one... :) :) :)
Welcome To DarkForce! http://www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS - Telnet:darkforce-bbs.dyndns.org 520
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

DarkLord wrote:Ube, there are *many* of us who are waiting for a new one... :) :) :)
Yepp. And I have *many* of them on my desk as of now. Just missing potentiometers. Been waiting for them for ages now. At least four weeks. They are marked to turn up by Wednesday, was hoping for this week..
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
trecool
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 133
Joined: Sat Jun 04, 2016 2:49 pm
Location: Greece

Re: My new, compact Atari -> VGA adapter.

Post by trecool »

Ok, drive is out and i see no change.
Reflowing the pins gives me some hope, yes I 'll try that!
By the way, my mistake, the delay is more than 2 seconds.
User avatar
DarkLord
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4466
Joined: Mon Aug 16, 2004 12:06 pm
Location: Prestonsburg, KY - USA
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by DarkLord »

ube wrote:
Yepp. And I have *many* of them on my desk as of now. Just missing potentiometers. Been waiting for them for ages now. At least four weeks. They are marked to turn up by Wednesday, was hoping for this week..
Awesome. :)

Figured the reason for the delay was something like that. Keep up the good work. :cheers:
Welcome To DarkForce! http://www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS - Telnet:darkforce-bbs.dyndns.org 520
User avatar
DarkLord
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4466
Joined: Mon Aug 16, 2004 12:06 pm
Location: Prestonsburg, KY - USA
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by DarkLord »

trecool wrote: By the way, my mistake, the delay is more than 2 seconds.
It's actually a lot longer than 2 seconds, more along the lines of
30 seconds or more maybe? Been awhile since I actually timed
one. :)
Welcome To DarkForce! http://www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS - Telnet:darkforce-bbs.dyndns.org 520
trecool
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 133
Joined: Sat Jun 04, 2016 2:49 pm
Location: Greece

Re: My new, compact Atari -> VGA adapter.

Post by trecool »

Success! I re-flowed the pins and now it works.
It takes 5 secs to get to the desktop without floppy connected. I hope that doesn't mean the controller is dead.
joska
Hardware Guru
Hardware Guru
Posts: 4721
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by joska »

DarkLord wrote:It's actually a lot longer than 2 seconds, more along the lines of
30 seconds or more maybe? Been awhile since I actually timed
one. :)
If you have a floppy drive attached but no floppy inserted, booting will take a while. Maybe 30 seconds as you say. However, if there is no floppy drive at all then TOS will boot a lot faster.
Jo Even

VanillaMiNT - Firebee - Falcon060 - Milan060 - Falcon040 - MIST - Mega ST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

trecool wrote:Success! I re-flowed the pins and now it works.
It takes 5 secs to get to the desktop without floppy connected. I hope that doesn't mean the controller is dead.

I'm SOOOOOOOOOO sorry for the inconvenience. Please PM me your address and I'll send you a new WD1772 and a drive.
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
trecool
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 133
Joined: Sat Jun 04, 2016 2:49 pm
Location: Greece

Re: My new, compact Atari -> VGA adapter.

Post by trecool »

No please, it's ok, don't worry about it. I think I have a sony drive around to mod.
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

30+1 shipped to Exxos.

-Plus one? You might say.

There is one v1.1 in the box, with external header for the button. Good for MSTE-owners. Who will get it? Only Exxos’ head of logistics (aka girlfriend) knows. :)
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
User avatar
leech
Atari God
Atari God
Posts: 1311
Joined: Tue Dec 01, 2015 3:26 pm

Re: My new, compact Atari -> VGA adapter.

Post by leech »

What is the button for so it would specifically be good for Mega STe owners? You know what would be a nice edition, a PAL/NTSC switch, though I don't know how feasible that is. Or if it is even needed for VGA output.
Last edited by leech on Mon Oct 09, 2017 9:22 pm, edited 1 time in total.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

Mega computers, the monitor itself is in the way. With the external connector one can place a button on the side of the computer for easier reach.

PAL/NTSC: not feasible. At least not without adding extra hardware. :)
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
User avatar
leech
Atari God
Atari God
Posts: 1311
Joined: Tue Dec 01, 2015 3:26 pm

Re: My new, compact Atari -> VGA adapter.

Post by leech »

ube wrote:Mega computers, the monitor itself is in the way. With the external connector one can place a button on the side of the computer for easier reach.

PAL/NTSC: not feasible. At least not without adding extra hardware. :)
So.. version 1.2? :) Always thought it would have been nice if there had been a standard hardware/keyboard combination you could do to switch these older systems between the standard video format instead of messing around with different boot loaders and such.

On my Amiga 4000D there was a jumper on the motherboard for PAL/NTSC, and probably 70% of the games required me to switch it to PAL, so I left it there, even though I use a scan doubler that outputs to proper VGA now.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

To switch NTSC/PAL it's probably easier adding some switch to the motherboard; on STEs it's R405 and R459 that needs to be disconnected for PAL.
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
User avatar
leech
Atari God
Atari God
Posts: 1311
Joined: Tue Dec 01, 2015 3:26 pm

Re: My new, compact Atari -> VGA adapter.

Post by leech »

ube wrote:Ought to. If there’s syncs on the same pins. If it doesn’t, plug it into an ST, set it to low res and hold the button for 3 seconds, it’ll save low res as default at power on.
Finally got the VBXE home safe and sound. Sadly all I get from the Dell 2001FP when I plug it into the VBXE board is 'Can not display this mode'.

Now, for giggles, I plugged this adapter into the 130XE's VBXE port, with a VGA cable to the GBS-8220, then out to my VGA switch box, and to my monitor and I get a screen displayed! But it's dark and grainy. So not sure if the GBS-8220 is doing some more doubling on it, or what the deal is. I kind of thought the VBXE did output RGB at 15khz similar to the ST/Amiga.

Back to the drawing board!
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)
User avatar
ube
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 122
Joined: Mon Jun 10, 2002 10:37 pm
Contact:

Re: My new, compact Atari -> VGA adapter.

Post by ube »

A bit of an announcement.

I’ve decided on stop making my switches, mainly due to the fact that they do take too much of my time; I haven’t opened my DAW to make music for quite some while (mainly because my desk is full of switch components). I will however continue developing, there are some small adjustments/additions I’d like/need to add.

Therefore there will probably be some kits from time to time for sale; I’ve got quite the stock of DIN13s incoming and they seem to be more and more difficult to get a hold of, at least the ones marked “inline”, push connectors are plenty.

And, I’ll probably start a new Atari project or two. When the Swedish cold, long winter sets in.
Atari STE w/ MicroCosmosex | Atari Falcon w/ Skunk| ubeswitch mk1 | ubeswitch mk2 | ubeswitch mk4 | ubeswitch mk5 | ubeswitch mk6 | ubeswitch mk6 v1.1b
Post Reply

Return to “Hardware”