Trouble with BigDOS (+CBHD)

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

Post Reply
User avatar
Awol
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 125
Joined: Sat Feb 16, 2008 6:04 am
Location: USA

Trouble with BigDOS (+CBHD)

Post by Awol »

I have a 32mb SD card and an 8GB SDHC card in my UltraSatan. I am currently able to boot from the 32mb card using CBHD. The trouble comes when I try to add BigDOS. I put BIGDOS.PRG in an AUTO folder on the 32mb card, and my 1040STE just freezes at bootup!

Regarding the 8GB card: I couldn't partition SD cards in Windows XP, so I made an Ubuntu Linux live CD. Using the linux CD, I was able to split the 8GB card into 4x 2GB FAT16 partitions. On the first partition I put CBHD.SYS and an AUTO folder with BIGDOS.PRG inside, but on my Atari I can't get the card to boot or the driver to install properly. When I choose "Install Devices" on the desktop, 4 hard disk icons show up, but I can't open them. Can some kind soul please help me figure out how to get a bootable 8GB card with 4x 2GB BIGDOS partitions running (using CBHD)?

I'm thinking maybe I should just bite the bullet and buy HDDRIVER.
1040STE: 4MB RAM, TOS 2.06
Formerly Grey_and_Purple.
User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 13004
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Trouble with BigDOS (+CBHD)

Post by wongck »

My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list
User avatar
Awol
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 125
Joined: Sat Feb 16, 2008 6:04 am
Location: USA

Re: Trouble with BigDOS (+CBHD)

Post by Awol »

wongck wrote:have you seen this UltraSatan Partitioning & User's Guide
Yes I have! And it's been very helpful, but I'm still having trouble with BigDOS. Just freezes my 1040STE on bootup.
1040STE: 4MB RAM, TOS 2.06
Formerly Grey_and_Purple.
User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 13004
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Trouble with BigDOS (+CBHD)

Post by wongck »

Running it only in AUTO without others?
May be download again in case the binaries are corrupted?
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list
User avatar
Awol
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 125
Joined: Sat Feb 16, 2008 6:04 am
Location: USA

Re: Trouble with BigDOS (+CBHD)

Post by Awol »

wongck wrote:Running it only in AUTO without others?
Yes.
wongck wrote:May be download again in case the binaries are corrupted?
Tried this and it didn't help.

When I boot, it loads CBHD, and then starts loading BigDOS. The last line shown on the screen before it freezes says "Hard disk driver has XHDI 01.25, XHDOSL )". Am I supposed to do something at that point? Tried pressing "return" and other keys. Shouldn't it just go straight to the desktop?

Thanks for reading my thread and trying to help by the way! I appreciate it a lot!
1040STE: 4MB RAM, TOS 2.06
Formerly Grey_and_Purple.
User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 13004
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Trouble with BigDOS (+CBHD)

Post by wongck »

Well Awol.
I can only suggest thus far, as I do not own an US.
May be you want to dl the trial HDDriver before purchasing it.
Just to make sure that it works with HDDriver.

I am sure others here will come by to help, may be Jookie will come by. :wink:
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list
User avatar
Awol
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 125
Joined: Sat Feb 16, 2008 6:04 am
Location: USA

Re: Trouble with BigDOS (+CBHD)

Post by Awol »

wongck wrote: May be you want to dl the trial HDDriver before purchasing it.
Just to make sure that it works with HDDriver.
I tried a 32mb card with a single GEM partition on it. I installed the HDDriver demo to it, and was able to boot from it. But as soon as I added an AUTO folder with BIGDOS.PRG inside, I got the freezing problem again. :(
1040STE: 4MB RAM, TOS 2.06
Formerly Grey_and_Purple.
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2709
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: Trouble with BigDOS (+CBHD)

Post by spiny »

I don't know the answer, but bigdos works for me with my 4096 ste, with both satandisk and ultrasatandisk.

this is the version I use:

http://www.spiny.org/atari/files/bigdos08.rar
simbo

Re: Trouble with BigDOS (+CBHD)

Post by simbo »

just and idea :coffe:

i think your maybe using 1mb/512kb 'parity' fastpage simms
you get this freeze issue also with cubase v3.01 both write to a low level driver
so i know from the past there is issues using 1mb simms parity but 3 chip types are the ones with issues
dont know about 512k types
try to use 8chip types 3 chips dont work fully
some people say you can use them yes you can
only the occasional app complains
is the machine just 1mb total ram??? if so check your using 8 chip types
if needed remove two of them leaving the 8 chip types that come with ataris and try again
if your machine was a 512 and had two added then you also get 512 types that are parity
the default type usualy has 8 chips and yellow capacitors soldered to the rear of its chips

usual problem with bigdos is with tos 1.0 it doesnt like it
and also just gives 2 or 4 bombs never had a freeze up
but this is one to check ....
SofiST
Atari Super Hero
Atari Super Hero
Posts: 591
Joined: Tue Apr 28, 2009 12:25 pm

Re: Trouble with BigDOS (+CBHD)

Post by SofiST »

Answers are here: http://ppera.07x.net/atari/ASThdFAQ.html
BigDOS disables partitions under 32MB .
Post Reply

Return to “Hardware”