TOS Switch and OS behaviour

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

Post Reply
User avatar
Arne
Atari Super Hero
Atari Super Hero
Posts: 644
Joined: Thu Nov 01, 2007 10:01 am

TOS Switch and OS behaviour

Post by Arne »

Hi folks,

I've been thinking about a problem lately. Let's say you have a Dual-TOS (e.g. 1.00 and 1.04) option built in your ST.
Now you power on the ST and it boots 1.04. OS code detects that the magic values are invalid and performs a cold boot.
After a while you switch to 1.00 and press the reset button. 1.00 code checks the (now valid) magic values and just performs a warm restart. Now all the undocumented TOS variables that might have changed location become invalid because of just that reason or they haven't changed location in TOS evolution but their values are - at least at that time during boot process - just crap.
I don't know if that makes sense. I do have such an option in a 1040 and it scrambled the floppy disk content a couple of times. But I'm not sure if this FDD thingy might be a hardware problem.

So: is the herein before mentioned reasoning valid or not?

PS: as this is OS relevant I put it in the "Applications" section - not Coding or Hardware.
Image
neanderthal
Captain Atari
Captain Atari
Posts: 164
Joined: Sun Jul 10, 2016 10:58 pm

Re: TOS Switch and OS behaviour

Post by neanderthal »

Interesting point,since the TOS roms were not really designed for 'hotswapping' so to speak.So the code could assume lots of things preset according to itself at a warmboot.
I had this idea about using bootloadable SRAM:s as TOS replacement once for easy testing and such,but never got around to making it.
Was mostly concerned about the hardware bit there but do remember that the soft part of the booting with 'rom' switches was in the back of the mind.
Post Reply

Return to “Applications”