Netsurf

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

PeterS
Captain Atari
Captain Atari
Posts: 324
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Netsurf

Post by PeterS »

Since February there have been no new Netsurf test builds https://ci.netsurf-browser.org/builds/atari/

https://listmaster.pepperfish.net/piper ... 14400.html

This is by far the best browser we have and no doubt a lot of work was put in to making it work on the Atari. I don't know what the issues are in "the toolchain" but it would be fantastic if someone could help them get it working again.
vido
Atari Super Hero
Atari Super Hero
Posts: 719
Joined: Mon Jan 31, 2011 7:39 pm

Re: Netsurf

Post by vido »

I just wanted to post almost the same message.
This is the answer of the NetSurf core team about CI builds:

"At this time, the toolchain doesn't build properly, and nobody has stepped
up to offer a clean way to sort it out. The core team don't have Atari
systems nor any way to ensure correctness, so can't do it alone.

If you know anyone who can offer the assistance needed, then we'll gladly
talk it over on the netsurf-dev list, or on IRC."

Any volunteer? :)
stormy
Atari Super Hero
Atari Super Hero
Posts: 758
Joined: Tue Jan 26, 2016 12:39 pm

Re: Netsurf

Post by stormy »

Sometimes I can be a little too negative ;)
Last edited by stormy on Sat Jun 29, 2019 7:48 pm, edited 1 time in total.
Falcon CT60e 060 - 256mb ram - Phantom bus and DSP accelerated // Atari TT - Thunder and Storm IDE 64mb ram - Lightning VME - USB LAN - ATI Mach64 2mb
Bengy
Atari nerd
Atari nerd
Posts: 49
Joined: Sat Jun 16, 2012 12:07 am

Re: Netsurf

Post by Bengy »

vido wrote:I just wanted to post almost the same message.
This is the answer of the NetSurf core team about CI builds:

"At this time, the toolchain doesn't build properly, and nobody has stepped
up to offer a clean way to sort it out. The core team don't have Atari
systems nor any way to ensure correctness, so can't do it alone.

If you know anyone who can offer the assistance needed, then we'll gladly
talk it over on the netsurf-dev list, or on IRC."

Any volunteer? :)
I would be happy to sponsor an Atari machine for the core team if it would help?
vido
Atari Super Hero
Atari Super Hero
Posts: 719
Joined: Mon Jan 31, 2011 7:39 pm

Re: Netsurf

Post by vido »

Bengy wrote:I would be happy to sponsor an Atari machine for the core team if it would help?
I think it would be better to sponsor Atari machine to Atari developer if he would agree to maintain NetSurf and maybe port/optimize any other software for the Atari comunity. I would contribute too.
Bengy
Atari nerd
Atari nerd
Posts: 49
Joined: Sat Jun 16, 2012 12:07 am

Re: Netsurf

Post by Bengy »

vido wrote:
Bengy wrote:I would be happy to sponsor an Atari machine for the core team if it would help?
I think it would be better to sponsor Atari machine to Atari developer if he would agree to maintain NetSurf and maybe port/optimize any other software for the Atari comunity. I would contribute too.
I'm in...
mikro
Hardware Guru
Hardware Guru
Posts: 2206
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: Netsurf

Post by mikro »

stormy wrote:You won't find any volunteer. There are no young enthusiastic coders in this community, the ones with the skills and knowledge lost their passion 15 years ago. Netsurf also doesn't work unless it's run at 16k+ colours either, making it mostly useless for 90% of the community anyway, so the effort is hardly worth it.
What an optimistic fellow you are, aren't you. ;-)

I have mixed feelings about their dev team and attention to this problem - in February 2017 I asked them what exactly is wrong with "the toolchain", no response. In March 2017 Ole Loots (m0n0) reposted my email to the list again, again no response. I signed off from the list and never looked back again.

To be fair, it is also because I have never used the browser so it was just an academic curiosity whether it isn't something quick I can help with.
ThorstenOtto
Atari God
Atari God
Posts: 1163
Joined: Sun Aug 03, 2014 5:54 pm

Re: Netsurf

Post by ThorstenOtto »

I'm also subscribed to the list, but they also explain it on their site: they don't post much there, most discussion is in their irc channel.

But i also wonder what might be wrong with the tooolchain, AFAIK they still use the same one as several years ago.
stormy
Atari Super Hero
Atari Super Hero
Posts: 758
Joined: Tue Jan 26, 2016 12:39 pm

Re: Netsurf

Post by stormy »

I'm just observant :P
Falcon CT60e 060 - 256mb ram - Phantom bus and DSP accelerated // Atari TT - Thunder and Storm IDE 64mb ram - Lightning VME - USB LAN - ATI Mach64 2mb
fmh
Captain Atari
Captain Atari
Posts: 185
Joined: Sat Apr 19, 2014 1:25 pm
Location: USA
Contact:

Re: Netsurf

Post by fmh »

How about a paid bounty on this? People who want an updated Netsurf can donate to the fund. Then however it is setup that every release or monthly the programmer gets XX Euros/Dollars etc for their effort. Honestly most likely will not be a lot but shows some appreciation for his/her efforts. May pay only for a few Mountain Dews, Coffees, or Beers per month but better than nothing but more importantly gets the community an up to date browser.

I really like Highwire but where Highwire stands to where Netsurf stands is that currently Netsurf is much further along.
Atari Gamer
FireBee
vido
Atari Super Hero
Atari Super Hero
Posts: 719
Joined: Mon Jan 31, 2011 7:39 pm

Re: Netsurf

Post by vido »

fmh wrote:How about a paid bounty on this? People who want an updated Netsurf can donate to the fund. Then however it is setup that every release or monthly the programmer gets XX Euros/Dollars etc for their effort. Honestly most likely will not be a lot but shows some appreciation for his/her efforts. May pay only for a few Mountain Dews, Coffees, or Beers per month but better than nothing but more importantly gets the community an up to date browser.

I really like Highwire but where Highwire stands to where Netsurf stands is that currently Netsurf is much further along.
This is also the way I am thinking. But I am ready to donate but not to take care of the funds. If there is someone to organize that I am in to donate.
Bengy
Atari nerd
Atari nerd
Posts: 49
Joined: Sat Jun 16, 2012 12:07 am

Re: Netsurf

Post by Bengy »

vido wrote:
fmh wrote:How about a paid bounty on this? People who want an updated Netsurf can donate to the fund. Then however it is setup that every release or monthly the programmer gets XX Euros/Dollars etc for their effort. Honestly most likely will not be a lot but shows some appreciation for his/her efforts. May pay only for a few Mountain Dews, Coffees, or Beers per month but better than nothing but more importantly gets the community an up to date browser.

I really like Highwire but where Highwire stands to where Netsurf stands is that currently Netsurf is much further along.
This is also the way I am thinking. But I am ready to donate but not to take care of the funds. If there is someone to organize that I am in to donate.
Same!
PeterS
Captain Atari
Captain Atari
Posts: 324
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: Netsurf

Post by PeterS »

I did have a look at their CI Jenkins builds to see if there were any clues to the issue:

https://ci.netsurf-browser.org/jenkins/job/netsurf/

There is an Atari log from Aug 2018:

https://ci.netsurf-browser.org/jenkins/ ... 34/console
User avatar
LynXX
Atari freak
Atari freak
Posts: 55
Joined: Wed Jul 19, 2017 3:15 am
Location: Bern, Switzerland

Re: Netsurf

Post by LynXX »

Found a bit more info:

https://listmaster.pepperfish.net/piper ... 03886.html (The post mentioned by Mikro I believe) :

Code: Select all

atari - The atari frontend is built for m68k and coldfire variants
         using a variant of the netsurf cross compliation
         toolchain/sdk. No serious updates have been made to this
         toolchain in some time and it has become a burden.

        Unless this is addressed before the next developer weekend the
         frontend will be disabled in the CI and subsequently code
         removed.
Your post Mikro is displayed as base64 (https://listmaster.pepperfish.net/piper ... 03890.html) , not sure why, but perhaps that didn't help getting a response :wink:

And a bug explaining what's wrong with the Atari toolchain: https://bugs.netsurf-browser.org/mantis ... hp?id=2059

I'm currently trying to build the toolchain, if I succeed I'll try to build the latest version of NetSurf. There's also a port of GCC 7 it looks like, perhaps worth trying but I don't know if I have the necessary skills.
User avatar
LynXX
Atari freak
Atari freak
Posts: 55
Joined: Wed Jul 19, 2017 3:15 am
Location: Bern, Switzerland

Re: Netsurf

Post by LynXX »

Actually, it loos like someone fixed the toolchain in Feb 2019: https://ci.netsurf-browser.org/jenkins/ ... tari-mint/ . So perhaps it's just a matter of re-enable the build in their Jenkins.
Bengy
Atari nerd
Atari nerd
Posts: 49
Joined: Sat Jun 16, 2012 12:07 am

Re: Netsurf

Post by Bengy »

LynXX wrote:Found a bit more info:

https://listmaster.pepperfish.net/piper ... 03886.html (The post mentioned by Mikro I believe) :

Code: Select all

atari - The atari frontend is built for m68k and coldfire variants
         using a variant of the netsurf cross compliation
         toolchain/sdk. No serious updates have been made to this
         toolchain in some time and it has become a burden.

        Unless this is addressed before the next developer weekend the
         frontend will be disabled in the CI and subsequently code
         removed.
Your post Mikro is displayed as base64 (https://listmaster.pepperfish.net/piper ... 03890.html) , not sure why, but perhaps that didn't help getting a response :wink:

And a bug explaining what's wrong with the Atari toolchain: https://bugs.netsurf-browser.org/mantis ... hp?id=2059

I'm currently trying to build the toolchain, if I succeed I'll try to build the latest version of NetSurf. There's also a port of GCC 7 it looks like, perhaps worth trying but I don't know if I have the necessary skills.
Awesome, happy to send you a tip :)
mikro
Hardware Guru
Hardware Guru
Posts: 2206
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: Netsurf

Post by mikro »

LynXX wrote:Your post Mikro is displayed as base64 (https://listmaster.pepperfish.net/piper ... 03890.html) , not sure why, but perhaps that didn't help getting a response
... what. Another 'fine' example when someone configures his own mail server instead of using something well established (the same could be said about their CI builds).

I guess the reason can be it was sent as html from my gmail account but that shouldn't lead to this, at least not in the 21st century.

Anyway, thank you for your investigation! It seems that all they need is to send them another email to re-enable the builds (Thorsten?)
ThorstenOtto
Atari God
Atari God
Posts: 1163
Joined: Sun Aug 03, 2014 5:54 pm

Re: Netsurf

Post by ThorstenOtto »

LynXX wrote: There's also a port of GCC 7
That won't fix their toolchain, since they don't use that port. Beside that, the link you mention is a version of gcc that produces elf objects and needs an extra tool to produces a working atari executable, not to mention that you would need all third party libraries, including mintlib, gemlib libm etc, also be available in that format.

I think one of the major problems with their toolchain is that they do not only build their own libraries with a working toolchain, but also rebuild the toolchain itself everytime a build job is started.

PS.: there are other versions of GCC available that don't suffer from problem mentioned above. You can find them here. Included are GCC 7.4, GCC 8.3 and also the rather new version 9.1.1.
PeterS
Captain Atari
Captain Atari
Posts: 324
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: Netsurf

Post by PeterS »

The issue with the various m68k versions sounds similar to some of the things that have been or are being addressed with Mint so maybe it won't be very hard for it to be addressed ?
User avatar
LynXX
Atari freak
Atari freak
Posts: 55
Joined: Wed Jul 19, 2017 3:15 am
Location: Bern, Switzerland

Re: Netsurf

Post by LynXX »

Thanks,
That won't fix their toolchain, since they don't use that port
I meant fixing in the broad sense of the term, if we can't make their toolchain work we could switch to another one. Thanks for the extra links about the alternative versions.

I went to their IRC channel to ask, and indeed someone fixed the toolchain but NetSurf was still not compiling. They have re-enabled it in the CI but there are still compilation issues. They will look into it, or perhaps I will if I can work out how to build it...

In any case that looks promising.
ThorstenOtto
Atari God
Atari God
Posts: 1163
Joined: Sun Aug 03, 2014 5:54 pm

Re: Netsurf

Post by ThorstenOtto »

They will look into it, or perhaps I will if I can work out how to build it..
I did that last year, when they announced to stop support for atari. It took a bit to get through their configuration system for the various platforms, but in the end wasn't that hard. It is also quite well documented. Key to success was to stick to the directory layout (they install the toochain somewhere in /opt IIRC), and to get all the needed libraries (you will find them also on my website, but maybe they switched to newer versions in the meantime).

I think PeterS has also done already something similar.
mikro
Hardware Guru
Hardware Guru
Posts: 2206
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: Netsurf

Post by mikro »

LynXX wrote:They have re-enabled it in the CI but there are still compilation issues.
Actually it seems to be something really trivial (like a missing include):

Code: Select all

ccache /opt/netsurf/m68k-atari-mint/cross/bin/m68k-atari-mint-gcc -W -Wall -Wundef -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wuninitialized -Wno-unused-parameter -Wno-unused-but-set-variable -Wredundant-decls -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -I. -Iinclude -Ibuild/Linux-atari -Ifrontends -Icontent/handlers  -O3 -DWITH_JPEG -UWITH_PDF_EXPORT -ULIBICONV_PLUG  -I/var/lib/jenkins//artifacts-m68k-atari-mint/include   -I/var/lib/jenkins//artifacts-m68k-atari-mint/include   -I/var/lib/jenkins//artifacts-m68k-atari-mint/include   -DUTF8PROC_EXPORTS -I/var/lib/jenkins//artifacts-m68k-atari-mint/include   -DCURL_STATICLIB -I/opt/netsurf/m68k-atari-mint/env/include   -DWITH_CURL -I/opt/netsurf/m68k-atari-mint/env/include   -DWITH_OPENSSL -I/opt/netsurf/m68k-atari-mint/env/include/libpng16   -DWITH_PNG -I/var/lib/jenkins//artifacts-m68k-atari-mint/include/   -DWITH_BMP -I/var/lib/jenkins//artifacts-m68k-atari-mint/include   -DWITH_GIF -I/var/lib/jenkins//artifacts-m68k-atari-mint/include   -DWITH_NSPSL -I/var/lib/jenkins//artifacts-m68k-atari-mint/include   -DWITH_NSLOG -DNETSURF_UA_FORMAT_STRING=\""NetSurf/%d.%d (%s)"\" -DNETSURF_HOMEPAGE=\""about:welcome"\" -DNETSURF_LOG_LEVEL=DEBUG  -DNETSURF_BUILTIN_LOG_FILTER=\"level:WARNING\" -DNETSURF_BUILTIN_VERBOSE_FILTER=\"level:VERBOSE\" -m68020-60 -I/opt/netsurf/m68k-atari-mint/env/include/freetype2 -DWITH_FREETYPE_FONT_DRIVER -DWITH_INTERNAL_FONT_DRIVER -DCARES_STATICLIB -I/opt/netsurf/m68k-atari-mint/env/include   -U__STRICT_ANSI__ -std=c99 -Dsmall -Dnsatari -D_BSD_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200112L -DNSLOG_LEVEL_0x0010=NSLOG_LEVEL_INFO -I/opt/netsurf/m68k-atari-mint/env/include   -DCURL_STATICLIB -I/opt/netsurf/m68k-atari-mint/env/include   -DDUK_OPT_HAVE_CUSTOM_H  -MMD -MT 'build/Linux-atari/deps/content_handlers_javascript_duktape_duktape.d build/Linux-atari/content_handlers_javascript_duktape_duktape.o' -MF build/Linux-atari/deps/content_handlers_javascript_duktape_duktape.d -o build/Linux-atari/content_handlers_javascript_duktape_duktape.o -c content/handlers/javascript/duktape/duktape.c
content/handlers/javascript/duktape/duktape.c: In function 'duk__enc_fastint_tval':
content/handlers/javascript/duktape/duktape.c:35551:34: error: 'ssize_t' undeclared (first use in this function)
content/handlers/javascript/duktape/duktape.c:35551:34: note: each undeclared identifier is reported only once for each function it appears in
content/handlers/javascript/duktape/duktape.c:35551:43: error: expected ')' before 'v'
make: *** [build/Linux-atari/content_handlers_javascript_duktape_duktape.o] Error 1
PeterS
Captain Atari
Captain Atari
Posts: 324
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: Netsurf

Post by PeterS »

ThorstenOtto wrote:
I think PeterS has also done already something similar.
I did try building it on the Milan a few years ago but ran out of steam after installing many components.
PeterS
Captain Atari
Captain Atari
Posts: 324
Joined: Fri Nov 09, 2007 1:53 pm
Location: England, GB

Re: Netsurf

Post by PeterS »

Just a guess, is it missing unistd.h ?
User avatar
LynXX
Atari freak
Atari freak
Posts: 55
Joined: Wed Jul 19, 2017 3:15 am
Location: Bern, Switzerland

Re: Netsurf

Post by LynXX »

Ok, Atari CI builds are working again, but noone was able to test them: https://ci.netsurf-browser.org/builds/atari/

Could someone familiar with NetSurf test it and report there or on #netsurf on Freenode?

Thanks!
Post Reply

Return to “Applications”