Mega STe, UltraSATAN, Fat16 for Linux/ST transfer?

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

Post Reply
User avatar
leech
Atari God
Atari God
Posts: 1322
Joined: Tue Dec 01, 2015 3:26 pm

Mega STe, UltraSATAN, Fat16 for Linux/ST transfer?

Post by leech »

So I know this SHOULD work and be easy, but it's being a pain to me.

I have the UltraSATAN with two 2GB SD Cards (cheapest/smallest, I could find, the 1GB ones are twice the price, what's up with that?). I manged to get the first one split up and set up into 4 partitions, but then Linux can't read it, and I don't want to start over. I ran 'disktype' against it, and it says it's an Atari ST disk, then complains about there being a partition on there that is 1.4TB! Well, whatever it works, and I only need one that I can copy stuff easily to with my Linux system.

Enter the second one, I formatted it into 4 partitions with FAT16. Weird thing is, the ST recognizes the partitions are there, but then when I double click on them until they do nothing.

If I try to go the other way, and format them with HDDRIVER (9.0.9) and use the options for TOS +Windows + Byteswapped, it doesn't show up as being partitioned even. Not even so much as a partition table.

I'm sure it's something I'm doing wrong, but just wanted to say, shouldn't this be fairly straight forward?
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)
redhawk668
Atari User
Atari User
Posts: 41
Joined: Fri Oct 14, 2011 4:04 pm
Contact:

Re: Mega STe, UltraSATAN, Fat16 for Linux/ST transfer?

Post by redhawk668 »

I have 2 sdcards, one 1 GB and a 2 GB. I had the same problems. What I did, I formatted the 2 GB sdcard first in Windows. This gives one partition of 2 GB which the ST can't read, of course. I then used HDDRIVER 9.09 to partition the 2 GB sdcard into 4 partitions with TOS/Windows compatibility. Surprisingly this works like a charm, Windows or Linux should now be able to read the first partition on the sdcard (Windows cannot read more than one partition on sdcard). The only annoying thing is Windows leaves those stupid System Volume Information folders behind, which show up on the ST as garbled names because of the long file names....
Atari ST/E', Mega ST4, Amiga stuff, a newly built Amiga 500++ with TF534, 1200 with 4 GB CF, Blizzard 1220/4. Atari 8 Bit Stuff, a modded 600XL with Ultimate 1 MB and Sophia RGB, 130XE with 320Kb RAM and Sophia RGB and a stock 800XLF. Some Commodore 64's, one modded with JiffyDOS switchless kernal switcher and an Ultimate64. Sinclair ZX Spectrum stuff, some self built clones. That's it, pretty much.
User avatar
leech
Atari God
Atari God
Posts: 1322
Joined: Tue Dec 01, 2015 3:26 pm

Re: Mega STe, UltraSATAN, Fat16 for Linux/ST transfer?

Post by leech »

Hmm, I haven't tested it since I reformatted it in Linux, I'll have to try that. Wow Windows is retarded that it can't read past the first partition on an SDCard, Linux just mounts them up as 4 with no problem, granted that was before I formatted them with hddriver.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)
Post Reply

Return to “Applications”