BUS ERROR when unmounting drives with HDDRIVER

FreeMiNT related questions are answered here.

Moderators: simonsunnyboy, Mug UK, Zorro 2, ThorstenOtto, mikro, Moderator Team

Post Reply
Mgi
Atari User
Atari User
Posts: 40
Joined: Sun Mar 14, 2021 7:15 am
Location: West Sussex

BUS ERROR when unmounting drives with HDDRIVER

Post by Mgi »

Hi,

I just replaced the AHDI 4.0 driver with the latest HDDRIVER 11 and all is fine except when I try to close or reboot Mint it throws an error as on the picture.

Any ideas what and how to fix it? Any config settings in HDDRiver?

Thanks
Michal
image_50547457.JPG
You do not have the required permissions to view the files attached to this post.
stormy
Atari Super Hero
Atari Super Hero
Posts: 958
Joined: Tue Jan 26, 2016 12:39 pm

Re: BUS ERROR when unmounting drives with HDDRIVER

Post by stormy »

Since you bought hd driver & with that you get support, might be worth emailing Uwe.
Falcon CT60e 060 - 256mb ram - Phantom bus and DSP accelerated // Atari TT - Thunder and Storm IDE 64mb ram - Lightning VME - USB LAN - ATI Mach64 2mb
Mgi
Atari User
Atari User
Posts: 40
Joined: Sun Mar 14, 2021 7:15 am
Location: West Sussex

Re: BUS ERROR when unmounting drives with HDDRIVER

Post by Mgi »

Talked to Uwe and he recommended asking here :)
Mgi
Atari User
Atari User
Posts: 40
Joined: Sun Mar 14, 2021 7:15 am
Location: West Sussex

Re: BUS ERROR when unmounting drives with HDDRIVER

Post by Mgi »

I managed to narrow it to the case when USB pen drive is mounted. No issue with normal HDD.
Perdrix24
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 142
Joined: Mon Feb 26, 2018 1:47 pm
Location: Québec, Canada
Contact:

Re: BUS ERROR when unmounting drives with HDDRIVER

Post by Perdrix24 »

I'm trying to understand. HDDRIVER doesn't manage USB pen drives. Are you loading the STORAGE.UDD driver for USB? What's your USB hardware interface? NetUSBee, Lightning?
Galvez
Captain Atari
Captain Atari
Posts: 300
Joined: Fri Oct 19, 2007 7:49 am

Re: BUS ERROR when unmounting drives with HDDRIVER

Post by Galvez »

Probably the bus error is shown only with HDDRIVER because AHDI doesn't support the XHDI protocol, during the shutdown sequence some XHDI calls are done, without XHDI MiNT's handling of drives changes.
Galvez
Captain Atari
Captain Atari
Posts: 300
Joined: Fri Oct 19, 2007 7:49 am

Re: BUS ERROR when unmounting drives with HDDRIVER

Post by Galvez »

Just in case one thing that it should be checked is that kernel_threads initiated by the USB drivers are terminated before the unmounting of file system is done, I don't think so but the code should be traced to see if this produced any issue.
Mgi
Atari User
Atari User
Posts: 40
Joined: Sun Mar 14, 2021 7:15 am
Location: West Sussex

Re: BUS ERROR when unmounting drives with HDDRIVER

Post by Mgi »

Following advise from Stormy on Discord to check the versions of the kernel vs. USB drivers I removed them all and refreshed from the same binaries as the kernel. Looks like I swapped them initially at some point with the ones I received with my Lightning. After refreshing all USB files and loader.prg it now all works well. Big thanks for help.
Post Reply

Return to “FreeMiNT support”