LXDE desktop won't start after linux update

https://github.com/MiSTer-devel/Main_MiSTer/wiki

Moderators: Mug UK, Zorro 2, spiny, Greenious, Sorgelig, Moderator Team

Shamus
Atariator
Atariator
Posts: 29
Joined: Mon Oct 15, 2018 1:55 pm

LXDE desktop won't start after linux update

Post by Shamus »

I just updated linux to the latest version and now LXDE does not start up anymore. All other cores are working just fine.

I'd really love to be able to use LXDE as I do all file transfers for MiSTer via the LXDE desktop. Any ideas?
User avatar
bazza12
Atariator
Atariator
Posts: 29
Joined: Sun Feb 17, 2019 5:45 pm
Location: Yorkshire, England.
Contact:

Re: LXDE desktop won't start after linux update

Post by bazza12 »

I have a similar problem only the 720 setting loads and the desktop is now larger than my screen and no matter what i do i can't get it to reduce in size.. i've altered the settings in mister.ini but nothing changes it.. none of the other resolutions load in at all.. i couldn't figure it out.. even after reinstalling the updates.. still isn't right. i've given up on it.. mind you my mister main menu screen don't fit on my 1360x768 anymore either - the logo in the top left is half missing.. again when i change the video settings.. it does fit but as soon as i then load minimig.. it crashes it.. so i've just left it. hoping a future update will correct it.. :(
Shamus
Atariator
Atariator
Posts: 29
Joined: Mon Oct 15, 2018 1:55 pm

Re: LXDE desktop won't start after linux update

Post by Shamus »

Yes, having LXDE on the MiSTer is a great feature - hope it will come back, soon!
warham
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 135
Joined: Fri Oct 12, 2018 7:17 am

Re: LXDE desktop won't start after linux update

Post by warham »

Is there a tutorial how to setup and run this on mister? Looks like it would be more user friendly than MC
Locutus73
Atari Super Hero
Atari Super Hero
Posts: 579
Joined: Wed Feb 07, 2018 6:13 pm

Re: LXDE desktop won't start after linux update

Post by Locutus73 »

warham wrote:Is there a tutorial how to setup and run this on mister? Looks like it would be more user friendly than MC
https://github.com/MiSTer-devel/Main_Mi ... ktop-Linux

Regards.

Locutus73
jayp76
Atari freak
Atari freak
Posts: 64
Joined: Wed Oct 17, 2018 10:09 am

Re: LXDE desktop won't start after linux update

Post by jayp76 »

Doesn't work for me anymore, either.
boidret
Atarian
Atarian
Posts: 1
Joined: Sat Jul 06, 2019 7:09 pm

Re: LXDE desktop won't start after linux update

Post by boidret »

The same happens to me. Has anyone found a solution?
misterItaly
Atarian
Atarian
Posts: 6
Joined: Sat Jun 29, 2019 3:22 pm

Re: LXDE desktop won't start after linux update

Post by misterItaly »

does not work for me as well.. any news?
Glaurung
Atari freak
Atari freak
Posts: 66
Joined: Sat Mar 30, 2019 6:22 am

Re: LXDE desktop won't start after linux update

Post by Glaurung »

doenst work too
Glaurung
Atari freak
Atari freak
Posts: 66
Joined: Sat Mar 30, 2019 6:22 am

Re: LXDE desktop won't start after linux update

Post by Glaurung »

I have reinstall ans setup LINUX SD and still downst work.
A black screen at boot.

:shrug:
breiztiger
Captain Atari
Captain Atari
Posts: 267
Joined: Sun Sep 20, 2009 6:54 am
Location: FRANCE

Re: LXDE desktop won't start after linux update

Post by breiztiger »

Me too, black screen
desin24
Atariator
Atariator
Posts: 28
Joined: Thu Dec 14, 2017 10:48 pm

Re: LXDE desktop won't start after linux update

Post by desin24 »

something is wrong with the with screen resolution /refresh
linux is booting but ok

Workaround
choose a older core like QL or FXcast first and switch to the LXDE core afterwards
User avatar
Peg4a
Atarian
Atarian
Posts: 9
Joined: Sun Nov 04, 2018 4:17 pm

Re: LXDE desktop won't start after linux update

Post by Peg4a »

Make sure you used the latest sdcard installer to prepare your card and make boot + linux update :P
User avatar
SHIFT838
Atari User
Atari User
Posts: 42
Joined: Tue Mar 15, 2016 9:31 pm
Contact:

Mister with Linux LXDE

Post by SHIFT838 »

I have been trying to get the Linux LXDE to work with my mister device and followed the documentation from the site wit the latest LXDE image and display settings.

However, my Mister when it tries to load my HDMI signal reads no signal detected. I have tried 1080p, 720p, and even 1024x768. Once I saw 2 penguins at the top of the screen but it never booted into it.

Any ideas? I took the archived and extracted it as documented in the root of the sd card and of course the .img file goes in the /linux folder.
Chris Schneider
SHIFT838
http://shift838.99er.net

Live TI-99 CHAT
http://shift838.99er...ex.php#TI-99ers

FuSiON BBS Information:
http://sourceforge.n...ource=directory

Online for Telnet only at:
fusionbbs.ddns.net : Port # 9640
BBond007
Captain Atari
Captain Atari
Posts: 466
Joined: Wed Feb 28, 2018 3:23 am

Re: Mister with Linux LXDE

Post by BBond007 »

There is a work-around posted here. I have not tried it though...

http://www.atari-forum.com/viewtopic.php?f=117&t=36903
desin24
Atariator
Atariator
Posts: 28
Joined: Thu Dec 14, 2017 10:48 pm

Re: LXDE desktop won't start after linux update

Post by desin24 »

works again

but after reboot it goes back to the old behavior

any ideas ?
User avatar
Sinclair
Atari User
Atari User
Posts: 30
Joined: Sun Dec 25, 2016 12:56 pm

Linux LXDE no longer work

Post by Sinclair »

For several updates of MiSTer the LXDE desktop has stopped working.

https://github.com/MiSTer-devel/Main_Mi ... ktop-Linux

There was an update 20180502, but then nothing, it's as if it had been discontinued.

It is a shame that this is lost :( although we hope that everything will be fixed.

Thanks to the Sorgelig and all the developers of this great project that is MiSTer.
© 1982 Sinclair Research Ltd
ziber
Atarian
Atarian
Posts: 4
Joined: Tue Sep 17, 2019 6:23 pm

Re: LXDE desktop won't start after linux update

Post by ziber »

Hello, I'm new on this forum.
I have the same problem with black screen. Linux is booting, framebuffer is working - I can take a valid screenshot of it using fbcat. Bus something is wrong with the FPGA. I would like to take a look at it and try to solve the problem, but I can't find the FPGA code nowhere. Sorgelig, could you please release the code of the FPGA? Thanks.
User avatar
Newsdee
Atari God
Atari God
Posts: 1561
Joined: Fri Sep 19, 2014 8:40 am

Re: LXDE desktop won't start after linux update

Post by Newsdee »

Isn't that the menu core?
ziber
Atarian
Atarian
Posts: 4
Joined: Tue Sep 17, 2019 6:23 pm

Re: LXDE desktop won't start after linux update

Post by ziber »

No, the menu core is FPGA core only, it doesn't instantiate the HPS, Framebuffer and CVO IPs needed by Linux Kernel to output its framebuffer. In the meanwhile I got it to work work with Kernel 5.1 and DE10_NANO_SoC_FB FPGA from Terasic in any resolution up to 1920x1080. But my monitor blinking black sometimes in 1920 resolution. I assume because Terasic have not constrainted HDMI path in their Quartus project. Tomorrow I'll try to compile it with proper constraints.
Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6348
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: LXDE desktop won't start after linux update

Post by Sorgelig »

I need to find the sources.
Generally, FPGA part needs to be redesigned to use open source scaler
ziber
Atarian
Atarian
Posts: 4
Joined: Tue Sep 17, 2019 6:23 pm

Re: LXDE desktop won't start after linux update

Post by ziber »

I have the impression the DE10_NANO_SoC_FB example from Terasic was not supposed to run at 1920x1080@60 32bit. The Frame Reader is connected via 128bit FPGA-to-HPS Interface at 50 MHz, it provides theoretically 800MB/s throughput. 1920x1080@60 32bit resolution needs ~500MB/s. I beleive that is the reason why my monitor is blinking - frame reader doesn't get enough data.
It would be much better to read the data via FPGA-to-HPS SDRAM 256bit Interface at 100 MHz and to use 1920x1080@60 16bit for a better throughput reserve. Sorry for this technical spam, I just want to get my Linux Desktop at 1920x1080@60 working. :roll:
I'll rebuild the soc_system using f2h_sdram to read the framebuffer in the next days...
Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6348
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: LXDE desktop won't start after linux update

Post by Sorgelig »

VIP cannot handle 1920x1080@60 32bit directly. Nothing to do with memory bandwidth (which is enough). VIP needs to use parallel pixel processing mode.
Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6348
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: LXDE desktop won't start after linux update

Post by Sorgelig »

ziber
Atarian
Atarian
Posts: 4
Joined: Tue Sep 17, 2019 6:23 pm

Re: LXDE desktop won't start after linux update

Post by ziber »

Thank you Sorgelig.
Locked

Return to “MiSTer”