Search found 159 matches

by JoeAtari
Wed Dec 26, 2018 1:56 am
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 85656

Re: CTPCI and Realtek 8139D

For my CTPCI project I have Video, USB (mouse and storage working great; the keyboard map is all funky for PC keyboard, but I'm using the Falcon keyboard anyway, so no problem there). I would love to resolve the network issue if anyone has any insight. As I stated before, nothing is reported at the ...
by JoeAtari
Sun Dec 23, 2018 4:48 am
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 85656

Re: CTPCI and Realtek 8139D

I checked my settings, and it is not set to log to file. Can someone please confirm that the driver reports on the screen even if the card is not present? It just seems that in my case the driver is not loading for some reason. I have tried a "bare" system, no ACC or auto programs other than mint, e...
by JoeAtari
Sat Dec 22, 2018 7:18 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 85656

Re: CTPCI and Realtek 8139D

Thanks Latz, I’m going to try some shorter IDE cables and some different network cards, but it sure seems like the driver should report something, even if there is no card in the slot. I don’t have a clue. I think I have tried everything.
by JoeAtari
Sat Dec 22, 2018 1:11 am
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 85656

Re: CTPCI and Realtek 8139D

Can someone please let me know if you rtl8139.xif driver is reported on the mint boot screen when it loads properly? For me, nothing is showing at all, and at the end of the boot screen it reports "network unreachable." Thanks!
by JoeAtari
Fri Dec 21, 2018 6:01 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 85656

Re: CTPCI and Realtek 8139D

Yes, I tested and now I understand that drivers.hex is needed for things to work, and that the TOS drivers are used for USB even under Mint. Thanks!
by JoeAtari
Fri Dec 21, 2018 2:26 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 85656

Re: CTPCI and Realtek 8139D

Okay, this answer makes me think that maybe drivers.hex should not be flashed (present) for Mint??? Does Mint handle everything for USB and Ethernet and I have a conflict because the TOS drivers are active? Is there a way to turn them off without re-flashing with only TOS and no drivers.hex? I can e...
by JoeAtari
Fri Dec 21, 2018 7:04 am
Forum: CT60 / CT63 Area
Topic: CTPCI and Realtek 8139D
Replies: 213
Views: 85656

Re: CTPCI and Realtek 8139D

I have tried everything suggested here and in the other CTPCI topics, but I cannot get the rtl8139.xif driver to load at all (I have tried both versions found here on the forum). I've tried all the versions of Mint so far including prepcibios as found here, with the exception of 1.17.0. Nothing is r...
by JoeAtari
Thu Dec 20, 2018 8:29 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and USB card
Replies: 181
Views: 73764

Re: CTPCI and USB card

So far I get no indication of the RTL8139 driver loading at all. Do you see it load when Mint is booting? I have tried both driver versions that I found here on the forum. I tried the prepcibios freemint and freemint 18 release version. I'll probably try changing the order of the cards in the slots ...
by JoeAtari
Thu Dec 20, 2018 1:04 am
Forum: CT60 / CT63 Area
Topic: CTPCI and USB card
Replies: 181
Views: 73764

Re: CTPCI and USB card

My USB problem was fixed by moving the cards to this order: Slot 1 - Radeon, Slot 2 - USB, Slot 3 - Network. Now on to trying to get the network card operating!
by JoeAtari
Wed Dec 19, 2018 8:05 pm
Forum: CT60 / CT63 Area
Topic: CTPCI and USB card
Replies: 181
Views: 73764

Re: CTPCI and USB card

I'm wondering if this is all sorted out now in the current Mint builds? My USB card and network card are visible with the TOS beta 2.02. With some flash drives I can get a drive letter, but file copy operations fail both on TOS and Mint. I'm just asking if I should follow the fixes in this thread or...
by JoeAtari
Mon Dec 17, 2018 6:35 am
Forum: CT60 / CT63 Area
Topic: CTPCI and Falcon IDE
Replies: 2
Views: 5437

Re: CTPCI and Falcon IDE

The problem was due to the CPX setting. Somehow in the order I copied things the CPX set the boot to the PCI IDE (I have no drive hooked there). This disabled the Falcon IDE (it was not seen when booting in 060 mode). The fix was to copy the CPX to a floppy, boot in 060 mode from the floppy (holding...
by JoeAtari
Mon Dec 17, 2018 12:06 am
Forum: CT60 / CT63 Area
Topic: CTPCI and Falcon IDE
Replies: 2
Views: 5437

CTPCI and Falcon IDE

I recently bought a CTPCI on eBay, and I installed it and everything was going great. So far I had only tested a Radeon 9250 card and a couple of different monitors. Suddenly after a reboot, the Falcon IDE drive is not recognized (HDDriver reports error) the led glows for a few seconds then goes out...
by JoeAtari
Sun Oct 21, 2018 5:51 am
Forum: Other emulators & tools
Topic: BeePi 1.0
Replies: 111
Views: 60026

Re: BeePi 1.0

Here is my blog post about what I have been able to accomplish so far with BeePi:
http://www.falconproductions.us/blog/st ... i-top.html
Philippe has helped to refresh the enjoyment of my Atari hobby following some not-so-great experiences.
Thank You Philippe!
by JoeAtari
Sun Oct 14, 2018 4:58 am
Forum: CT60 / CT63 Area
Topic: USB Mint no drive letter is assigned
Replies: 3
Views: 5375

Re: USB Mint no drive letter is assigned (solved)

mzry: Now I understand what you were saying. I did have the jumper in place. It had to do with something related to the wiring to boost the motherboard. When I put the original CT60 back in place, the board worked just fine. I ended up using my CT60e on the "new" motherboard, and my original CT60 on...
by JoeAtari
Sun Oct 14, 2018 1:42 am
Forum: CT60 / CT63 Area
Topic: USB Mint no drive letter is assigned
Replies: 3
Views: 5375

Re: USB Mint no drive letter is assigned

I swapped it a long time ago, and USB has been working since then. I must have changed something in my configuration that is causing this.

Thanks!
by JoeAtari
Sat Oct 13, 2018 11:14 pm
Forum: CT60 / CT63 Area
Topic: USB Mint no drive letter is assigned
Replies: 3
Views: 5375

USB Mint no drive letter is assigned

The USB driver for Mint is no longer assigning a drive letter. The driver loads, finds the flash drive, the drive lights up all as before, but now no drive letter is assigned. This is a CT60e Falcon with an EtherNat for the USB hardware. Thanks!
by JoeAtari
Mon Aug 20, 2018 4:28 am
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

Great to know! I have a Raspberry Pi3 model B. The B+ does not work with the pi-top OS at this point. Since I re-flashed the card with Edge and worked around whatever issue was causing it to run slowly, it has been working perfectly. I have leaned a lot about Linux by working with this, and BeePi is...
by JoeAtari
Sun Aug 19, 2018 7:31 am
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

I don't really understand what the difference would be, but I tried using "Etch" with a PC to create the SD Card rather than "Pi Filler" on my Mac. Now I no longer get the problem with the system freezing at the desktop. More testing is in order, but I am encouraged. I'll use it for a few days to se...
by JoeAtari
Wed Aug 15, 2018 5:27 am
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

I think this may be something different than what is explained in the documentation. I can get to the desktop, but it often freezes before any icons display. If I get to the full desktop, it will often freeze so that the cursor will move, but I cannot click the mouse or use the keyboard. If I boot e...
by JoeAtari
Tue Aug 14, 2018 3:04 am
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

Regarding the pi-top laptop, I now believe there is a hardware incompatibility. The system keeps hanging when booting.
by JoeAtari
Sun Aug 12, 2018 5:07 am
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

Okay, I kept at it and now things are working just fine! I'm not sure what I did that was different. I know that I started clean, applied the update and then did this: - delete /etc/udev/rules.d/70-persistent-net.rules - edit /lib/udev/rules.d/75-persistent-net-generator.rules and remove eth*|wlan*|...
by JoeAtari
Sat Aug 11, 2018 8:59 am
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

I found the shutdown. Thanks! I did apply the update. The only way I could get networking to function was by doing this: - delete /etc/udev/rules.d/70-persistent-net.rules - edit /lib/udev/rules.d/75-persistent-net-generator.rules and remove eth*|wlan*| from # device name whitelist KERNEL!= ... But ...
by JoeAtari
Sat Aug 11, 2018 6:33 am
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

I think now that the problems I thought were related to shutdown or some kind of corruption are actually related to enabling networking. The system hangs whenever I have networking enabled. I had both ethernet and wifi working, but only for a short period of time before things started hanging on boo...
by JoeAtari
Fri Aug 10, 2018 8:02 pm
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

What is the recommended shutdown procedure for BeePi? I finally got everything working, then something got corrupted; I think because I am powering off with the power button on my pi-top. Shutdown from ARANYM does a reboot.
by JoeAtari
Fri Aug 10, 2018 6:59 pm
Forum: Other emulators & tools
Topic: BeeKey Atari on a key and now BeePi
Replies: 210
Views: 119715

Re: BeeKey Atari on a key and now BeePi

First, let me say "thank you" for this great work. I'm having a lot of fun with it! I bought a pi-top laptop and I'm setting up a beepi-top! I have followed this thread and finally got networking by bringing up the interfaces with ifconfig at bash. I have one problem. I cannot edit the file "interfa...

Go to advanced search