Search found 457 matches

by BBond007
Tue May 12, 2020 5:51 am
Forum: MiSTer
Topic: Minimig (Amiga) core discussion
Replies: 1404
Views: 317598

Re: Minimig (Amiga) core discussion

Hello, new minimig user here. Anyone here use minimig with 15khz arcade monitor ? I'm trying figure out how to adjust the horizontal position for the whdload games. I got full screen on workbench (NTSC Hi-Res) but when I load the games there's a gap on left of the screen. It really depends on the g...
by BBond007
Fri May 08, 2020 3:47 am
Forum: MiSTer
Topic: Minimig (Amiga) core discussion
Replies: 1404
Views: 317598

Re: Minimig (Amiga) core discussion

I've been trying to work this out for a while and I fear it may be beyond my capability. The _step pulse that minimig generates is only 20us. It should be at least 3ms, any ideas why? I hope you can work it out... The Minimig 1.1 supports this feature, and I do think it is sounds more authentic tha...
by BBond007
Fri May 08, 2020 12:01 am
Forum: MiSTer
Topic: MidiLink 2.0 looking for testers. (no MIDI devices required)
Replies: 345
Views: 80598

Re: MidiLink 2.0 looking for testers. (no MIDI devices required)

i've merged BBond007 changes into Main, so it will be used till some reading of UART speed will be implemented. @BBond007, can you test if it works as you designed? Thanks! Would it be possible to disable/hide the BAUD option for the just for the cores that support reading the UART? So far so good....
by BBond007
Tue May 05, 2020 5:45 am
Forum: MiSTer
Topic: MidiLink 2.0 looking for testers. (no MIDI devices required)
Replies: 345
Views: 80598

Re: MidiLink 2.0 looking for testers. (no MIDI devices required)

I posted on the Atari thread but will also post here. With the new midilink MIDI does not work any longer for me. Am I the only one? Can you be more specific? "Local:MUNT", "Local:FSynth", "Remote:UDP"? Nothing works? You mention the Atari ST thread, so I assume you mean that core, but do other cor...
by BBond007
Tue May 05, 2020 2:11 am
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

what do you think about my changes in midilink? sources are updated in mister-devel repo. Thanks! I responded here --> http://www.atari-forum.com/viewtopic.php?f=117&t=35031&start=325#p400997 ------------------------------------------------- Serial/parallel port redirect to USB --------------------...
by BBond007
Tue May 05, 2020 2:06 am
Forum: MiSTer
Topic: MidiLink 2.0 looking for testers. (no MIDI devices required)
Replies: 345
Views: 80598

Re: MidiLink 2.0 looking for testers. (no MIDI devices required)

what do you think about my changes in midilink? sources are updated in mister-devel repo. Thanks! I do like the changes :) The "UDP_BAUD_ALT" setting is definitely useful, but the problem is all these NULL/modem playable games all work at a different baud (typically 300 - 9600), so you'll still be ...
by BBond007
Sat May 02, 2020 6:47 pm
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

I noticed something strange in this core with MFP. If you try to type a forward slash "/" in a terminal program, it actually sends multiple characters every time. The really strange thing is that what it sends/echos back varies depending on what terminal program you're in, but it never sends just t...
by BBond007
Sat May 02, 2020 7:43 am
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

I think an OSD option to either route the UART to MIDI or MFP in the Atari ST core would cover all bases. Since i'm completely out of Atari ST, i want to get a clear picture. But seems can't make the puzzle together. Doesn't MIDI option with Remote+TCP/UDP cover all use of MIDI connection? I think ...
by BBond007
Sat May 02, 2020 7:30 am
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

Not to forget Midi-Maze https://www.mobygames.com/game/atari-st/midi-maze The First "First Person Co-Op" Yes. That one would probably work well with UDP. I think to make it work for more than 2 MiSTers I'd need to use multicast. Then we need to think how to organize the connections. May be it's goo...
by BBond007
Sat May 02, 2020 6:19 am
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

So this last few days i have been tinkering with the st core to get PPP working. Thank you! Your image worked for me. I was able to ping, however, AFTP client did not seem to work. I was successful using this simple command line FTP client --> http://www.atari-forum.com/viewtopic.php?t=34155 If you...
by BBond007
Fri May 01, 2020 5:57 am
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

Is there a OSD option to switch between MIDI/MFP? How does it know which to use? there is no sprecial OSD option. When UART mode is set to MIDI, then MIDI port is routed to UART. In other UART modes, MFP serial is routed to UART. I was just hoping to be able to manually set this option. For example...
by BBond007
Thu Apr 30, 2020 8:03 pm
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

You want to be using the Atari ST core from the updater/github because the one Sorgelig posted here is for modem testing only and not for MIDI. Not correct. It's for both modem and midilink. Just make sure you use MiSTer binary i've posted together. Sorry for the incorrect info... Is there a OSD op...
by BBond007
Thu Apr 30, 2020 6:27 pm
Forum: MiSTer
Topic: MidiLink 2.0 looking for testers. (no MIDI devices required)
Replies: 345
Views: 80598

Re: MidiLink 2.0 looking for testers. (no MIDI devices required)

As my settings works locally for MIDI what should I look for after SSHing? Just check that MidiLink is starting correctly and all the parameters are being read in correctly (for example UDP_SERVER). You may also want to try and "ping" the UDP_SERVER and make sure that works... If you are not using ...
by BBond007
Thu Apr 30, 2020 2:22 am
Forum: MiSTer
Topic: MidiLink 2.0 looking for testers. (no MIDI devices required)
Replies: 345
Views: 80598

Re: MidiLink 2.0 looking for testers. (no MIDI devices required)

I also have a question regarding the volume settings in MidiLink.Ini: their default value is -1. What are the proper values? Thanks You said you are trying to do remote MIDI anyway... All you really need is UDPMIDI and MUNT. If you are not seeing packets on your UDPMIDI app, then start midilink man...
by BBond007
Thu Apr 30, 2020 2:03 am
Forum: MiSTer
Topic: MidiLink 2.0 looking for testers. (no MIDI devices required)
Replies: 345
Views: 80598

Re: MidiLink 2.0 looking for testers. (no MIDI devices required)

I also have a question regarding the volume settings in MidiLink.Ini: their default value is -1. What are the proper values? Thanks Deprecated. don't mess with that setting. -1 means don't alter ALSA mixer which we don't support anyway... That is a leftofer from testing when this required a USB DAC...
by BBond007
Tue Apr 28, 2020 11:42 pm
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

jca wrote: OK for SSHing, if I want to test FluidSynth it would be
midilink FluidSynth (capitalization OK?)

Code: Select all

midilink FSYNTH
midilink FsYnTh
etc...
https://github.com/MiSTer-devel/MidiLin ... /README.md
by BBond007
Tue Apr 28, 2020 11:35 pm
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

It was just an abuse of language, I have the proper files in the right place, thanks to your install script :? Check to see if the soundfont is like 130mb in size or if its just an small TXT file. Seems the old soundfont install script is broken. If you need it, you can get it from here --> https:/...
by BBond007
Tue Apr 28, 2020 9:57 pm
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

I have the sound roms in the right places. In the OSD UART I selected MIDI, Local, FluidSynth. On the Atari I ran the Music program to select Roland MT32. FluidSynth uses a ".sf2" soundfonts, not ROMs. MUNT uses the ROMs. If you don't have a ".sf2" configured in the MidiLInk.INI then FluidSynth won...
by BBond007
Mon Apr 27, 2020 9:24 pm
Forum: MiSTer
Topic: ScummVM running on FrameBuffer
Replies: 143
Views: 55801

Re: ScummVM running on FrameBuffer

Is it possible to send the MIDI music in MISTer ScummVM to an external device? I want to test it with Munt running on my Windows PC just see how it compares to the AO486 core, but can't see any option to do this. Thanks It is possible if you connected both together using two USB MIDI adapters, but ...
by BBond007
Sat Apr 25, 2020 4:04 am
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

I understand that part but I meant how do I install the two other files in the zip file. How do I put them in the usr/sbin folder. If you upload "uartmode" to say "/media/fat/AtariST" (via FTP) then you can install it using SSH or the FB console (F9) by issuing the command : #cp /media/fat/AtariST/...
by BBond007
Sat Apr 25, 2020 2:52 am
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

Are there any settings or anything that can be done to fix this? Nope, so far. Munt is known as very slow app requiring much faster CPU than MiSTer has. Ok thanks, will have to stick with DOSBOX and ScummVM on Windows, or get a real MT-32! You can also use the OSD "UART: MidiLink/Remote : UDP" opti...
by BBond007
Fri Apr 24, 2020 4:42 am
Forum: MiSTer
Topic: Mac Plus help?
Replies: 71
Views: 8305

Re: Mac Plus help?

What's the advantage of using the iso file? Just to try, I downloaded a 755 disk image from that site, renamed it to boot.vhd and that works, just like with the Mac Plus core. A lot of these premade image files are minimal and incomplete as far as extensions and control panels. I like to install fr...
by BBond007
Thu Apr 23, 2020 9:40 pm
Forum: MiSTer
Topic: Mac Plus help?
Replies: 71
Views: 8305

Re: Mac Plus help?

Status of trying to run Mac on Amiga or "Les tribulation d'un Mac au pays de l'Amiga". I hit a wall and sadly quantum tunneling did not occur :( After spending countless hours trying a gazillion ROMs, FD images, HD Images, using Amiga Forever to transfer files and also trying unsuccessfully to run ...
by BBond007
Thu Apr 23, 2020 8:23 am
Forum: MiSTer
Topic: Atari ST core
Replies: 298
Views: 15753

Re: Atari ST core

es. I've noticed too and have no idea why. I tested and TAZ seems to have issues with FX CAST serial too. Not the same double char thing - seems like its loosing chars. Maybe I got a bad copy? Battle Chess seems to work properly with the UART. That uses a speedy 300 BPS connection. Atari ST vs. Ami...

Go to advanced search