Search found 9 matches

by dizzy33
Tue Mar 31, 2020 11:07 am
Forum: Hardware
Topic: ATARI 520 STF RAM : mix of 100ns and 120ns ?
Replies: 4
Views: 622

ATARI 520 STF RAM : mix of 100ns and 120ns ?

Hello, I own an Atari 520 STF which I would like to upgrade to 1Mo of RAM. So I need to add 16 RAM chips. Currently on the motherboard there is 512Ko of 41256-12 RAM chips (so 120ns). I have a lot of difficulties to find 41256-12 RAM chips at decent price. I would like to add 41256-10 instead (100ns...
by dizzy33
Tue Mar 31, 2020 10:19 am
Forum: Hardware
Topic: New RAM testing program
Replies: 30
Views: 47822

Re: New RAM testing program

OK thanks ! Just one question not related to this thread (sorry but I have no other choice) : I cannot post anymore in the hardware section of this forum, does anyone know why ?
by dizzy33
Tue Mar 31, 2020 8:56 am
Forum: Hardware
Topic: New RAM testing program
Replies: 30
Views: 47822

Re: New RAM testing program

Just one quick simple question : how to load this program into my Atari ? Is there any way to load it using a Gotek ? Does this program exist on a ".ST" file so I can load it using my Gotek ?
by dizzy33
Tue Mar 31, 2020 8:31 am
Forum: Hardware
Topic: ATARI 520 STF RAM : mix of 100ns and 120ns ?
Replies: 4
Views: 622

ATARI 520 STF RAM : mix of 100ns and 120ns ?

Hello, I own an Atari 520 STF which I would like to upgrade to 1Mo of RAM. So I need to add 16 RAM chips. Currently on the motherboard there is 512Ko of 41256-12 RAM chips (so 120ns). I have a lot of difficulties to find 41256-12 RAM chips at decent price. I would like to add 41256-10 instead (100ns...
by dizzy33
Sun Dec 08, 2019 6:39 pm
Forum: Games - Compatibility Issues etc.
Topic: 1040 STE : floppy drive issue
Replies: 1
Views: 3179

1040 STE : floppy drive issue

Hello, since this morning, my 1040 STE does not read any games anymore. I loaded International Karate using my Gotek, just before the game started some bombs were displayed and the STE crashed. Since then, when I start my STE, the STE tries to boot the floppy (Gotek) then display the desktop but wit...
by dizzy33
Sat Oct 01, 2011 3:53 pm
Forum: Hardware
Topic: Megafile 30 power up problem
Replies: 8
Views: 1154

Re: Megafile 30 power up problem

The problem is not the MFM drive. When I power up the PSU, nothing happens (no led lit). So I know the problem comes from the PSU. But I don't know which component may be dead (again, the fuse is OK).
by dizzy33
Sat Oct 01, 2011 9:57 am
Forum: Hardware
Topic: Megafile 30 power up problem
Replies: 8
Views: 1154

Re: Megafile 30 power up problem

Yes this small whistle noise at power off maybe normal, I talked about that in my first post because that is a proof that the power supply does receive electricity when the switch is powered on ...
by dizzy33
Fri Sep 30, 2011 10:50 pm
Forum: Hardware
Topic: Megafile 30 power up problem
Replies: 8
Views: 1154

Re: Megafile 30 power up problem

Thanks for your answer but it whistle only for one second, and only when I power down the power supply... I guess if it was a capacitor it would whistle as long as the power supply is powered on.
by dizzy33
Fri Sep 30, 2011 5:46 pm
Forum: Hardware
Topic: Megafile 30 power up problem
Replies: 8
Views: 1154

Megafile 30 power up problem

Hello, I just received a megafile 30 which has a problem : when I power it up, nothing happens. Then, when I power it down, I can ear a short whistle noise. I checked the fuse on the power supply but it seems OK, and there are no blown components (all solders seem OK). Does anyone already met this p...

Go to advanced search