MagiC/MagiCMacX source updated

Latest news in the Atari world

Moderators: Mug UK, Silver Surfer, Moderator Team

ThorstenOtto
Captain Atari
Captain Atari
Posts: 494
Joined: Sun Aug 03, 2014 5:54 pm

Re: MagiC/MagiCMacX source updated

Postby ThorstenOtto » Fri Dec 21, 2018 6:45 pm

Okay, going a bit offtopic, but: NTFS does allow to delete an open file. Its the Windows layer that forbids this. They are not identical, eg. Windows allows only 260 char long pathnames, while NTFS can handle up to ~64K. Without this, POSIX layers like MS own subsystem or cygwin would not work.
And the Windows layer does those checks only, because they decided to make it compatible to MSDOS/CPM, where the GEMDOS also derives from.

User avatar
dhedberg
Atari Super Hero
Atari Super Hero
Posts: 854
Joined: Mon Aug 30, 2010 8:36 am
Contact:

Re: MagiC/MagiCMacX source updated

Postby dhedberg » Fri Dec 21, 2018 6:54 pm

Yes. NTFS is not a bad fs but the Windows layer cripples it in many ways. Not making any distinction between lower- and upper-case letters is another one. It's kind of amusing to see how confused Windows gets in this case.
Daniel, New Beat - http://newbeat.atari.org. Like demos? Have a look at our new Falcon030 demo MORE.

ThorstenOtto
Captain Atari
Captain Atari
Posts: 494
Joined: Sun Aug 03, 2014 5:54 pm

Re: MagiC/MagiCMacX source updated

Postby ThorstenOtto » Sat Jan 12, 2019 9:28 am

There had been some notable updates recently, including automated builds (see link in the first post). Stay tuned!

mpattonm
Hardware Guru
Hardware Guru
Posts: 362
Joined: Mon Oct 21, 2002 8:52 am
Location: Czech republic
Contact:

Re: MagiC/MagiCMacX source updated

Postby mpattonm » Sat Jan 12, 2019 11:04 am

Wonderful! Pretty please, keep it up!
BTW The commits list is impressive. I see lot of effort towards CT60, does it mean we can expect CT60 test builds soon? :)

ThorstenOtto
Captain Atari
Captain Atari
Posts: 494
Joined: Sun Aug 03, 2014 5:54 pm

Re: MagiC/MagiCMacX source updated

Postby ThorstenOtto » Sat Jan 12, 2019 11:36 am

According to a user of the german forum, they should work already. He used magic_p.tos to patch the resulting magic.ram (source included, but not currently build; has to be verified if that still is needed) and a slightly modified version of the ct60 specific boot program (also not currently build, but that will change soon), the ct60new.s in the kernel/bios/atari/boot folder. With those, he successfully booted MagiC.

User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1541
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: MagiC/MagiCMacX source updated

Postby Cyprian » Sat Jan 12, 2019 12:01 pm

Hey Otto,
What does this message means?
Steem__00002.png


It is from Steem. I prepared an empty hard disk partition,and I copied then content of "EN" folder from "magicmac-20190112-090039-bin.zip":
https://bintray.com/th-otto/magicmac-fi ... /snapshots
You do not have the required permissions to view the files attached to this post.
Jaugar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/

User avatar
Ektus
Captain Atari
Captain Atari
Posts: 235
Joined: Mon May 24, 2010 2:58 am
Location: Germany
Contact:

Re: MagiC/MagiCMacX source updated

Postby Ektus » Sat Jan 12, 2019 12:17 pm

ThorstenOtto wrote:According to a user of the german forum, they should work already. He used magic_p.tos to patch the resulting magic.ram (source included, but not currently build; has to be verified if that still is needed) and a slightly modified version of the ct60 specific boot program (also not currently build, but that will change soon), the ct60new.s in the kernel/bios/atari/boot folder. With those, he successfully booted MagiC.


That would be me. Haven't done any more testing yet, but the machine is up and running, CTPCI and all. That's with the build from post https://forum.atari-home.de/index.php/t ... #msg235546


Regards
Ektus.
Schneider CPC464 (long retired), Atari Mega ST4 (retired), Falcon+CT2A, Falcon+CT63+CTPCI+Radeon 9250, Milan040+SCSI+Rage

ThorstenOtto
Captain Atari
Captain Atari
Posts: 494
Joined: Sun Aug 03, 2014 5:54 pm

Re: MagiC/MagiCMacX source updated

Postby ThorstenOtto » Sat Jan 12, 2019 12:58 pm

Cyprian wrote:Hey Otto,
What does this message means?


It means that
  • there are still some messages that need to be translated ;)
  • The *.OSD driver was not found when initializing the VDI. I have this error occasionally when running an emulator on a harddisk image that is also mounted in linux. Make sure that is not the case. Otherwise: how was STeem configured (which machine type, resolution etc?)

ThorstenOtto
Captain Atari
Captain Atari
Posts: 494
Joined: Sun Aug 03, 2014 5:54 pm

Re: MagiC/MagiCMacX source updated

Postby ThorstenOtto » Sat Jan 12, 2019 3:38 pm

There were some minor mistakes in the layout (themes & pat folder ended up in the wrong location), these are now fixed. But that should not prevent the system to work.

I have uploaded now also a ~16MB sample Harddisk image populated with the english version, that works in Hatari & Aranym. Maybe that should give you also a start for SteeM.

ThorstenOtto
Captain Atari
Captain Atari
Posts: 494
Joined: Sun Aug 03, 2014 5:54 pm

Re: MagiC/MagiCMacX source updated

Postby ThorstenOtto » Sat Jan 12, 2019 3:42 pm

oops, duplicate post deleted.

User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1541
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: MagiC/MagiCMacX source updated

Postby Cyprian » Sat Jan 12, 2019 6:41 pm

Thanks for preparing harddisk image.
I've checked with Hatari 2.1.0 and Steem 3.9.4 (both with EmuTOS 0.9.10) and both of them shows me:

floppy_00001.png


ant then:
floppy_00002.png
You do not have the required permissions to view the files attached to this post.
Jaugar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/

ThorstenOtto
Captain Atari
Captain Atari
Posts: 494
Joined: Sun Aug 03, 2014 5:54 pm

Re: MagiC/MagiCMacX source updated

Postby ThorstenOtto » Sat Jan 12, 2019 8:29 pm

I don't use Steem, so i can't tell how to set up a harddisk image there. For Hatari it should work however, at least with recent versions on linux. Same for Aranym (where the last official release is quite old). In both cases i'm using current (snapshot) versions.

Maybe for Steem you could try attaching it as a 2nd Harddisk first, and boot from some already working one, to check whether it is recognized at all. It's just a normal partition table with only a single partition in it.

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1141
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: MagiC/MagiCMacX source updated

Postby TheNameOfTheGame » Sat Jan 12, 2019 8:41 pm

In Steem, I have to use an ASCI drive image for MagiC, could't work with GEMDOS (host system) drive. I believe when the ASCI drive is enabled, GEMDOS drives have to be disable for MagiC to work. Just trying to remember off the top of my head.

User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1541
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: MagiC/MagiCMacX source updated

Postby Cyprian » Sat Jan 12, 2019 8:59 pm

ThorstenOtto wrote:I don't use Steem, so i can't tell how to set up a harddisk image there. For Hatari it should work however, at least with recent versions on linux. Same for Aranym (where the last official release is quite old). In both cases i'm using current (snapshot) versions.


I'm using Windows, maybe there is something different in how Hatari manages disk image between both systems.

I'll let Hatar and Steem SSE team know about my issue.
Is it ACSI or IDE image?

ThorstenOtto wrote:Maybe for Steem you could try attaching it as a 2nd Harddisk first, and boot from some already working one, to check whether it is recognized at all. It's just a normal partition table with only a single partition in it.

Will try

TheNameOfTheGame wrote:In Steem, I have to use an ASCI drive image for MagiC, could't work with GEMDOS (host system) drive. I believe when the ASCI drive is enabled, GEMDOS drives have to be disable for MagiC to work. Just trying to remember off the top of my head.


I have disabled GemDOS emulation. I can see HD driver message (as posted above) therefore EmuTOS and TOS boots ACSI image.
Last edited by Cyprian on Sat Jan 12, 2019 9:07 pm, edited 2 times in total.
Jaugar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1141
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: MagiC/MagiCMacX source updated

Postby TheNameOfTheGame » Sat Jan 12, 2019 9:06 pm

ASCI image. I have a blank 1GB hdd image if you need it. Then load HDDriver as a floppy image .ST and partition the drive image and install the driver, then do the same for MagiC, etc. I also used a program- PP's Drive Imager v1.35 to put zip files on the drive so I could install software easier, but had to use a VirtualBox linux install as it only works on linux I think. http://atari.8bitchip.info/drimlus.php

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1141
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: MagiC/MagiCMacX source updated

Postby TheNameOfTheGame » Sat Jan 12, 2019 9:20 pm

Btw, I'm using Steem 3.8.0 win32. Not sure if newer versions have changed anything.

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1141
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: MagiC/MagiCMacX source updated

Postby TheNameOfTheGame » Sun Jan 13, 2019 1:20 am

Eh, 3 posts in a row...sorry. Here is the blank drive image I used to install hddriver and magic under steem.

hdd-1gb_blank.zip
You do not have the required permissions to view the files attached to this post.

User avatar
Cyprian
10 GOTO 10
10 GOTO 10
Posts: 1541
Joined: Fri Oct 04, 2002 11:23 am
Location: Warsaw, Poland

Re: MagiC/MagiCMacX source updated

Postby Cyprian » Sun Jan 13, 2019 3:53 pm

thanks,
It seems something is wrong with my Hatari setup, due to I'm not able to install the latest HDDriver Demo on your Partition.
I have to check on a clean setup.
Jaugar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm / SM124 / SC1435
SDrive / PAK68/3 / CosmosEx / SatanDisk / UltraSatan / USB Floppy Drive Emulator / Eiffel / SIO2PC / Crazy Dots / PAM Net
Hatari / Steem SSE / Aranym / Saint
http://260ste.appspot.com/


Social Media

     

Return to “News & Announcements”

Who is online

Users browsing this forum: No registered users and 6 guests