NetUSBee TOS driver

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1742
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: NetUSBee TOS driver

Postby frank.lukas » Tue Aug 21, 2018 6:47 pm

Galvez wrote:
frank.lukas wrote:Work not with the PAK68/3. With my Atari TT the Netusbee is not working too.

New driver to test with the TT and the PAK/3.
netusbee.zip


It is not working. The USB.ACC show the USB Stick connected to the netusbee but at the Desktop there is no drive letter for the USB Stick. HDDriver display for the Buses "Bus 3: USB Mass Storage" but there are no Availabe Devices on Bus 3 and no Availabe Drives for the USB Stick.

SETMAC.PRG works fine
HT3ENEC.TOS work not "Reset Bit not Set FATAL"
HT2ENEC.TOS work not "ffffffff" MAC Address
HT1ENEC.TOS work not

I check the Netusbee in a Atari Mega ST and it works fine there.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

susher
Atari maniac
Atari maniac
Posts: 93
Joined: Sat Oct 03, 2015 7:06 pm

Re: NetUSBee TOS driver

Postby susher » Tue Aug 21, 2018 8:03 pm

SETMAC always says that it works... but on many TTs it doesn't actually mange to write to the EEPROM.

It looks like your TT is even more incompatible with the NetUSBee than mine, though cleaning the cartridge port helped a lot. (Your results are similar to mine before I cleaned the contacts individually and then used folded paper to polish the last of the corrosion off.)

Galvez
Captain Atari
Captain Atari
Posts: 264
Joined: Fri Oct 19, 2007 7:49 am

Re: NetUSBee TOS driver

Postby Galvez » Wed Aug 22, 2018 5:55 pm

Hi Frank, thanks for the feedback.

frank.lukas wrote:It is not working. The USB.ACC show the USB Stick connected to the netusbee but at the Desktop there is no drive letter for the USB Stick. HDDriver display for the Buses "Bus 3: USB Mass Storage" but there are no Availabe Devices on Bus 3 and no Availabe Drives for the USB Stick.

Were those test made with the PAK/3 or the TT? or both?

Also I'd like to mention that the USB TOS drivers don't work when the NetUSBee network driver for STING is configured and working. Just in case you have it installed on those machines.

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1742
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: NetUSBee TOS driver

Postby frank.lukas » Wed Aug 22, 2018 6:11 pm

Galvez wrote:Hi Frank, thanks for the feedback.

frank.lukas wrote:It is not working. The USB.ACC show the USB Stick connected to the netusbee but at the Desktop there is no drive letter for the USB Stick. HDDriver display for the Buses "Bus 3: USB Mass Storage" but there are no Availabe Devices on Bus 3 and no Availabe Drives for the USB Stick.

Were those test made with the PAK/3 or the TT? or both?


for both ...
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

rcamp48
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 138
Joined: Wed Feb 21, 2018 8:03 am

Re: NetUSBee TOS driver

Postby rcamp48 » Fri Jan 25, 2019 7:07 am

Hi I just ordered a NetUsbEE from Lotharek and it should be in soon. When I get it I would love to test it on my 1 meg ST machine and my 4 meg machine which I should have ready by the time the netusbee comes in, I also have a 1040 STE with 4 megs but it is down right now. Russ PS: I am in Canada so you would have a beta tester for US machines.
Call Spy Visits Spy BBS at Telnet 99.250.141.63
port 1989. BBS is up and running , but not all of the bugs ironed out. :megaphone:

Perdrix24
Atari maniac
Atari maniac
Posts: 83
Joined: Mon Feb 26, 2018 1:47 pm

Re: NetUSBee TOS driver

Postby Perdrix24 » Fri Jan 25, 2019 12:34 pm

rcamp48 wrote:Hi I just ordered a NetUsbEE from Lotharek and it should be in soon. When I get it I would love to test it on my 1 meg ST machine and my 4 meg machine which I should have ready by the time the netusbee comes in, I also have a 1040 STE with 4 megs but it is down right now. Russ PS: I am in Canada so you would have a beta tester for US machines.

Hi, I'm in Canada too! Gatineau, QC near Ottawa. I will add you to my list of testers, so you'll receive beta drivers to test.

Meanwhile, download the latest drivers at viewtopic.php?f=15&t=34355 . There I put together USB drivers from different authors in a package. We have drivers for USB storage, mouse and keyboard.


Claude

Ibanezq
Atarian
Atarian
Posts: 1
Joined: Fri Aug 17, 2018 3:58 pm

Re: NetUSBee TOS driver

Postby Ibanezq » Mon Jun 10, 2019 10:09 am

Hi @Pedrix24, any updates, progress etc.? :)

elrnsd
Retro freak
Retro freak
Posts: 10
Joined: Fri Dec 08, 2017 5:13 pm

Re: NetUSBee TOS driver

Postby elrnsd » Mon Jul 01, 2019 1:24 am

Hey guys (and gals),

I am having some issues with my NetUSBEE and getting USB drives to work. Basically I was able to get an older USB to work right out of the box with TOS on my TT (TOS 3.06). However after a little while it stopped working and then my system would freeze up and unless I removed the USB at start up, it would no longer recognize in the system. Confused, I tried other USB thumb drives....with no luck. HDDRUtil 10.3 would see some drives, not others. In vain I have even gone so far as to purchase 2 different USB sticks (both 16GB) and again, the HDUtil's would see one of the drives, but I can not partition it, add files to it, or when I copy files from Windows and then put to my TT it does not see the files. I have even tried to format it in the HDUtils thinking it was something with the file structure on the USB drive.

I am at a total loss now. I can not get any USB thumb drives to work. I have tried the following with the results:

SanDIsk 2 GB - sees the device, but will not allow me to access it. Also when it's in the NETUSBEE on startup, locks up the system.
SanDisk 4 GB - does not see it at all. I've tried both formatting in FAT and FAT32 on Windows, no luck.
SanDisk 16 GB - See's the device in HDUTIL, and will format it, but I can not partition it and TOS does not see any files on it.
PNY 16 GB - Same as the SanDIsk 16GB.

Are there specific USB sticks that are known to work and is there a specific process in order to get the drives to work?

I have the drivers in the auto folder correctly and the most current ones as verified by Pendrix.

Any help would be greatly appreciated.

Thanks,
Eric

6BQ5
Atari User
Atari User
Posts: 41
Joined: Thu Jan 17, 2019 5:59 am
Location: Minden, NV USA

Re: NetUSBee TOS driver

Postby 6BQ5 » Tue Jul 02, 2019 12:01 am

I've been using a Kingston DataTraveler G4 16GB unit with my NetUSBee. Also, some of the super small Sandisk Cruzer Fit devices work too.

Boris

Atari 130XE
Atari 1040 STe


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 0 guests