Latest Firmware Kills my CosmosEx

News, questions and bugs reports about CosmosEx by Jookie. Now we have a Raspberry Pi in our machines!

Moderators: Jookie, Moderator Team

Sowden
Atari freak
Atari freak
Posts: 70
Joined: Mon Mar 17, 2014 6:15 pm

Latest Firmware Kills my CosmosEx

Postby Sowden » Wed Feb 20, 2019 9:28 pm

Hey guys. So this last weekend I decided to try the newest firmware posted last year. I updated it and I instantly lost my mouse. Looking at the problem further, I discovered that it killed my self powered USB hub I had plugged into it, so that killed my USB thumbstick, mouse and wifi. After looking at it more, it seems like it losses all USB connection strait to the Pi. No USB device is powered the instant the new firmware is updated. Now I tried different SDcards, different images, Jessie and Stretch and they both gave the same result. Luckily I backed up my card before I updated it so I had something to revert back to. I have the first run of CosomsEx with a Pi Model 2 B on my 1040STF with TOS 1.02. I know that the firmware kills my USB ports at Main App Firmware 2018-05-10 and it is the same at 2018-05-16. Anyone might have an idea on why this happens or should I make a post on their github? Thanks.
Last edited by Sowden on Thu Feb 21, 2019 6:02 pm, edited 1 time in total.

mikro
Hardware Guru
Hardware Guru
Posts: 2034
Joined: Sat Sep 10, 2005 11:11 am
Location: Kosice, Slovakia
Contact:

Re: Latest Firmware Kills my CosmosEx

Postby mikro » Thu Feb 21, 2019 6:46 am

Sowden wrote:I know that the firmware kills my USB ports at Main App

That's a very bold statement. All the firmware does is to either communicate with Atari (custom ICs - Hanz/Franz) or provide an user-space application to the underlying Linux OS. It doesn't know anything specific about USB ports or any other RPi hardware.

I guess some repro steps would be needed as nobody else has ever complained about this.

Sowden
Atari freak
Atari freak
Posts: 70
Joined: Mon Mar 17, 2014 6:15 pm

Re: Latest Firmware Kills my CosmosEx

Postby Sowden » Thu Feb 21, 2019 4:58 pm

mikro wrote:That's a very bold statement. All the firmware does is to either communicate with Atari (custom ICs - Hanz/Franz) or provide an user-space application to the underlying Linux OS. It doesn't know anything specific about USB ports or any other RPi hardware.


I don't what else it could be. I have my firmware setup at 2017-04-13. I set it into motion the update the firmware. It goes through it's deal of downloading and installing. Meanwhile my USB hub is plugged in and it has a red LED on to show that it's powered. The last order is that it resets the apps, then goes strait to the main CE menu. Then the LED on my hub goes strait off. Can't move mouse, get internet, etc. And it doesn't update Hans or Franz or Xilinx, so I don't know what else it could be. I think I'll make a ticket then.

Sowden
Atari freak
Atari freak
Posts: 70
Joined: Mon Mar 17, 2014 6:15 pm

Re: Latest Firmware Kills my CosmosEx

Postby Sowden » Thu Feb 21, 2019 6:08 pm

Well isn't that strange? The newest firmware is working using the Yocto SDcard image but it brakes using the Jessie image. I know I own a Pi Model 2 B, but I was instructed a long time ago to change it to Jessie because it was made for my Pi model. Now I have it upgraded and the USB ports are working great. I guess the last two updates break my Pi using Jessie because I have an older Pi? I dono, but I'm glad its working now.

User avatar
ggn
Atari God
Atari God
Posts: 1258
Joined: Sat Dec 28, 2002 4:49 pm

Re: Latest Firmware Kills my CosmosEx

Postby ggn » Fri Feb 22, 2019 6:24 pm

What Sowden reports actually happened here.

Just to be extra sure I installed a fresh ce jessie image, updated the ce firmware, and when I ran ce_start.sh usb ports and network are dead. I'm using a raspberry pi 1. Did not try to update anything on the linux side, just the ce firmware.

I'll raise an issue with jookie, perhaps he can roll back to a previous firmware until this gets fixed.
is 73 Falcon patched atari games enough ? ^^

Sowden
Atari freak
Atari freak
Posts: 70
Joined: Mon Mar 17, 2014 6:15 pm

Re: Latest Firmware Kills my CosmosEx

Postby Sowden » Sun Feb 24, 2019 5:08 pm

Ok, I am glad that it's not just me. Maybe there is something with an older pi then, since others aren't getting the same issue. We'll see what Jookie has to say. And ggn, if you need it I have a image saved with a Jessie image. It has everything minus the two updates in 2018. If you'd want it, PM me.


Social Media

     

Return to “CosmosEx”

Who is online

Users browsing this forum: No registered users and 8 guests