Problems with USB mouse

All things related to the Atari Coldfire Project

Moderators: Mathias, Mug UK, [ProToS], moondog/.tSCc., Galvez, Moderator Team

Problems with USB mouse

Postby goev » Wed Apr 20, 2011 11:35 am

I've tried to connect a Logitech Wireless USB mouse to my FireBee, and this is what I experienced:

1. When I tried to use the "internal" one, I got no response at boot. FireTos reports nothing in that port. When trying with a memorystick, it is recognized though.

2. When I try to connect to one of the USB ports on the back, the mouse is recognized, however I can only move vertically by moving the mouse horizontally. To move horizontally, I have to press the left mouse button, and then it does move correctly but very irregular.

I understand that there were some issues with USB but this was fixed around new year. Or am I wrong?

I've just booted from a card-reader with a CF-card and an SD-card and it worked just fine from both the "internal" one and the ones in the back.

So, why won't FireTos recognize the mouse when it is connected in the "internal" port, and why does the mouse behave so strange?
Any ideas anyone?

- goev
--------------------------------------------------------------------------------------------------------------------------------
FireBee, Falcon AB040, Mega ST, STE, Stacy, ST, Jaguar, Lynx
goev
Retro freak
Retro freak
 
Posts: 12
Joined: Mon Dec 08, 2008 11:56 am
Location: Mandal, Norway

Re: Problems with USB mouse

Postby Mathias » Wed Apr 20, 2011 8:48 pm

So we are talking about FireTOSs built in USB drivers, not about Davids MiNT USB right?

Which FireTOS are you using. Last time I tried it im February, was with the latest official TOS from early December and early January. I got no problems with various mouses (Microsoft, Logitech, etc). I even could use MegaSTE mouse and USB mouse at the same time!

Maybe you found a bug with a newer TOS?
MegaST 4 with Sounddesigner II MegaBus hardware and 56001, Hades 040, MagiC Mac at Mac OS 9 and a FireBee.
Mathias
Atari Super Hero
Atari Super Hero
 
Posts: 522
Joined: Sat Dec 20, 2008 4:51 pm
Location: Vienna

Re: Re: Problems with USB mouse

Postby joska » Wed Apr 20, 2011 9:15 pm

Mathias wrote:Maybe you found a bug with a newer TOS?


I have the exact same problem as Geir. USB mouse has never worked with FireTOS. USB storage devices work, but not 100% reliably.
Jo Even

Firebee - Milan060 - Falcon040 - Falcon030 - FreeMiNT - XaAES - MIST - STM - STE - Amiga 600 - Sharp MZ700 - MSX - Amstrad CPC - C64
joska
Atari God
Atari God
 
Posts: 1856
Joined: Tue Oct 30, 2007 2:55 pm
Location: Florø, Norway

Re: Problems with USB mouse

Postby Dal » Thu Apr 21, 2011 12:52 am

I have used my belkin USB mouse without problems so far plugged into the ports on the 'rear' of the FB. I'll try some more as I get time though.
FireBee, Falcon -Soundpool case: CT63@95Mhz + 14MB/512MB + 16GB SSD + FPU + Phantom 25/50 + SuperVidel + SoundPool FDI + FA8 + ADAT + Eiffel, TT030: 4MB/16MB + Crazy Dots, Mega"SST" 12, STbook, STacy 2, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's
User avatar
Dal
Administrator
Administrator
 
Posts: 3208
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK


Return to FireBee

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests