Battle Hawks 1942

A section to cover all the different problems encountered by running game x on system y! Whether it's as simple as a non-STE compatible game through to h/drive installable games. Discuss them all in here.

Moderator: Moderator Team

tcat
Atari freak
Atari freak
Posts: 73
Joined: Fri May 03, 2013 6:00 am

Battle Hawks 1942

Postby tcat » Mon Aug 14, 2017 8:06 pm

Hi,

I was thinking what this section is for, now I have a first game that behaves differently under emulator and on the real ST machine.

I just discovered this game and the manual, which is quite a piece of interesting read. I can play the game on `Hatari' emulator alright, when copied to floppy, I experience one missing colour in background, it is `ready room' screen, grey is missing, `pilot cockpit dashboard', grey is missing. Grey colour is not rendered in pictures probably.

I have tried many archive images of the same game, no difference, grey missing in screens.

Any ideas?

Many thanks, Tom

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2809
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: Battle Hawks 1942

Postby AtariZoll » Tue Aug 15, 2017 7:19 am

You need to try it with different TOS versions. And give here more details about exact Hatari version, settings, TOS verison used.
Grey is missing - and what color is there then instead it ?
Negative feedback has usually positive effect.

tcat
Atari freak
Atari freak
Posts: 73
Joined: Fri May 03, 2013 6:00 am

Re: Battle Hawks 1942

Postby tcat » Tue Aug 15, 2017 9:49 am

Hi,

I keep `Hatari' reflecting real ST machine, so the config is the same for both.

ATARI ST
RainBow TOS v1.04
1MB RAM
Floppy, no HD
Blitter ON/OFF - has no difference

Gray is rendered as Black in `menu screen', `ready room', `pilot cockpit' screens, only on real ST machine.

EDIT
Please look for the difference in pictures?
Landing deck, Battle ship turrets.

Tom
real-ST.JPG

hatari.png
You do not have the required permissions to view the files attached to this post.

User avatar
shoggoth
Nature
Nature
Posts: 853
Joined: Tue Aug 01, 2006 9:21 am
Location: Halmstad, Sweden
Contact:

Re: Battle Hawks 1942

Postby shoggoth » Tue Aug 15, 2017 10:21 am

Isn't this just a case of different gamma in emulator vs. your particular monitor? (i.e. TOS/machine/emulator has nothing to do with it?).
Ain't no space like PeP-space.

User avatar
farvardin
Captain Atari
Captain Atari
Posts: 348
Joined: Fri Jan 01, 2010 5:50 pm
Location: France
Contact:

Re: Battle Hawks 1942

Postby farvardin » Tue Aug 15, 2017 10:23 am

yeah, it's pretty sure it's the monitor luminosity which is set too low.

tcat
Atari freak
Atari freak
Posts: 73
Joined: Fri May 03, 2013 6:00 am

Re: Battle Hawks 1942

Postby tcat » Tue Aug 15, 2017 10:52 am

Hi,

It may well be the case, although I doubt as the darkish gray appears as normal black.

Not the case with other games. The game engine seems decompressing images before putting them into display buffer, perhaps if, if I can somehow manage to touchup game image gray in a drawing tool, compress them again (not sure how), and save back to the game image?

Tom

tcat
Atari freak
Atari freak
Posts: 73
Joined: Fri May 03, 2013 6:00 am

Re: Battle Hawks 1942

Postby tcat » Tue Aug 15, 2017 11:01 am

Hi,

I have turned monitor brightness quite up, black now appears as dark grey where it should, black remains black, so I can at least tell two colours appart, but my eye site suffers.

EDIT, now contrast slightly up, so the brightness, better now.
So I dismissed The idea of modifying game pictures, seems silly.

Tom


Social Media

     

Return to “Games - Compatibility Issues etc.”

Who is online

Users browsing this forum: No registered users and 2 guests