Need emulator recommendation

WinSTon, Nostalgia, MSA Converter, FloImg, Makedisk and all the others.

Moderators: Mug UK, Moderator Team

mjx
Retro freak
Retro freak
Posts: 10
Joined: Sun Jul 22, 2012 4:47 pm

Need emulator recommendation

Postby mjx » Sun Jul 29, 2012 9:31 am

Every once in a while over the last few years i've checked several Atari Emulators, but i never found what i need.

Here's what i'm looking for:
- i want to run any original TOS, preferably 3.06 or 4.04 (or similar)
- i don't want to use a custom desktop
- i want a custom screen resolution at 16 or 24 bit true color
- i want highest compatibility at GEM level, meaning old "badly" written Gem programs should work fine
(this clears fVDI from the list)
- i want highest possible CPU speed
- i don't need game-like compatibility

The only emulator i found so far that would match these requirements is STEmulator, but it's not free.

I thought the easiest way would be use a Falcon based emulation, because of the "native" 16bit color.
So i made several experiments with Aranym, but i never managed to get custom resolutions without fVDI.

Gemulator had a nice program VGAWIN.PRG that you could put in the auto folder and it would let you choose a custom resolution, but i never found anything similar that works with another emulator.

Are there any other options?

User avatar
BoNuS
Atari Super Hero
Atari Super Hero
Posts: 766
Joined: Mon Jan 19, 2009 12:45 pm
Location: The Netherlands
Contact:

Re: Need emulator recommendation

Postby BoNuS » Sun Jul 29, 2012 2:49 pm

Did you already try Hatari ?

http://hatari.tuxfamily.org/
http://bonus.home.xs4all.nl/
( I have just to much Atari stuff)

mjx
Retro freak
Retro freak
Posts: 10
Joined: Sun Jul 22, 2012 4:47 pm

Re: Need emulator recommendation

Postby mjx » Sun Jul 29, 2012 3:49 pm

Thanks for your response.

Yes, i tried Hatari, but it seems to be more focused on hardware compatibility for games. I didn't see an option to get "maximum speed" mode and whenever i tried to increase the VDI resolution, pretty much nothing worked. The system didn't boot at all, crashed at the desktop or the mouse was unusable, because the mapping of coordinates was off.

User avatar
lp
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2442
Joined: Wed Nov 12, 2003 11:09 pm
Location: GFA Headquarters
Contact:

Re: Need emulator recommendation

Postby lp » Sun Jul 29, 2012 5:21 pm

mjx wrote:I thought the easiest way would be use a Falcon based emulation, because of the "native" 16bit color.
So i made several experiments with Aranym, but i never managed to get custom resolutions without fVDI.


You have laid down some pretty high requirements. TOS v3.06 and up pretty much eliminate all emulators except aranym. Hatari is moving towards TT and Falcon support but its incomplete at this time.

See here:
http://userpages.bright.net/~gfabasic/html/i_emu.htm

It is the result of many experiments with aranym. Its using TOS 4.04, native videl mode + NVDI (fVDI removed), and disk images for maximum compatibility. Also custom resolutions with BlowUp 030. So its limited to actual Falcon video, you won't get 24 bit, but you can get 16 bit high color.

Dio
Captain Atari
Captain Atari
Posts: 451
Joined: Thu Feb 28, 2008 3:51 pm

Re: Need emulator recommendation

Postby Dio » Sun Jul 29, 2012 5:34 pm

Image
:)

Shredder11
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2434
Joined: Mon Nov 26, 2007 2:23 pm
Location: West Yorkshire, United Kingdom (England)
Contact:

Re: Need emulator recommendation

Postby Shredder11 » Sun Jul 29, 2012 9:45 pm

Haha is that "he wants the moon on a stick" by any chance! :wink: :lol:

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12774
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Need emulator recommendation

Postby wongck » Sun Jul 29, 2012 11:12 pm

If I am not mistaken... you can load Aranym with the TOS from an Falcon.
I think in this way, fVDI is not loaded ( I think fVDI is used in MInt ).
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
DarkLord
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4350
Joined: Mon Aug 16, 2004 12:06 pm
Location: Prestonsburg, KY - USA
Contact:

Re: Need emulator recommendation

Postby DarkLord » Mon Jul 30, 2012 4:42 am

Shredder11 wrote:Haha is that "he wants the moon on a stick" by any chance! :wink: :lol:


Or that maybe he's "shooting for the moon"? :lol:
Welcome To DarkForce! http://www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS - Telnet:darkforce-bbs.dyndns.org 520

mjx
Retro freak
Retro freak
Posts: 10
Joined: Sun Jul 22, 2012 4:47 pm

Re: Need emulator recommendation

Postby mjx » Mon Jul 30, 2012 6:48 am

wongck wrote:If I am not mistaken... you can load Aranym with the TOS from an Falcon.
I think in this way, fVDI is not loaded ( I think fVDI is used in MInt ).
Yes, that works. But then i'm limited to the video resolutions that the Falcon hardware supports. With BlowUp or similar tools i can tweak the resolutions up, but not in the way i would like to. (And not high enough).

Thanks for all the answers, apparently it's not as easy as i had hoped.

I guess i have to stay with Gemulator for now.

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1965
Joined: Sun Jul 31, 2011 1:11 pm

Re: Need emulator recommendation

Postby Eero Tamminen » Fri Jan 18, 2013 10:05 pm

mjx wrote:Yes, i tried Hatari, but it seems to be more focused on hardware compatibility for games. I didn't see an option to get "maximum speed" mode and whenever i tried to increase the VDI resolution, pretty much nothing worked. The system didn't boot at all, crashed at the desktop or the mouse was unusable, because the mapping of coordinates was off.


VDI resolution mode in Hatari is like having a graphics card. Only programs that access video memory cleanly work with it. Note that if you specify high enough resolution, you need to specify also enough RAM for the system. Many programs don't expect screen to be so large.

As to TOS versions... TOS 4.x doesn't support Hatari's VDI mode. TOS 3.x works with it though, as do earlier TOS versions.

If you just want large GEM resolution, use TT-highres. :-)


Social Media

     

Return to “Other emulators & tools”

Who is online

Users browsing this forum: No registered users and 3 guests