Hatari on OSX PPC?

A forum about the Hatari ST/STE/Falcon emulator - the current version is v2.2.0

Moderators: simonsunnyboy, thothy, Moderator Team

User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 334
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Hatari on OSX PPC?

Postby Bikerbob » Sun Jun 02, 2019 12:38 am

I was not able to get 2.2.1 to run on my G4 1.2ghz laptop.

What is the last binary that does? Would assume this machine would be able to run it pretty well.

James

darwinmac
Captain Atari
Captain Atari
Posts: 217
Joined: Sat Aug 06, 2011 2:49 pm
Location: San Jose, USA

Re: Hatari on OSX PPC?

Postby darwinmac » Sun Jun 02, 2019 7:28 am

It appears that 1.7 is the last version with a PPC binary. There were no longer Mac users with an Xcode old enough to build for PPC. In addition, the default SDL supported is 2.x which only supports Intel Macs.

As the emulation has improved, the system requirements have increased. Therefore, you might not be happy with the performance of 2.2.1 on a PPC Mac if you have an Xcode old enough to do the compile.

Bob C

User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 334
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: Hatari on OSX PPC?

Postby Bikerbob » Sun Jun 02, 2019 12:38 pm

Was just a thought Bob, I really love this laptop .. I am using it right now to login. I think the keyboard is one of the best ever made and its small clean and works really well.. and what can I say.. I love my retro computers. I just thought it might be cool to run on this to try it .. My only Intel mac is a Hackintosh.. which most likely will run it.. but since it is not portable.. I could then just run it on my PC and be done with it.

Thanks for the response.. SO all I need to do is find an Xcode that works with PPC and I could compile it huh? that might be a fun search.

James

darwinmac
Captain Atari
Captain Atari
Posts: 217
Joined: Sat Aug 06, 2011 2:49 pm
Location: San Jose, USA

Re: Hatari on OSX PPC?

Postby darwinmac » Sun Jun 02, 2019 5:24 pm

If you compiled 1.8 or 1.9, it might work with a simple compile if you have a copy of SDL 1.x for PPC. At this point, there may be code changes that are not compatible with PPC.

If you do get a later version compiled for PPC, there may still be other Mac PPC who would be interested in it.

Bob C

User avatar
tyk
Atari nerd
Atari nerd
Posts: 48
Joined: Fri Sep 23, 2011 5:55 pm

Re: Hatari on OSX PPC?

Postby tyk » Wed Oct 23, 2019 6:33 pm

There is many people that only Mac they had is PPC Mac. And they like them.

Some hints how to make for OSX 10.5 PPC (and even OSX 10.4 PPC) even with with OSX 10.6 Intel:

You find Xcode from every OSX installation DVDs and even OSX 10.2-10.3 installation CDs.

How to make PPC support for Intel Xcode 4:
https://github.com/thinkyhead/Legacy-XCode-Scripts

Some official hints for compiling:
https://developer.apple.com/library/arc ... -TPXREF101

And please if make new PPC version, make it for OSX 10.4 (Tiger), because most of PPC people like it more than OSX 10.5 (Leopard).

User avatar
Estrayk
Captain Atari
Captain Atari
Posts: 261
Joined: Mon Nov 23, 2015 2:52 pm
Location: Spain

Re: Hatari on OSX PPC?

Postby Estrayk » Wed Oct 23, 2019 9:46 pm

Btw, there're a MorphOS version of HATARI 2.1.0 and MorphOS runs in an Apple PowerPC machine.
https://www.morphos-storage.net/?find=hatari
https://www.youtube.com/watch?v=n8m7bM6IkeM
・Falcon ct60e・Atari MegaSTE ・Atari STe ・MIST ・MISTer・


Social Media

     

Return to “Hatari”

Who is online

Users browsing this forum: No registered users and 5 guests