Hatari 2.0 and ACSI Image problems ...

A forum about the Hatari ST/STE emulator - the current version is v2.0.0

Moderators: simonsunnyboy, thothy, Moderator Team

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Fri Nov 18, 2016 11:21 am

I can use not longer any of my ACSI Images with Hatari 2.0 and EmuTOS 0.97 (512kB). Hatari crash at startup ...

With Hatari 1.7 all works fine.


My System is a Macintosh with macOS Sierra.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1492
Joined: Sun Jul 31, 2011 1:11 pm

Re: Hatari 2.0 and ACSI Image problems ...

Postby Eero Tamminen » Wed Nov 23, 2016 9:26 pm

Is it Hatari crash, or crash of something emulated inside Hatari?

Do your ACSI images still work with older Hatari version?

Because you're using EmuTOS, I assume that you don't use HD driver on the ACSI disk. I tried on Linux EmuTOS 0.9.7 with Hatari 2.0 & latest Mercurial versions using 8MB, 16MB and 200MB ACSI images. All worked fine. So the crash could be something OSX port specific.

Can you reproduce the issue if you rename your hatari.cfg file?

If not, which machine type and other Hatari settings you use?

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Wed Nov 23, 2016 10:35 pm

My ACSI Images works fine with Hatari 1.9 and EmuTOS 0.97 under macOS Sierra.

I delete my hatari.cfg, but it do not help ...

I will test it tomorrow under OSX 10.6 on a another Computer.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Thu Nov 24, 2016 10:20 am

On a old MacBook with OSX 10.6.8 it crash also ...

hatari_crash.png



There is something wrong with the Mac Port of Hatari 2.0 !
You do not have the required permissions to view the files attached to this post.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

darwinmac
Captain Atari
Captain Atari
Posts: 162
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA

Re: Hatari 2.0 and ACSI Image problems ...

Postby darwinmac » Thu Nov 24, 2016 4:54 pm

Frank,

I also run MacOS (OS X) version of Hatari. I was able to use the sample 80MB ACSI image provided on the Hatari website along with the 512K version of EmuTOS 0.9.7. I am also running MacOS Sierra (10.12.1).

Have you tried the sample image to see if that works for you with Hatari 2.0?

Bob C

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Thu Nov 24, 2016 5:09 pm

I download it and rename the 80MB Image to *.img and Hatari crash as before !

I build my Images using the macOS Hdutil program create a MSDOS FAT 900MB Image and partition it with HDDriver under Hatari ...


What can I do ?
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

darwinmac
Captain Atari
Captain Atari
Posts: 162
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA

Re: Hatari 2.0 and ACSI Image problems ...

Postby darwinmac » Thu Nov 24, 2016 5:39 pm

Frank,

Honestly, I am running out of ideas. I have no problems using the hd80mb.img file. In fact, that is my normal Hatari HD image since only a few of my games are HD compatible. I would suggest moving the hatari.cfg file out of ~/Library/Application Support/Hatari. This will force Hatari to start with its default options. It will boot up with EmuTOS (probably the 192K version) and you can add the sample 80MB ACSI image from there and reboot Hatari.

Bob C

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Thu Nov 24, 2016 7:41 pm

... exactly so tried it but it not work for me !

One of my Image -> https://www.dropbox.com/s/ib5lkyqy9qkxu ... g.zip?dl=0
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

darwinmac
Captain Atari
Captain Atari
Posts: 162
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA

Re: Hatari 2.0 and ACSI Image problems ...

Postby darwinmac » Fri Nov 25, 2016 5:45 am

Frank,

Yes, your image also crashes my Hatari. However, I created a 400 MB image and formatted it using AHDI. I was able to successfully boot the disk image using the 512K EmuTOS. Since even the sample 80MB image does not boot for you, I would eliminate your disk images as the problem for now.

Have you tried the sample 80 MB image on your old Macbook running 10.6.8? Right now, I cannot say there is a problem for everyone using the OS X version of Hatari when booting ACSI images. Unfortunately, I do not know why the problem is happening for you.

When I run Hatari from the Terminal, I see the following message along with other Hatari diagnostic messages:
Mounting hard drive image '/Users/bobc/Downloads/400MB_image_easymint_68k_ext2.img'
Abort trap: 6

At that point, Hatari crashes. I have no idea what the Abort trap message means.

I was able to mount the test 400 MB image that I formatted with AHDI 5 (boot program was AHDI 6) without a problem.

You may need to subscribe to the Hatari developers list to get more technical help with this problem.

Bob C

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Fri Nov 25, 2016 1:03 pm

I started hatari over the Terminal and is comes up ...

Franks-MacMini:~ frank$ /Applications/Atari_ST_Emulatoren/Hatari/Hatari.app/Contents/MacOS/hatari
2016-11-25 13:52:24.386 hatari[1027:29105] Could not find image named 'disk'.
VDI screen: request = 1024x768@4, result = 896x672@4
Video_SetSystemTimings1 0 3
Video_SetSystemTimings2 0 3 -> 2 (WS3) 503 503 64
Hatari v2.0.0, compiled on: Nov 3 2016, 20:48:13
IPF : IPF_Init
IPF : capsimage library version release=5 revision=1
Video_SetSystemTimings1 0 3
Video_SetSystemTimings2 0 3 -> 2 (WS3) 503 503 64
Configured max Hatari resolution = 832x588, optimal for ST = 832x588
update cyc speed 0 throttle 0.000000 clock_mult 512
CPU cycleunit: 256 (0.500)
CPU cycleunit: 256 (0.500)
1870 CPU functions
Building CPU, 44274 opcodes (0 -2 1)
CPU=68000, FPU=0, MMU=0, JIT=0. prefetch and cycle-exact 24-bit
Mounting hard drive image '/Applications/Atari_ST_Emulatoren/Hatari/900MB_TEST.IMG'
Abort trap: 6
Franks-MacMini:~ frank$


My Hatari Home directory is /Applications/Atari_ST Emulatoren/Hatari/

There are the EmuTOS and my Images ...


My OSX 10.6.8 Computer: I generate with the HDUtil Program a 900MB MSDOS FAT Image and partition it with HDDriver under EmuTOS. These works all fine. But my old Images I can not use because Hatari 2.0 crash. But I can use these Images with Hatari 1.9 or 1.7 without a Problem. Why ?


Hatari 2.0 crash with the 900MB Image to from the OSX 10.6 Computer under macOS Sierra ...

- My TEST Image has a BGM and a LNX Partition for the MiNT ext2 Filesystem -
You do not have the required permissions to view the files attached to this post.
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

darwinmac
Captain Atari
Captain Atari
Posts: 162
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA

Re: Hatari 2.0 and ACSI Image problems ...

Postby darwinmac » Fri Nov 25, 2016 6:44 pm

Frank,

I posted a link to this discussion on the Hatari developers list. Hopefully, someone there will have an answer.

Bob C

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Fri Nov 25, 2016 7:48 pm

a big thanks ...
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

czietz
Hardware Guru
Hardware Guru
Posts: 397
Joined: Tue May 24, 2016 6:47 pm

Re: Hatari 2.0 and ACSI Image problems ...

Postby czietz » Fri Nov 25, 2016 9:40 pm

Frank, I just made a 15 minute analysis of the Hatari code involving ACSI images and found a bug that could be the reason for your crash. Can you please test if the image loads, if the file name of the hard drive image is really short? I.e. instead of having /Applications/Atari_ST_Emulatoren/Hatari/900MB_TEST.IMG, could you load for example in /tmp/900MB_TEST.IMG (assuming there is /tmp on MacOSX)?

darwinmac
Captain Atari
Captain Atari
Posts: 162
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA

Re: Hatari 2.0 and ACSI Image problems ...

Postby darwinmac » Fri Nov 25, 2016 10:25 pm

Frank,

I just tried Christian's suggestion and I was able to load your image. I did not see the problem because my images are saved in ~/Documents/Hatari/Disks so the pathname was smaller. Since your pathname is 41 characters, you only have 6 characters to work around the problem if you leave your images in the same path. I am not sure when a new executable may be released with this fix. Is there a way you could move your images to another directory with a shorter pathname?

Christian,

As macOS is derived from FreeBSD, it does have a /tmp directory. However, it is normally hidden. The easiest way for Frank to find it in the Finder is by selecting Go to Folder in the Go menu. At that dialog box, simply type "/tmp" to get to /tmp. Actually, /tmp is a link to /private/tmp on macOS.

Bob C

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1492
Joined: Sun Jul 31, 2011 1:11 pm

Re: Hatari 2.0 and ACSI Image problems ...

Postby Eero Tamminen » Fri Nov 25, 2016 10:43 pm

Thomas has commited a fix to (1-byte) stack overwrite in HD handling code to Mercurial repo.

darwinmac
Captain Atari
Captain Atari
Posts: 162
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA

Re: Hatari 2.0 and ACSI Image problems ...

Postby darwinmac » Fri Nov 25, 2016 11:15 pm

Eero,

I saw the commit by Thomas. However, most macOS users do not compile Hatari themselves. That is why I gave Frank other ways to work around the problem.

Bob C

darwinmac
Captain Atari
Captain Atari
Posts: 162
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA

Re: Hatari 2.0 and ACSI Image problems ...

Postby darwinmac » Sat Nov 26, 2016 2:01 am

Frank,

I have uploaded an updated Hatari binary to my Dropbox account. Please note it will probably only run on your macOS Sierra Mac. This is a 64-bit only binary. The official binary runs on more systems. However, this should resolve your problem with the long image names.

https://dl.dropboxusercontent.com/u/162 ... Hatari.zip

This binary also includes any other changes that were made since Hatari 2.0 was released about three weeks ago. Since this is a development version, it has not been heavily tested. However, I am optimistic that the changes that have been made will not affect you.

Bob C

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Sat Nov 26, 2016 7:42 am

many thanks to czietz and Bob ...

It works, wonderful
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Sat Nov 26, 2016 11:06 am

Is there a possibility to update the officially Hatari 2.0 Macintosh Download at http://download.tuxfamily.org/hatari/ with the fix now ?
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

User avatar
troed
Atari God
Atari God
Posts: 1146
Joined: Mon Apr 30, 2012 6:20 pm
Location: Sweden

Re: Hatari 2.0 and ACSI Image problems ...

Postby troed » Sat Nov 26, 2016 12:02 pm

frank.lukas wrote:Is there a possibility to update the officially Hatari 2.0 Macintosh Download at http://download.tuxfamily.org/hatari/ with the fix now ?


Since there exists a workaround I'm not sure a point release will be made with just this fix.

User avatar
frank.lukas
Hardware Guru
Hardware Guru
Posts: 1356
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Hatari 2.0 and ACSI Image problems ...

Postby frank.lukas » Sat Nov 26, 2016 12:12 pm

So we must wait for the 2.1 version ...
fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE

User avatar
troed
Atari God
Atari God
Posts: 1146
Joined: Mon Apr 30, 2012 6:20 pm
Location: Sweden

Re: Hatari 2.0 and ACSI Image problems ...

Postby troed » Sat Nov 26, 2016 12:48 pm

... or use short paths and filenames :)


Social Media

     

Return to “Hatari”

Who is online

Users browsing this forum: No registered users and 2 guests