1943 Capcom game bug

A forum about the Hatari ST/STE emulator - the current version is v1.7

Moderators: simonsunnyboy, thothy, Moderator Team

1943 Capcom game bug

Postby darwinmac » Sat Apr 28, 2012 4:16 am

I readily admit this is not a classic shoot-em-up. However, I happened to hear about it from somewhere and I found a cracked ST version on Planet Emulation. However, the game plays much faster than it's supposed to. I've noticed that the music is speeded up as well. I have tried several cracks and TOS 1.0 as well as 1.04. While Hatari is set to 8 Mhz, I am guessing that the game is running at a much faster speed. I am not an assembly programmer, but I am assuming the game is doing software loops that it assumes take a certain amount of time on an 8 Mhz ST.

I only mention this because this same problem might affect a better game.


Bob C
darwinmac
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
 
Posts: 105
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA

Re: 1943 Capcom game bug

Postby npomarede » Tue May 01, 2012 1:23 pm

Hello

you're probably using a TOS version that set the refresh mode to 60 Hz instead of 50 Hz (US TOS for example).
Could you try with a french tos for example ?

Nicolas
User avatar
npomarede
Atari Super Hero
Atari Super Hero
 
Posts: 753
Joined: Sat Dec 01, 2007 7:38 pm
Location: France

Re: 1943 Capcom game bug

Postby darwinmac » Thu May 03, 2012 3:43 am

npomarede wrote:Hello

you're probably using a TOS version that set the refresh mode to 60 Hz instead of 50 Hz (US TOS for example).
Could you try with a french tos for example ?

Nicolas


Nicolas,

Yes, I was using US versions of TOS. When I tried the French TOS 1.0 version, the problem went away. I mean the game still stinks :), but it was playable. I have to say I got a good laugh at the game moving at 10x the normal speed. I have not had that problem before. I kept the French version of TOS 1.0 around in case this happens again to me. I previously kept a UK version of 2.06 but, even when I owned a real ST back in the day, I found that the older games really preferred TOS 1.0 or TOS 1.04 at most.


Bob
darwinmac
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
 
Posts: 105
Joined: Sat Aug 06, 2011 2:49 pm
Location: Chicago, USA


Return to Hatari

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests