Hatari 2.1.0 Linux Falcon emulation sound issue

A forum about the Hatari ST/STE/Falcon emulator - the current version is v2.1.0

Moderators: simonsunnyboy, thothy, Moderator Team

Faucon2001
Atari Super Hero
Atari Super Hero
Posts: 728
Joined: Sat Oct 26, 2013 11:19 pm
Location: Brasil
Contact:

Hatari 2.1.0 Linux Falcon emulation sound issue

Postby Faucon2001 » Thu Nov 08, 2018 1:20 pm

Hi,
I have been trying to include in BeeKey a Falcon setup with Hatari 2.1.0 and I am facing issues with sound, or it crashes or I don't have sound.
System : Ubuntu sever 16.04, X11, Openbox, SDL 2.0.8, Alsa, jackd, Hatari 2.1.0 latest build with portaudio

1 - First I don't have any issue if I run Hatari in STE emulation with TOS 1.62. Sound is working, system is stable.

2 - If I run Hatari in Falcon emulation mode without jackd I have sound but the emulation crashes after a few minutes.
Hatari error messages :
ALSA lib pcm_route.c:867: Found no matching channel map
ALSA lib pulse.c:243: Unable to connect : Connection refused
hatari: pcm.c:2758: Assertion 'dst < src || dst >= src + bytes' failed
Aborted

3 - If I run Hatari in Falcon emulation mode with jackd ( jackd -d alsa) the emulation is stable but I have no sound.
Hatari error message :
ALSA lib pcm_dmix.c:1029: unable to open slave
ALSA lib pcm_snoop.c:606: unable to open slave

Any idea of what can be wrong with my setup?
Philippe

Firebee, Falcon, STE, Aranym Box, Hatari Pi Box.
My music http://www.philippeworld.net/
My photography http://phil-67.deviantart.com/
EasyAraMint, BeeKey and BeePi https://sites.google.com/site/beebox68k/

User avatar
Eero Tamminen
Atari God
Atari God
Posts: 1758
Joined: Sun Jul 31, 2011 1:11 pm

Re: Hatari 2.1.0 Linux Falcon emulation sound issue

Postby Eero Tamminen » Mon Nov 12, 2018 10:01 pm

Faucon2001 wrote:I have been trying to include in BeeKey a Falcon setup with Hatari 2.1.0 and I am facing issues with sound, or it crashes or I don't have sound.
System : Ubuntu sever 16.04, X11, Openbox, SDL 2.0.8, Alsa, jackd, Hatari 2.1.0 latest build with portaudio

1 - First I don't have any issue if I run Hatari in STE emulation with TOS 1.62. Sound is working, system is stable.

2 - If I run Hatari in Falcon emulation mode without jackd I have sound but the emulation crashes after a few minutes.
Hatari error messages :
ALSA lib pcm_route.c:867: Found no matching channel map
ALSA lib pulse.c:243: Unable to connect : Connection refused
hatari: pcm.c:2758: Assertion 'dst < src || dst >= src + bytes' failed
Aborted

3 - If I run Hatari in Falcon emulation mode with jackd ( jackd -d alsa) the emulation is stable but I have no sound.
Hatari error message :
ALSA lib pcm_dmix.c:1029: unable to open slave
ALSA lib pcm_snoop.c:606: unable to open slave

Any idea of what can be wrong with my setup?


Assert & abort seems to come from ALSA initialization, same with the other ALSA errors. Hatari doesn't do anything directly with ALSA, all audio data goes through SDL APIs.

Portaudio should be used only for Falcon microphone, but maybe it's interfering with SDL audio functionality. If you build Hatari without portaudio, does it work any better?

If not, do other SDL2 programs with audio output work in your setup?


Social Media

     

Return to “Hatari”

Who is online

Users browsing this forum: No registered users and 9 guests