Help getting SSE running on this machine

A forum for anything about the Steem Engine STE emulator, comments, problems, bug reports etc. Steven Seagal regularly provides updated versions of the original STEem code. The current version is v3.9.4.

Moderators: Mug UK, Steem Authors, Moderator Team

Bikerbob
Atari maniac
Atari maniac
Posts: 96
Joined: Wed Mar 23, 2016 2:46 am

Help getting SSE running on this machine

Postby Bikerbob » Thu Dec 07, 2017 3:13 am

OK, not sure now why I cannot get any DD or D3D version to run

Pent4 dual core SSE3 cpu
1.5gb ram
Nvidia Gt7300 video
Windows XP(sp3)
issues1.JPG


I did at one point have several different versions of Steem on the machine, but it was better if I got down to just the one.

DXdiag works completely 9c. Video works, games work, but STEEM, I get this every time.

James
You do not have the required permissions to view the files attached to this post.

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2930
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: Help getting SSE running on this machine

Postby AtariZoll » Thu Dec 07, 2017 7:39 am

Most likely problem is Win XP. Install Win 7 at least.
There is way to stop global warming.

amilo3438
Atari nerd
Atari nerd
Posts: 46
Joined: Sun Oct 01, 2017 12:41 pm

Re: Help getting SSE running on this machine

Postby amilo3438 » Thu Dec 07, 2017 10:42 am

Hmm, it works fine on my XP3...
Try to extract files to a new folder and start from there! (try both d3d and dd versions)
Does it work now?

User avatar
Steven Seagal
Atari God
Atari God
Posts: 1985
Joined: Sun Dec 04, 2005 9:12 am
Location: Undisclosed
Contact:

Re: Help getting SSE running on this machine

Postby Steven Seagal » Thu Dec 07, 2017 4:17 pm

As stated elsewhere in this forum, the Visual C++ 2008 "redistributable" is probably missing. Steem SSE can run on an XP machine.

Bikerbob
Atari maniac
Atari maniac
Posts: 96
Joined: Wed Mar 23, 2016 2:46 am

Re: Help getting SSE running on this machine

Postby Bikerbob » Thu Dec 07, 2017 7:30 pm

I will check again.. but I am pretty sure its there.. I think you told me this before and I installed in on the machine.

Since that thread - I have upgraded the cpu $5 to a Pentium 4 3.0ghz and got the GT7300 video card - so no longer dealing with VIA video drivers.

Steve, does the program deal with chipsets of the machine at all.. this one is using a via chipset, which is not common?

Is there any sort of debug version I can run that will tell me what it hung up on causing that error to show?

James

Bikerbob
Atari maniac
Atari maniac
Posts: 96
Joined: Wed Mar 23, 2016 2:46 am

Re: Help getting SSE running on this machine

Postby Bikerbob » Fri Dec 08, 2017 3:20 am

OK Steven, you were right, I had 2010 on the machine, figured newer was better.. but no.. I deleted everything.. downloaded 2008 and installed and now I am running. Thanks again. I had not thought I needed to have exactly 2008.

James

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2930
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: Help getting SSE running on this machine

Postby AtariZoll » Fri Dec 08, 2017 7:28 am

So, VC redist. is not backward compatible, and we need to install multiple versions (if it is possible and they don't kill each other) for making SW to run ?
That sucks ! Microsoft did this things better in the past. Or they just want people getting new Win versions.
There is way to stop global warming.

Bikerbob
Atari maniac
Atari maniac
Posts: 96
Joined: Wed Mar 23, 2016 2:46 am

Re: Help getting SSE running on this machine

Postby Bikerbob » Fri Dec 08, 2017 1:15 pm

Yeah, you seem to be right AtariZoll, I got the idea that I had to do this because on my laptop (which is still running windos 7) I have multi versions installed, because I think there are separate programs that use a specific package. So that made me think.. hmm maybe he mean is needs 2008 specifically..
The machine is going to be used as an atari server. For my 8-bits and my 16bits. Networking, and telnet modem etc..etc.. It has a floppy drive, a DVD drive, a couple of smaller (250gb) Hds and real printer and serial ports. KVM switch between ST and Server so I can either copy things to the STEEM emu to test, or make Floppies for the real ST or copy some of the software I have here to images to use. I have an HP DJ350 which should work great on the 16bits. and emulates great to the 8-bits through APE. So its a very nice retro computers through a "retro" pc.. :)

James

User avatar
Hazzardus
Atari freak
Atari freak
Posts: 53
Joined: Sun Jun 21, 2009 10:43 pm
Location: Hove Beach

Re: Help getting SSE running on this machine

Postby Hazzardus » Fri Dec 08, 2017 4:14 pm

AtariZoll wrote:So, VC redist. is not backward compatible, and we need to install multiple versions (if it is possible and they don't kill each other) for making SW to run ?
That sucks ! Microsoft did this things better in the past. Or they just want people getting new Win versions.


Oh god, no they didn't :lol: This has been the case since as far back as I can remember :lol: :lol: :lol: Have DirectX 9? well, guess what, you still need Directx 5 and 6. Have .Net 4.5? well, you need 1.0 and 2.0 as well.

Not saying other companies are any better (Apple :cough:) but Windows has always been a nightmare for running software compiled for older runtimes, if you have to start from fresh without having to hunt for multiple versions of supposedly the same thing.

User avatar
MrMaddog
Captain Atari
Captain Atari
Posts: 170
Joined: Fri Oct 06, 2006 3:03 am
Contact:

Re: Help getting SSE running on this machine

Postby MrMaddog » Fri Dec 08, 2017 6:09 pm

AtariZoll wrote:So, VC redist. is not backward compatible, and we need to install multiple versions (if it is possible and they don't kill each other) for making SW to run ?
That sucks ! Microsoft did this things better in the past. Or they just want people getting new Win versions.


It's always been like this... Every PC game I bought always reinstalls some form of VC++ and I've got multiple versions on my drive. It's a waste of space but removing any one of them will break some game that needs it.

And if you download something off the web, like SSE, then the programer needs to let you know which version of VC++ you need to download and manually install. Yeah it sucks, but Windows is always gonna be stuck with all this kruft in as long as people still need "backwards compatiblity".

User avatar
Steven Seagal
Atari God
Atari God
Posts: 1985
Joined: Sun Dec 04, 2005 9:12 am
Location: Undisclosed
Contact:

Re: Help getting SSE running on this machine

Postby Steven Seagal » Fri Dec 08, 2017 7:59 pm

Please call it Steem SSE, not just SSE.
The need for VC++ 2008 is mentioned in the manual.

Steem SSE requires an SSE-enabled processor and the Visual C++ 2008
Redistributable, which is already installed on most computers.


Yes, each successive version requires its set. It's just a matter of adding some dll, much easier and less bug-prone than making one big dll compatible with everything.


Social Media

     

Return to “Steem”

Who is online

Users browsing this forum: No registered users and 1 guest