Topic reply notification mails

News, updates, like or dislike

Moderators: Mug UK, Silver Surfer, Moderator Team

Topic reply notification mails

Postby Desty » Fri Jul 29, 2011 6:17 pm

Greets,

I often am away from the forum for a while and just pop back in when I get a reply notification email to a subscribed topic. Sometimes, they contain links to posts with the IP address and full path, rather than the simpler atari-forum.com URLs. For example:

Code: Select all
http://69.90.163.150/~atari276/viewtopic.php?f=27&t=18790&p=190511&e=190511


This is a little bit annoying because depending on what machine I'm using, it will probably think it's a different site and thus my saved password won't work. I'm not sure how this mechanism works, but it'd be great to have the proper domain name in the links?
tá'n poc ar buile!
User avatar
Desty
Atari God
Atari God
 
Posts: 1935
Joined: Thu Apr 01, 2004 2:36 pm
Location: 53 21N 6 18W

Re: Topic reply notification mails

Postby Dal » Fri Jul 29, 2011 7:03 pm

hmmmm odd one - I'm looking into it. Must be the way the backend enumerates the sitename. I'll see if I can set it as a constant
FireBee, Falcon -Soundpool case: CT63@95Mhz + 14MB/512MB + 16GB SSD + FPU + Phantom 25/50 + SuperVidel + SoundPool FDI + FA8 + ADAT + Eiffel, TT030: 4MB/16MB + Crazy Dots, Mega"SST" 12, STbook, STacy 2, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's
Dal
Administrator
Administrator
 
Posts: 3175
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK

Re: Topic reply notification mails

Postby Dal » Fri Jul 29, 2011 7:58 pm

OK found the function that generates the url and it does indeed enumerate the site from the hosting account. This is where the ipaddress url is coming from. Still a little odd as to why it's temperamental however.

I assume that this same function is used for everything (including generating the base url for topic notifications). I can't see why it wouldn't be as the code is pretty tight. I need to fix it properly, however for the purposes of testing, I have set the function so that it always outputs http://www.atari-forum.com

@Desty: Please can you let me know how this goes over the next few weeks or so. If this does fix it, I know that I need to speak to the hosting company to ensure HTTP_HOST always resolves correctly and I can remove my dirty little hack in the php ;)

I'm pretty sure this is what it is.
FireBee, Falcon -Soundpool case: CT63@95Mhz + 14MB/512MB + 16GB SSD + FPU + Phantom 25/50 + SuperVidel + SoundPool FDI + FA8 + ADAT + Eiffel, TT030: 4MB/16MB + Crazy Dots, Mega"SST" 12, STbook, STacy 2, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's
Dal
Administrator
Administrator
 
Posts: 3175
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK

Re: Topic reply notification mails

Postby Desty » Fri Jul 29, 2011 11:23 pm

Dal wrote:@Desty: Please can you let me know how this goes over the next few weeks or so. If this does fix it, I know that I need to speak to the hosting company to ensure HTTP_HOST always resolves correctly and I can remove my dirty little hack in the php ;)

I'm pretty sure this is what it is.

Well, the topic reply notification for your post looked spot on :P Nice speedy hackfix!
tá'n poc ar buile!
User avatar
Desty
Atari God
Atari God
 
Posts: 1935
Joined: Thu Apr 01, 2004 2:36 pm
Location: 53 21N 6 18W

Re: Topic reply notification mails

Postby lp » Sat Jul 30, 2011 12:54 am

Desty wrote:Greets,

I often am away from the forum for a while and just pop back in when I get a reply notification email to a subscribed topic. Sometimes, they contain links to posts with the IP address and full path, rather than the simpler atari-forum.com URLs. For example:


I get links like that now and then to. Didn't think to report them at the time though.
User avatar
lp
Atari God
Atari God
 
Posts: 1745
Joined: Wed Nov 12, 2003 11:09 pm
Location: My desk

Re: Topic reply notification mails

Postby wongck » Sat Jul 30, 2011 4:09 am

The ip address is also on some search results from Google or Yahoo.
I guess these are bots.... :roll:
Having the ip address on search results ain't so good either.
My Stuff: Falcon CT63+CTPCI ATI R7500 14+512MB 30GB HDD CF HxC_SD EtherNEC/ FB/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list
User avatar
wongck
Ultimate Atarian
Ultimate Atarian
 
Posts: 10705
Joined: Sat May 03, 2008 2:09 pm
Location: Far East

Re: Topic reply notification mails

Postby Dal » Sat Jul 30, 2011 7:23 am

Yeah that's not good. Definitely a host configuration problem then. I'll raise a ticket with them.
FireBee, Falcon -Soundpool case: CT63@95Mhz + 14MB/512MB + 16GB SSD + FPU + Phantom 25/50 + SuperVidel + SoundPool FDI + FA8 + ADAT + Eiffel, TT030: 4MB/16MB + Crazy Dots, Mega"SST" 12, STbook, STacy 2, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's
Dal
Administrator
Administrator
 
Posts: 3175
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK


Return to Website Discussions

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests