Atari-Forum Restore 'snags' list...

News, updates, like or dislike

Moderators: Mug UK, Silver Surfer, Moderator Team

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Atari-Forum Restore 'snags' list...

Postby Dal » Wed Jan 19, 2011 12:29 am

Here's my ToDo list based on things I know are broken and things that should be done moving forward (in order of priority):

1. Prepare my backup script to run on a scheduled basis (this will come down to my NAS drive which in turn is backed up to an online backup solution (giving me a redundant backup). ********Done - however due to a limitation at the host (can't cron an automatic backup), I have had to take a different approach:
1. Backup URL passed from one of my local machines (always on) between 2300 and 0000 GMT
2. Backup will be FTP'd to a new host account I have created for another site I admin (hosted with a completely different hosting company)
3. 7 Days backups at any one time
'********


2. The Wiki - I have the database so will restore that and will upload the base Wiki application and hook it up. I seem to be missing the files so likelihood is, the Wiki will have dead references to images etc. ********Wiki from backup installed: However it is not the most current Wiki (it is a frozen one from 2009). We are discussing what do do with this. At present, I have set it to Read-Only********

3. Upgrade phpBB as it is not at the latest level. Complete (2nd Feb 2011)

4. Search.php doesn't seem to work for Unread topics. This may be because it was missing from the archive and consequently, I uploaded a version of the file from the latest phpBB installation package. This package is a newer release to the version of phpBB currently running on the site. This problem may disappear after upgrading phpBB? After updating phpBB, the problem has disappeared - :D

5. Install TapaTalk add-on Complete (2nd Feb 2011)

6. There has been one report of an erroneous 406 error. Keep an eye on this one - if it persists after the phpBB upgrade, then I'll report it to HostPapa. ********Looks like an isolated issue at present. I'm not treating this is a server problem unless it starts to affect more users.********

7. As the backup archive was truncated, it is possible the attachments directory is incomplete. Write an SQL script to build a list of files that I can compare to the /files directory to get a feel for the percentage of files lost. If we ever get to the 250host account, I can easily roll these back.

Anything you spot, please add to this thread and I'll set it a priority in this post.

I'm sure most will agree with the order of priority?
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2634
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby spiny » Wed Jan 19, 2011 11:25 am

once the wiki is back, i'll check all the pages i've made changes too and have a look at everything else to see if I can fix anything.

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Thu Jan 20, 2011 9:50 pm

OK Wiki has been re-instated and searching for articles appears to work ok however the main page will need to be re-created.

A bit of a long shot but I don't suppose anyone has a cached copy of the main Wiki page on their machines??

Also, I'm a bit gutted that my HxC article is gone :( If anyone has that cached, then let me know.
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Thu Jan 20, 2011 10:08 pm

Ah - ha. Needed to integrate the forum login to the Wiki login in order to get the main page back - phew!!

OK - I think I'm getting there - would still like a copy of my HxC article though...
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
1024MAK
Atari Super Hero
Atari Super Hero
Posts: 632
Joined: Sat Aug 01, 2009 2:58 am
Location: Looking forward to summer time in Somerset, UK...

Re: Atari-Forum Restore 'snags' list...

Postby 1024MAK » Fri Jan 21, 2011 3:21 am

Have some replacement images for one of the wiki pages, but where is the upload tool/function?
Falcon, Atari 520ST, 520STFM, 1040STE, Mega, TT and more PC's than I care to count and an assortment of 8 bit micros (nearly forgot the Psion's).
Visit the Atari-Forum Wiki. Lots of technical info at DrCoolZic Atari ST Site :D

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Fri Jan 21, 2011 9:05 am

You should be able to edit the page is question (top right corner) and the upload should be available through the editor?
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Fri Jan 21, 2011 10:59 am

Ahhhh - right.... It appears I have some more configuration work to do.

Never installed a Wiki before, so a bit of a learning experience! :D
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12781
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby wongck » Fri Jan 21, 2011 11:11 am

I see the wiki is available. Great work guys.
I notice that some of the updates I done are gone. :(
Never mind, i will update it again.
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Fri Jan 21, 2011 12:37 pm

Yes - the one Wiki article I wrote has disappeared also :(

As 1024MAK has pointed out, there is some missing functionality (ability to upload files). As I didn't have the full Wiki in the backup, I had to establish which flavour of Wiki was installed (luckily I found references to MediaWiki in the database!), installed MediaWiki on the server and then imported the old database into the new one. Then I had to integrate the login mechanism with the forum user database

I've looked through the Admin manual though and as is normally the case, it's pretty straight forward to change through config files.

I'm out tonight so will pick up again over the weekend.
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
Mug UK
Administrator
Administrator
Posts: 11422
Joined: Thu Apr 29, 2004 7:16 pm
Location: Stockport (UK)
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Mug UK » Fri Jan 21, 2011 12:44 pm

I'm sure between all of us that helped with the initial stages of and the ticking over of the Wiki that we can get it back to its former glory.

It could do with some strengthening though as it was annoying to see so much page vandalism when some bored 'haxor' got in and peppered as many pages as they could with adverts for Viagra etc.
My main site: http://www.mug-uk.co.uk - slowly digging up the bits from my past (and re-working a few): Atari ST, Sega 8-bit (game hacks) and NDS (Music ripping guide).

I develop a free Word (for Windows) add-in that's available for Word 2007 upwards. It's a fix-it toolbox that will allow power Word users to fix document errors. You can find it at: http://www.mikestoolbox.co.uk

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Fri Jan 21, 2011 1:13 pm

I've configured the authentication so that only members of the Registered Users group in the forum may edit the Wiki...

So for a hoaxer to maliciously edit the Wiki they would need to:
Obtain / hack the password for a valid user account.
Create a legitimate account through the forum.

Unfortunately, Newly Registered users aren't in any way prohibited from logging on to the Wiki. I have created a new user and logged straight into the Wiki.

I will have a ponder and see how I can implement something that doesn't involve faffing about adding users to a special group etc
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
Mug UK
Administrator
Administrator
Posts: 11422
Joined: Thu Apr 29, 2004 7:16 pm
Location: Stockport (UK)
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Mug UK » Fri Jan 21, 2011 4:11 pm

OK, nice one Dal. If it prevents the stereotypical 'bored teenage hacker' from going in and damaging pages for the sheer hell of it, it'll be a good thing.
My main site: http://www.mug-uk.co.uk - slowly digging up the bits from my past (and re-working a few): Atari ST, Sega 8-bit (game hacks) and NDS (Music ripping guide).

I develop a free Word (for Windows) add-in that's available for Word 2007 upwards. It's a fix-it toolbox that will allow power Word users to fix document errors. You can find it at: http://www.mikestoolbox.co.uk

User avatar
Zorro 2
Administrator
Administrator
Posts: 2209
Joined: Tue May 21, 2002 12:44 pm
Location: Saint Cloud (France)
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Zorro 2 » Fri Jan 21, 2011 6:54 pm

Dal wrote:2. The Wiki - I have the database so will restore that and will upload the base Wiki application and hook it up. I seem to be missing the files so likelihood is, the Wiki will have dead references to images etc.

About the last back-up, it seems out of date : 2009.

I need to see what it needs to be update soon...
Member of NoExtra Team

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12781
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby wongck » Sat Jan 22, 2011 4:13 am

Dal wrote:I've configured the authentication so that only members of the Registered Users group in the forum may edit the Wiki...
I will have a ponder and see how I can implement something that doesn't involve faffing about adding users to a special group etc


How did the 3 posting rule on the forum works?
Was someone actually looking at the post before releasing it?

I am not saying a vetting of the wiki page before releasing.
I asked because it may be a non-automated registration where someone needs to grant the permission to edit the wiki.

yeah... too much work I guess.
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Sat Jan 22, 2011 10:01 am

It's pretty simple, the backend has a setting for the minimum number of posts a user must make before their posts are unmoderated.

When a user posts, the application simply checks the users number of posts against this value. If user posts are <=3 (in our case), the post sits in the moderators 'approval' queue for handling.

All moderators will get a notification symbol against any forums they moderate containing posts awaiting approval.

Looking at the settings for controlling how the Wiki authenticates using the forum, there are really only two settings of interest:

A value pointing to the users table
A value that sets the group a user must belong to in order to be granted access.

All registered users (regardless of whether their post count is <3 or not) belong to the Registered Users group.

The 'easy to implement' option is to simply create a Wiki group. However this would require admins to perform additional work manually deploying users into that group (moderators can't do this AFAIK).

The smarter option would be for me to see if I can somehow automate that mechanism without potentially breaking anything when phpBB is upgraded to later releases...

Or

Perhaps something else - I really need to have a think and research how others do it.
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Sun Jan 23, 2011 10:31 am

Re: The Wiki: Please read this
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Sat Jan 29, 2011 9:47 pm

Note status has been updated - refer to my initial post (changes in bold).
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

Dal
Administrator
Administrator
Posts: 4178
Joined: Tue Jan 18, 2011 12:31 am
Location: Cheltenham, UK
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby Dal » Wed Feb 02, 2011 11:31 am

Initial post updated again after completing maintenance (See above)
Mega"SST" 12, MegaSTE, STE: Desktopper case, IDE interface, UltraSatan (8GB + 512Mb) + HXC floppy emulator. Plus some STE's/STFM's

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12781
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Atari-Forum Restore 'snags' list...

Postby wongck » Sat Feb 05, 2011 8:22 am

Dal wrote:4. Search.php doesn't seem to work for Unread topics. This may be because it was missing from the archive and consequently, I uploaded a version of the file from the latest phpBB installation package. This package is a newer release to the version of phpBB currently running on the site. This problem may disappear after upgrading phpBB? After updating phpBB, the problem has disappeared - :D


Yeah... it's working, Excellent work. :thumbs: :thumbs: :thumbs:
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

insanity
Captain Atari
Captain Atari
Posts: 173
Joined: Wed Oct 15, 2003 12:31 pm
Location: Leicester, England

Re: Atari-Forum Restore 'snags' list...

Postby insanity » Sat Feb 12, 2011 7:34 am

Notice the pics on the Motherboard page are missing... does anyone have a cached copy of them...

wiki/index.php?title=Atari_ST_motherboard_revisions

Thanks

baz


Social Media

     

Return to “Website Discussions”

Who is online

Users browsing this forum: No registered users and 5 guests