Where to start with Mint?

Hardware, coding, music, graphic and various applications

Moderators: Mug UK, moondog/.tSCc., [ProToS], lp, Moderator Team

User avatar
piku
Captain Atari
Captain Atari
Posts: 190
Joined: Wed Jan 30, 2008 5:17 am
Location: Philadelphia, PA USA
Contact:

Re: Where to start with Mint?

Postby piku » Sat Jan 07, 2017 8:19 pm

Sorry to revive an old dead thread but this is for the benefit of people searcing (and myself in the future when I inevitably forget). I had a heck of a time getting matrix video card on mint working on a modern 1.19 ST kernel (mega ste) and I finally found a workaround. This was hard to figure out as it was difficult to get an error message. The only way I was able to was to disable redirect.prg and to start n.aes, not xaaes or rom gem. Anyway, the driver does a do_open on "C:\MATRIX\CXX\*.CXS". For whatever reason in the current kernel this fails. I used a hexeditor to replace string "\MATRIX\CXX\*.CXS" with \matrix\cxx\m.cxx" and I made a file m.cxx with my desired mode. Then I booted without going to rom gem or anything. Just works straight away. The file you need to edit is ncxx256.sys if you are using 8 bit color (or ncxx16 if you are using 16 color, etc etc).

EDIT: I take that back xaaes is just a blank white screen so you probably still need to do a rom gem trick
EDIT Again: XaAES was working, it was taking a really long time to load the textures
piku http://www.atari-source.org http://rpmint.com/
CT60 Falcon - Dead Firebee - Some others ;)

helmut
Captain Atari
Captain Atari
Posts: 175
Joined: Thu Jan 07, 2010 4:30 pm

Re: Where to start with Mint?

Postby helmut » Sat Jan 07, 2017 10:49 pm

On my other TT where I have a CV110 something I never needed such actions. I have all the matrix-stuff on C: which is not VFAT.

Maybe you would get the error-message with MiNT's boot-log enabled (In C:\mint\boot.log)?
Do you have NVDI running before the MATRIX-driver loads (I have but that should not affect the path-search)?
It's not impossible to create lower-case-files on a TOS-FS, but you would see that in the desktop.


On an ST you should really disable textures (textures = 0 in xaaes.cnf) or try xaaesst.km.

User avatar
piku
Captain Atari
Captain Atari
Posts: 190
Joined: Wed Jan 30, 2008 5:17 am
Location: Philadelphia, PA USA
Contact:

Re: Where to start with Mint?

Postby piku » Sun Jan 08, 2017 12:53 am

Actually the error message did appear in the xa_boot.log which I found after I already knew what the problem is. I will check that out, maybe I can get some more RAM. Even with monster and 10MB I could definitely use a little more free ram.
piku http://www.atari-source.org http://rpmint.com/
CT60 Falcon - Dead Firebee - Some others ;)

helmut
Captain Atari
Captain Atari
Posts: 175
Joined: Thu Jan 07, 2010 4:30 pm

Re: Where to start with Mint?

Postby helmut » Sun Jan 08, 2017 5:28 pm

I might add that I call cxx_driv.ttp with a command-line using an explicit path (no *):

C:\matrix\cxx_driv.ttp C:\matrix\cxx\...cxs

from xaaes.cnf, but should also work from mint.cnf.

Don't know if that matters (and if there's a bug in MiNT or not).

User avatar
piku
Captain Atari
Captain Atari
Posts: 190
Joined: Wed Jan 30, 2008 5:17 am
Location: Philadelphia, PA USA
Contact:

Re: Where to start with Mint?

Postby piku » Sun Jan 08, 2017 6:04 pm

I didn't know you could do this and certainly that is useful, but I am running the nvdi matrix driver which puts the functionality of cxx_driv into a .sys file (I think). So hexediting the sys file was the right answer for me.
piku http://www.atari-source.org http://rpmint.com/
CT60 Falcon - Dead Firebee - Some others ;)


Social Media

     

Return to “Professionals”

Who is online

Users browsing this forum: No registered users and 3 guests