Broken TTM195

Hardware, coding, music, graphic and various applications

Moderators: Mug UK, [ProToS], lp, moondog/.tSCc., Moderator Team

Broken TTM195

Postby anodyne » Sat Aug 11, 2012 5:00 am

My TTM195 is dead. Fortunately I have a backup, but I'd like to revive the dead one if possible. I have reasonable soldering skills, but alas no 'scope, so I can't do signal tracing.

Can anyone suggest parts to replace, or point me to any online troubleshooting docs (I *do* have the maintenance manual).

Thanks,
Roger Burrows
anodyne
Atari User
Atari User
 
Posts: 34
Joined: Mon Aug 27, 2007 11:15 pm
Location: Canada

Re: Broken TTM195

Postby frank.lukas » Sat Aug 11, 2012 11:52 am

fancy Atari Musik anDA Dance "Agare Hinu Harukana" 1998 ATARI http://www.youtube.com/watch?v=JX10fxb5eYE
User avatar
frank.lukas
Captain Atari
Captain Atari
 
Posts: 416
Joined: Tue Jan 29, 2008 5:33 pm
Location: Germany

Re: Broken TTM195

Postby lp » Sat Aug 11, 2012 3:27 pm

anodyne wrote:Can anyone suggest parts to replace, or point me to any online troubleshooting docs (I *do* have the maintenance manual).


If you get really desperate I have an Atari TTM194 Moniterm Monitor in storage you can have. I don't know the condition or if it works, I'd have to open the box and find out. The shipping would be astronomical to your location.
User avatar
lp
Atari God
Atari God
 
Posts: 1706
Joined: Wed Nov 12, 2003 11:09 pm
Location: My desk

Re: Broken TTM195

Postby Hippy Dave » Sat Aug 11, 2012 4:51 pm

First, do a visual inspection and clean it.
Maybe it has a blown fuse, or some obvious fault.
Don't calibrate anything before it is clean.
The rest of the trouble shooting is outlined
in your service manual.
BTW, read the manual before opening the monitor.
User avatar
Hippy Dave
Captain Atari
Captain Atari
 
Posts: 414
Joined: Sat Jan 10, 2009 5:40 am

Re: Broken TTM195

Postby anodyne » Mon Aug 13, 2012 4:41 am

Thanks to everyone for the comments and suggestions!

The info from the URL supplied by frank.jukas was exactly what I was looking for, so after a bit of work with Google translate, my German dictionary, and my rusty schoolboy German, I have a list of simple things to do which have a good chance of fixing it. With that, the maintenance manual, and a healthy respect for 20000 volts, I'm ready to go.

Thanks again, Atari folk are the greatest!
Roger Burrows
anodyne
Atari User
Atari User
 
Posts: 34
Joined: Mon Aug 27, 2007 11:15 pm
Location: Canada

Re: Broken TTM195

Postby hercule12 » Mon Aug 13, 2012 10:41 am

I have two TTM 195s, both reluctant to display TT hi res. Would you be so kind as to post your investigations so my soldering iron wielding friend can have a butchers at mine, please.
hercule12
Atari User
Atari User
 
Posts: 40
Joined: Tue Nov 01, 2011 10:19 am

Re: Broken TTM195

Postby 3AtariSTE » Thu Aug 16, 2012 9:10 am

anodyne wrote:Thanks to everyone for the comments and suggestions!

The info from the URL supplied by frank.jukas was exactly what I was looking for, so after a bit of work with Google translate, my German dictionary, and my rusty schoolboy German, I have a list of simple things to do which have a good chance of fixing it. With that, the maintenance manual, and a healthy respect for 20000 volts, I'm ready to go.

Thanks again, Atari folk are the greatest!
Roger Burrows



Hi Roger
What's the problem?
The monitor does not turn on?
White screen? or what?
2xAtari 130XE+XF551+1050+XC11+XC12+SIO2PC+TouchTablet+LightPen+Philips CM8833II
Atari 1040STf (Boxed) + Atari 520STe + 5xAtari 1040STe 4Mb + 1xFalcon030 14Mb....
Atari Italian Site: http://www.ataricomputers.altervista.org
Atari Italian Forum: http://ataricomputers.mastertopforum.net/
3AtariSTE
Captain Atari
Captain Atari
 
Posts: 180
Joined: Wed Sep 20, 2006 3:18 pm
Location: Cagliari, ITALY

Re: Broken TTM195

Postby hercule12 » Thu Jun 06, 2013 6:49 am

Living dangerously, I opened my dead TTM 195. The 240volt UK mains goes into a sealed metal box with the mains switch and connector mounted on it. Brown, blue and earth seem to come out of this box and plug into the mobo. I have the schematics but can't tell what, if anything is inside this box. Does 240v go straight onto the mobo 'cos it ain't at the moment?

Q. Have a guess how many screws hold the shielding cage in place?
hercule12
Atari User
Atari User
 
Posts: 40
Joined: Tue Nov 01, 2011 10:19 am

Re: Broken TTM195

Postby tenox » Fri Jun 07, 2013 12:30 am

Dump the monitor and replace with a modern LCD panel. :mrgreen:

7a.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
tenox
Captain Atari
Captain Atari
 
Posts: 207
Joined: Thu Apr 05, 2012 11:52 pm
Location: Sunnyvale, California


Return to Professionals

Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest