Alpha release: USB mouse driver v0.80

Hardware, coding, music, graphic and various applications

Moderators: Mug UK, moondog/.tSCc., [ProToS], lp, Moderator Team

Coda
Atari nerd
Atari nerd
Posts: 44
Joined: Fri Jun 11, 2004 2:52 pm
Location: Brno, CZ
Contact:

Alpha release: USB mouse driver v0.80

Postby Coda » Fri Jul 20, 2007 8:21 pm

I have decided to make the latest version of my USB
mouse driver available for public download. This is
considered an ALPHA release. There are things to fix,
things to add etc, but it is useable and works on
ST/TT/Falcon with EtherNat or NetUSBee, in TOS and
MiNT. As for MagiC, you'll have to try it, I don't own
it, so I can't develop for it.

Get it from the downloads page on
http://www.janthomas.org.uk/ and don't forget to read
the text file before you install it!

Obviously, if you don't have an EtherNAT
(http://nature.atari.org) or a NetUSBee
(http://hardware.atari.org) there's no point in
downloading it!

Please let me know if you are using it (via the email
address on my website, NOT the gmail spamtrap address
I use for usenet).

Many thanks for your patience and for being unwilling
ALPHA testers! :-)

Coda.

User avatar
daeghnao
Captain Atari
Captain Atari
Posts: 479
Joined: Wed Oct 27, 2004 12:41 pm
Location: York, UK
Contact:

Postby daeghnao » Sat Jul 21, 2007 9:14 am

Good to hear from you, and thanks for staying with us! Have downloaded, will hopefully get time to try it out on a couple of computers later today. I can grab a few different USB mice from our local computer recycling project if that would be useful for the testing?

Coda
Atari nerd
Atari nerd
Posts: 44
Joined: Fri Jun 11, 2004 2:52 pm
Location: Brno, CZ
Contact:

Postby Coda » Mon Jul 23, 2007 2:08 pm

Thanks very much for your offer of help. If you can wait a couple of days before going to all the trouble of testing a zillion mouses, I will add some stuff to the logfile particularly to identify the mouse brand and model. This used to work in an older version but I broke it somehow... :roll:

User avatar
Mark_G
Atari Super Hero
Atari Super Hero
Posts: 518
Joined: Sun Feb 05, 2006 11:55 am
Location: Belgium

Postby Mark_G » Tue Jul 24, 2007 5:11 pm

Tested yesterday with 2 MS mice, on my falcon with SBII.
Worked under mint and 80 lines mode, not in 40 lines mode.

Will send you extend log soon.

Thanks for the software.


Regards,

Mark.

Coda
Atari nerd
Atari nerd
Posts: 44
Joined: Fri Jun 11, 2004 2:52 pm
Location: Brno, CZ
Contact:

Postby Coda » Tue Jul 24, 2007 8:13 pm

Version 0.90 is out.

Please discard 0.80 and get the new one. The logging is better, which will help me fix those pesky mouse not detecting errors.

Thanks.
Coda.

http://www.janthomas.org.uk/

User avatar
calimero
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2286
Joined: Thu Sep 15, 2005 10:01 am
Location: STara Pazova, Serbia
Contact:

Postby calimero » Fri Jul 27, 2007 4:09 pm

Should this USB mouse work in any application (e.g. games)?

Coda
Atari nerd
Atari nerd
Posts: 44
Joined: Fri Jun 11, 2004 2:52 pm
Location: Brno, CZ
Contact:

Postby Coda » Fri Jul 27, 2007 5:02 pm

If the game is a GEM application then yes.

If you are talking about normal games then of course not.

Paolo
Captain Atari
Captain Atari
Posts: 460
Joined: Tue Sep 28, 2004 3:43 pm
Location: Italy

Postby Paolo » Wed Aug 01, 2007 1:54 pm

Hi, Coda!
Let me first tell you "Keep up the good job!".

Now, I'd like to know whether the driver can "drive" usb wireless mice or not.

Mind you, I didn't connect the usb wires to my EtherNat card yet, but i't be interesting to know. Also, do you know if the board can supply enough power to let such a wireless device work?

Ciao!

Coda
Atari nerd
Atari nerd
Posts: 44
Joined: Fri Jun 11, 2004 2:52 pm
Location: Brno, CZ
Contact:

Postby Coda » Wed Aug 01, 2007 2:25 pm

Now, I'd like to know whether the driver can "drive" usb wireless mice or not.


I have no idea. I guess it depends if the wireless function is transparent (which I think it would be) or not.

Mind you, I didn't connect the usb wires to my EtherNat card yet, but i't be interesting to know. Also, do you know if the board can supply enough power to let such a wireless device work?


USB devices have to meet strict power requirements, and in the worst case a device cannot draw more than 500ma from any one USB port, which is a LOT. I have only seen external 2.5" drives pull this much, and they were quite old ones. If you have any mouse that needs anything like this amount of current, throw it away! :)

Anyway, whether the ethernat can or can't supply 1A at 5V (for two USB ports) depends on 3 things.

1. The EtherNATs PCB design
2. The CT60's PCB design
3. Your PSU

Questions 1&2 should be directed to Nature, and Rodolphe Czuba respectively. To be honest, if I thought there was even a slim chance that there would be a problem I would have asked them years ago.

(these guys know what they are doing :wink: )


Social Media

     

Return to “Professionals”

Who is online

Users browsing this forum: No registered users and 3 guests