Page 1 of 1

Need help!

Posted: Thu Mar 24, 2016 6:41 am
by bearsoft
Hi! I'm new here...
I need some help to test my 3D-engine... on real Falcon 060 hardware...
I need to know if it works with or without sound, and how high the FPS is...

Watch demo.avi... using ARAnym...
http://www.fukt.bsnet.se/~bearsoft/Atari/

Re: Need help!

Posted: Thu Mar 24, 2016 2:24 pm
by galax
My Falcon is currently out of service waiting for me to get around to ordering a part. When I get it running again I'll give it a try, someone else who has a working machine will probably beat me to it though.

Re: Need help!

Posted: Thu Mar 24, 2016 2:32 pm
by bugs
Didnt you buy the extended warranty galax?

Re: Need help!

Posted: Thu Mar 24, 2016 2:54 pm
by Dal
I'm happy to try it out, however I'm not sure how to measure FPS on a real machine.

Re: Need help!

Posted: Thu Mar 24, 2016 3:15 pm
by galax
bugs wrote:Didnt you buy the extended warranty galax?


The extended warranty is a soldering iron ;)

Dal wrote:I'm happy to try it out, however I'm not sure how to measure FPS on a real machine.


Many phones can do "slo-mo" (really "high speed") video now (mine can do 240fps). Counting the number of identical frames (do a few and take the average) and dividing 240 by that number gives me the FPS.

Re: Need help!

Posted: Thu Mar 24, 2016 3:43 pm
by bearsoft
There is a FPS counter up in the left corner... If you look at the video "demo.avi"... you see it...

Re: Need help!

Posted: Thu Mar 24, 2016 4:30 pm
by fidzen
I have tested it on my Falcon 030 with a CT63 running at 90 MHz and with a SuperVidel card.
I got between 14 and 16 FPS.

Re: Need help!

Posted: Thu Mar 24, 2016 8:39 pm
by bearsoft
Okay, thanks for the help:)
I'm using "http://vincent.riviere.free.fr/soft/m68k-atari-mint/" to compile...

I think I have made a mistake when i compiled the project, but I'm not sure...
I think that I have not optimized for 060...

http://www.fukt.bsnet.se/~bearsoft/Atari/Twirl060.zip

Re: Need help!

Posted: Wed Mar 30, 2016 7:15 pm
by lotek_style
Will it be a big demo in the end?

Re: Need help!

Posted: Thu Apr 14, 2016 3:47 am
by bearsoft
It's only a test scene... that I took from one of my productions...
http://www.fukt.bsnet.se/~bearsoft/snow ... wninja.avi
I don't know if it's possible to port the demo to Atari Falcon 060... I think that some 3D objects have too much polygons...

I have tried to port my latest production to Atari Falcon 060, but I have some problem to load all of the scenes, some problem with memory management, new, malloc...
It works when It runs in Windows, but it crash in Araranym, if i load to much scenes...
For the moment I have made a bad fix, it takes a lots of memory to get all scenes to run in Aranym...

Re: Need help!

Posted: Mon May 23, 2016 4:06 pm
by bearsoft
It looks like the problem is only in TOS, if I run it from Mint Console it works...
I need help to test my new creation on real Atari Falcon 060 hardware...
See if the sound also works... music.mp3...
I'm sorry about the slow loading time...

Warning: Content May Be Offensive or Disturbing to Some Audiences

http://www.fukt.bsnet.se/~bearsoft/OneSidedLoveAtari/

Re: Need help!

Posted: Tue Oct 11, 2016 5:59 am
by mikro
If you need help, just shout. :) Nice scene, btw.

Re: Need help!

Posted: Tue Feb 06, 2018 12:28 pm
by bearsoft
I have issue with slow loading time.
I think that I have speed it up now.
At least in Aranym it's much faster.
But I need help to test it on real hardware.
Atari Falcon 060/Supervidel.

Re: Need help!

Posted: Tue Feb 06, 2018 4:09 pm
by marss
nice demo. eager to seeing a final version ;)

Re: Need help!

Posted: Thu Feb 08, 2018 7:43 am
by bearsoft
Thanks:)
Do you mean "One sided love"?
I released a new demo on a demo party that is called "Gerp".
I had some issues, loading time, the music is not properly synced.
Hard to test, when I have no real hardware...
Atari Falcon is both expensive, and hard to get.

The latest version of...
"One sided love"

http://www.fukt.bsnet.se/~bearsoft/OneS ... edlove.wmv
http://www.fukt.bsnet.se/~bearsoft/OneS ... edlove.zip

Re: Need help!

Posted: Thu Feb 08, 2018 4:01 pm
by marss
yes. I meant that one ;)
cool, you released another demo ;)

Re: Need help!

Posted: Fri Feb 09, 2018 12:03 pm
by wongck
Haha :thumbs:

Re: Need help!

Posted: Sat Feb 10, 2018 11:50 am
by lotek_style
Hi to be sure... is it THIS entry: https://demozoo.org/productions/183433/

So there was wrong naming in the results file then...

Re: Need help!

Posted: Thu Feb 15, 2018 6:25 pm
by bearsoft
Yes, that's the demo.
It's called "Frost".
I had some problem with it, too long loading time, so I had remove half of the demo.
And censor some scenes becuase of xxx-stuff.
When I showed it at the party on real hardware.

And the music was not correctly synced.
I have fixed faster loading time now.
But I need to fix syncing of music.

This is how it look when I run it in Aranym...
I have added music to the video.
There is some xxx-stuff... so if you can not handle it...
I maybe will release a censored version later... but this is the full version.
http://www.fukt.bsnet.se/~bearsoft/Frost8/frost.wmv