request hdd led for mega ste

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

bevenais
Atarian
Atarian
Posts: 5
Joined: Wed Nov 28, 2018 12:55 am

request hdd led for mega ste

Postby bevenais » Tue Feb 04, 2020 11:49 pm

Hi

Im looking for mega ste hdd yellow led

Can you help me ?

User avatar
Timnaber
Atari maniac
Atari maniac
Posts: 88
Joined: Fri Sep 21, 2018 3:12 pm

Re: request hdd led for mega ste

Postby Timnaber » Wed Feb 05, 2020 4:07 pm

Best Electronics

B&C Computer Visions
ST: TT030 10/32m; Falcon 030 14m(2); MSTe 4m; MST 4m(3); MST 4m AdSpeed; 1040STf 4m(4); ST 4m(2); MF 44 w/SCSI2SD(3); MF 30(3); MF30 w/Drem

8-Bit: 320XE w/Ultraspeed+/FIXXL; 320XE; 130XE w/Ultimate 1m; 600XL w/Ultimate 1m; 800XL w/Omnimon XL/Boss XL/Omniview XL; 800 w/Incognito; 800 48K; Black Box Enhanced(3); 1050 Super Archiver II; 1050 Happy(2); XF551 360K(2); XF551 720K; HD Tower 480m

tzok
Captain Atari
Captain Atari
Posts: 194
Joined: Fri Jun 30, 2017 7:22 pm
Location: Bielsko-Biala, PL
Contact:

Re: request hdd led for mega ste

Postby tzok » Wed Feb 05, 2020 10:23 pm

Isn't it just a regular LED? I guess, the "lens" is separate, like in SH205/Megafile.

User avatar
Timnaber
Atari maniac
Atari maniac
Posts: 88
Joined: Fri Sep 21, 2018 3:12 pm

Re: request hdd led for mega ste

Postby Timnaber » Thu Feb 06, 2020 4:27 pm

I have no idea. When I bought the Hard Drive Kit for a MSTE from Best, it came with a defective LED. I told Brad about it and he sent me another to replace it. So I know they have these laying around.
ST: TT030 10/32m; Falcon 030 14m(2); MSTe 4m; MST 4m(3); MST 4m AdSpeed; 1040STf 4m(4); ST 4m(2); MF 44 w/SCSI2SD(3); MF 30(3); MF30 w/Drem

8-Bit: 320XE w/Ultraspeed+/FIXXL; 320XE; 130XE w/Ultimate 1m; 600XL w/Ultimate 1m; 800XL w/Omnimon XL/Boss XL/Omniview XL; 800 w/Incognito; 800 48K; Black Box Enhanced(3); 1050 Super Archiver II; 1050 Happy(2); XF551 360K(2); XF551 720K; HD Tower 480m

Count
Atari nerd
Atari nerd
Posts: 47
Joined: Sat Sep 16, 2017 9:15 am
Location: Castrop-Rauxel, Germany

Re: request hdd led for mega ste

Postby Count » Thu Feb 06, 2020 6:09 pm

It's a regular LED. I replaced mine a few weeks ago after one pin of the old one broke off because of rust. 8O

susher
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 103
Joined: Sat Oct 03, 2015 7:06 pm

Re: request hdd led for mega ste

Postby susher » Fri Feb 07, 2020 4:21 pm

It's a 2mm 2.1V LED, nothing special. It's held in a PVC grommet.

User avatar
DarkLord
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 4418
Joined: Mon Aug 16, 2004 12:06 pm
Location: Prestonsburg, KY - USA
Contact:

Re: request hdd led for mega ste

Postby DarkLord » Fri Feb 07, 2020 6:19 pm

Leech over at Atari Age is looking at making replacements for this. He's already
done a replacement for the power LED on the Mega STe. Good stuff.

https://atariage.com/forums/topic/30093 ... lacements/
Welcome To DarkForce! http://www.darkforce.org "The Fuji Lives.!"
Atari SW/HW based BBS - Telnet:darkforce-bbs.dyndns.org 520

User avatar
leech
Atari God
Atari God
Posts: 1267
Joined: Tue Dec 01, 2015 3:26 pm

Re: request hdd led for mega ste

Postby leech » Fri Feb 07, 2020 7:22 pm

DarkLord wrote:Leech over at Atari Age is looking at making replacements for this. He's already
done a replacement for the power LED on the Mega STe. Good stuff.

https://atariage.com/forums/topic/30093 ... lacements/

Yeah, I'll start creating the yellow LEDs tonight. I just need to measure out the wire, cut some out and then do the soldering / housing. Should be able to make these easily. At least now that I have a proper crimper for them.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)

User avatar
leech
Atari God
Atari God
Posts: 1267
Joined: Tue Dec 01, 2015 3:26 pm

Re: request hdd led for mega ste

Postby leech » Fri Feb 07, 2020 7:23 pm

susher wrote:It's a 2mm 2.1V LED, nothing special. It's held in a PVC grommet.

I ended up getting 3mm ones, which should show up today. I'll test the grommets that I bought, but they fit the power LED amazingly well.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (VBXE, U1MB, Stereo POKEY)
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)

User avatar
Bikerbob
Captain Atari
Captain Atari
Posts: 372
Joined: Wed Mar 23, 2016 2:46 am
Location: Oakville, ON, Canada
Contact:

Re: request hdd led for mega ste

Postby Bikerbob » Fri Feb 07, 2020 11:49 pm

Count wrote:It's a regular LED. I replaced mine a few weeks ago after one pin of the old one broke off because of rust. 8O



Just happened to me Yesterday.. from the hdd ST157n - yellow.. I find yellow harder to find.. measured mine 3mm - and find just a pack of say 5 3mm led is hard now.. you tend to have to buy 50 or something from Amazon just to find them.

James

Count
Atari nerd
Atari nerd
Posts: 47
Joined: Sat Sep 16, 2017 9:15 am
Location: Castrop-Rauxel, Germany

Re: request hdd led for mega ste

Postby Count » Sat Feb 08, 2020 3:32 pm

Bikerbob wrote:
Count wrote:It's a regular LED. I replaced mine a few weeks ago after one pin of the old one broke off because of rust. 8O

Just happened to me Yesterday.. from the hdd ST157n - yellow.. I find yellow harder to find.. measured mine 3mm - and find just a pack of say 5 3mm led is hard now.. you tend to have to buy 50 or something from Amazon just to find them.


I desoldered it from an IDE-CF adapter which I don't need anymore.


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 7 guests