Screen flickering on Atari STe (not PSU-related)

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, spiny, Greenious, Moderator Team

theimann
Retro freak
Retro freak
Posts: 10
Joined: Tue Aug 01, 2017 1:00 pm

Screen flickering on Atari STe (not PSU-related)

Postby theimann » Tue Jul 17, 2018 2:07 pm

Dear Atari Community,

Two of my Atari 1040 STe run into screen flickering issues after 5-15 minutes.

I suspected defective capacitors on the PSU and replaced both of them with recapped replacements, but that didn't fix it. I spent a lot of time researching the web for answers, but to no avail. I'm using a SCART connection to my LCD TV, but I am pretty sure that the problem needs to be fixed on the ST side since the issue seems to be heat-related.

Here's a video of the behavior: https://www.youtube.com/watch?v=5u0oJZwflaA

It starts with the screen flickering every few seconds, then the frequency increases and eventually the screen breaks down.

The only idea I have left is checking the motherboards with a laser thermometer or use cooling spray (is this even safe?) to locate the faulty component.

Your advice is most welcome - please help me get my beloved STEs back in working order :)

theimann
Retro freak
Retro freak
Posts: 10
Joined: Tue Aug 01, 2017 1:00 pm

Re: Screen flickering on Atari STe (not PSU-related)

Postby theimann » Sun Aug 19, 2018 4:33 pm

A quick follow-up in case anyone is running into the same issues. Never identified the cause, I bought an SC1224 and the issues never came up again. Seems to be related to the TV/Scart signal.

mlynn1974
Captain Atari
Captain Atari
Posts: 205
Joined: Mon Mar 03, 2008 10:33 pm
Contact:

Re: Screen flickering on Atari STe (not PSU-related)

Postby mlynn1974 » Sun Aug 19, 2018 11:14 pm

I get this effect when my STFM and when any PS2 (Fat or slim) is connected to my Samsung 40" LCD TV. In this TV there is an old analogue tuner which is now no longer required because analogue transmitters are switched off and a Digital Terrestrial TV (Freeview) Tuner. I assume this interference is due to poor separation or shielding between the old analogue tuner and the SCART circuitry. I just live with it. My newer Panasonic TV is fine.

For a while in the UK households were sent interference suppressors for Freeview equipment which might get interference from 4G mobile phone signals but I don't think this is the problem in this case.
Still got, still working: Atari 4Mb STe, 520STFM, 2.5Mb STF.
Hardware: Cumana CSA 354, Ultimate Ripper, Blitz Turbo, Synchro Express II (US and UK Versions).

theimann
Retro freak
Retro freak
Posts: 10
Joined: Tue Aug 01, 2017 1:00 pm

Re: Screen flickering on Atari STe (not PSU-related)

Postby theimann » Mon Aug 27, 2018 2:44 pm

It has to be a combination of two unrelated issues - only 2 of my 3 STEs are showing this behavior, but only when connected to the LCD TV and only after approx. 10-20 minutes.

I suspect it's a cap on the main board (not PSU) that is somehow related to the RGB/composite output (see also viewtopic.php?t=24839).


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 6 guests