SC1224 / Philips CM 8833 MK I colour monitor problems

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

Chandler
Atari God
Atari God
Posts: 1170
Joined: Tue Feb 14, 2006 12:15 am

SC1224 / Philips CM 8833 MK I colour monitor problems

Postby Chandler » Fri Jul 08, 2016 10:30 am

can anyone advise what could be the likely issue with the following monitors?



1: SC 1224 colour monitor, PSU OK as i tested and used it in another monitor

basically switch on monitor and green LED illuminates and you hear the static from the tube as though it's all starting up correctly

then! suddenly the green led goes off and the tube sounds like it's been switched off

then green LED back on and tube sounds like it's starting up again!

anyway this loop carries on and on so i switched it off

any ideas?


2: Philips CM 8833 MK I RGB colour scart type monitor

switched on, picture came on for a while then started to go dim, crackling sound from inside monitor and poof! picture gone!

swapped the psu and nothing so i guess it's something on the main PCB or LOPT or tube

again any ideas?

Silly_Pony
Captain Atari
Captain Atari
Posts: 216
Joined: Sat Jul 02, 2011 7:18 pm

Re: SC1224 / Philips CM 8833 MK I colour monitor problems

Postby Silly_Pony » Mon Jul 11, 2016 9:54 pm

Had the problem you're having with the first one before. Was LOPT on mine, but could also be other things.
1040STe, 1040STf

Chandler
Atari God
Atari God
Posts: 1170
Joined: Tue Feb 14, 2006 12:15 am

Re: SC1224 / Philips CM 8833 MK I colour monitor problems

Postby Chandler » Wed Jul 13, 2016 7:02 am

ok thanks

I have another faulty SC 1224 also

switch on, power LED illuminates but very dimly, screen is black and no sound, no "static" sounds from tube starting up either

sounds like a power supply issue so I changed it for the one in the other monitor but it does the same

any ideas?

Silly_Pony
Captain Atari
Captain Atari
Posts: 216
Joined: Sat Jul 02, 2011 7:18 pm

Re: SC1224 / Philips CM 8833 MK I colour monitor problems

Postby Silly_Pony » Wed Jul 13, 2016 7:49 am

I'd swap the second 1224's LOPT into the first and see what happens. I'm no monitor expert, but there's always a few on amibay who are. Particularly of the Philips 8833/Commodore 1084.
1040STe, 1040STf


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 3 guests