CM8833 monitor just broke - making a high pitched whine

Troubles with your machine? Just want to speak about the latest improvements? This is the place!

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2457
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

CM8833 monitor just broke - making a high pitched whine

Postby spiny » Sun Feb 22, 2015 6:56 pm

Just popped to the kitchen to put the kettle on and when I came back to my ST, the Philips CM8833 monitor was blank and making a high pitched squeal. When I switched it off, the squeal went down in note, almost on steps.
Is this a 'it might kill you fiddling with LOPT things' fault or perhaps something more simple ?

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2457
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: CM8833 monitor just broke - making a high pitched whine

Postby spiny » Sun Feb 22, 2015 7:02 pm

also noticed the the little light by the power button isn't lit, so could be a PSU issue ?

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2457
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: CM8833 monitor just broke - making a high pitched whine

Postby spiny » Sun Feb 22, 2015 7:21 pm

ah, juts found this thread, not looking good for my monitor :/ viewtopic.php?t=18380

User avatar
paul92706
Atari God
Atari God
Posts: 1394
Joined: Mon Apr 25, 2011 4:28 am
Location: Orange, CA

Re: CM8833 monitor just broke - making a high pitched whine

Postby paul92706 » Sun Feb 22, 2015 7:55 pm

spiny wrote:Just popped to the kitchen to put the kettle on and when I came back to my ST, the Philips CM8833 monitor was blank and making a high pitched squeal. When I switched it off, the squeal went down in note, almost on steps.
Is this a 'it might kill you fiddling with LOPT things' fault or perhaps something more simple ?

hI Spiny, unfortunatly your monitor "Go bye bye" :? my SC1224 monitor at the time did the same thing a high pitch and ZAaaappp!!!! no picture. At the time i didn't have expierience with fixing monitors (and still don't :lol: ), so i tossed it wish i would of kept it and fixed it! :roll: I'm sure someone here with knowledge will help you, it maybe something simple, i hope! :) goodluck buddy!
Atari Falcon CT60/CTPCI 14MB+ 512mb ATI9250 + NetUSBee
Atari Falcon030 CF 4gb + NetUSBee+ 14MB Ram
Atari TT030 2meg STRAM/16meg TTRAM + Nova Adaptor +Maxtor SCSI HD + DaynaPort Pocket SCSI

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2457
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: CM8833 monitor just broke - making a high pitched whine

Postby spiny » Sun Feb 22, 2015 9:26 pm

found these at a price I can live with if it doesn't fix the issue:

http://www.donberg.ie/descript/h/hr_7506.htm

apparently its the part that usually breaks - worth a go ?

User avatar
alexh
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2672
Joined: Wed Oct 20, 2004 1:52 pm
Location: UK - Oxford
Contact:

Re: CM8833 monitor just broke - making a high pitched whine

Postby alexh » Sun Feb 22, 2015 9:52 pm

Remember you will probably have to replace HOT (Horizontal Output Transistor) too.

I would disassemble, discharge, check out the LOPT & HOT to make sure you buy the right ones.

Check for any burnt out resistors etc. while doing it.

User avatar
spiny
Disk Imager Supreme
Disk Imager Supreme
Posts: 2457
Joined: Mon Aug 11, 2003 11:53 pm
Location: just outside bristol
Contact:

Re: CM8833 monitor just broke - making a high pitched whine

Postby spiny » Sun Feb 22, 2015 11:02 pm

cool :) I'll have a look.

junosix
Captain Atari
Captain Atari
Posts: 235
Joined: Sun Jul 08, 2007 3:22 pm
Location: Plymouth

Re: CM8833 monitor just broke - making a high pitched whine

Postby junosix » Mon Feb 23, 2015 3:50 pm

Yeah, defo give the idea of replacing the LOPT some thought, a friend of mine recently had a CM8833-II go pop and took it to a TV repair place, they initially said it was the LOPT and no way could a replacement but we found a new LOPT on the Donberg site and that was just the ticket. Worth replacing the caps whilst the board is out too as they'll be 20+ years old.

Guest

Re: CM8833 monitor just broke - making a high pitched whine

Postby Guest » Mon Feb 23, 2015 6:22 pm

my advice is the find the line output transistor {HOT} TS467 you should check the transistor isnt short
use a DVM set to beep test
power off for five mins then test between the center pin and the grounding {emiter of the transistor connects to ground}
if it beeps its gubbed if you know how to use diode test if it reads incorrectly then its gubbed
this is a BU508A so has no damper diode inside it the damper is D467

the BU508Ais on the right side on the metal plate to the right of the lopt


then disconnect with a desolder tool the center pin {collector} {should have 123v here}

my experiance if it whines then the HOT is driving a bad trippler

now turn it on
does it still whine
then something on the output of the psu has failed or the psu driver chip / circuit has a problem
a capacitor etc.... {like c470 469 is short}

if it doesnt whine the lopt is prob dead ...and the green led should come back on
tells you the psu is ok and not loaded anymore...
i think the lopt trippler has died
so you can find the transformer eary easily
making the tube safe to unclip the anode cap {round cap comes from the lopt}
is to use two screwdrivers with metal shafts slide one over the other place one on the black surface
at the back of the tube
slide the other one over it under the cap to the center connector
you may get a spark

so once youve done this its safe to unplug

when working on live equipment place your left hand in your pocket
and work with the right only

this is easy to solve
and as said change out the caps look for any damaged poly caps etc like c470 and c469
this fault can also be caused by some bad caps and the damper diode in the hot circuit fails
replace the caps and the diode and it will come up
so dont give up on the lopt till you do this center pin test

service manaul @
http://pdf.textfiles.com/manuals/ARCADE ... ish%5D.pdf

there is a few versions of cm8833 so you need to get the number from the lopt then look online for a supplier {youll find it}
if you cant find it let me know ill check out my catalogues

Guest

Re: CM8833 monitor just broke - making a high pitched whine

Postby Guest » Mon Feb 23, 2015 6:58 pm

http://www.donberg.co.uk/catalogue/line ... _7533.html

about 30 euros or less...

this one is the right one for some cm8833 .,..

the only way to be sure is the match the details on the page's with the label on the one already fitted

here is a bit of text says it all http://www.gifford.co.uk/~coredump/cm8833.htm

User avatar
tjlazer
Atari Super Hero
Atari Super Hero
Posts: 614
Joined: Mon Feb 02, 2004 4:00 am
Location: Tacoma, WA USA
Contact:

Re: CM8833 monitor just broke - making a high pitched whine

Postby tjlazer » Mon May 21, 2018 7:39 am

I am having the same issue with my SC 1435. High pitch whine on power on, green LED is off. Ordered and replaced the Flyback and the problem persists. Anyone that can help me to test other components on this monitor? I believe this monitor is the same as the CM8833.
Atari Computer Collector since 1984

From the 8-bit Atari 400 to the 32-bit Atari TT030!


Social Media

     

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 3 guests