NVDI 5 - missing black/grey on 16M colours printout

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Tue Aug 29, 2017 8:01 am

I am trying to print out some docs from Papyrus 5.15, using HP Deskjet 1200 driver of NVDI 5.03 with 16M colour.
The output was mostly blank except for the areas of graphics and coloured text.
The graphics and coloured text was exactly where they are suppose to be, but there was no black colour text.
The graphics looks horrible as it lacks black/grey.

Have anyone encountered this?

If i use 8 colours or black & white mode, the entire doc is printed.
With 8 colours, there was lots of dithering which makes the graphics looks bad.
It has the 16M colours mode but why does it not print black text and some colours of the graphics ??
The graphics are in truecolour anyway.

So I wrote a small program to print some text and an full RGB graphic to the printer, the results were similar to Papyrus.
Only black & white and 8-colours, the text and graphics are printed.
To test further, I printed out text using the colours from Colour Lookup table ( CLUT) and found that red, green, blue, yellow in various shades were printed out but there was no black nor grey shades. Also small graphics are missing lots of colours at lower corner.
( attached the pdf scan of the printout
vdi_text_colur_test.pdf
)

Any one any ideas on how to fix this or load the correct CLUT onto the driver ?
You do not have the required permissions to view the files attached to this post.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
AdamK
Captain Atari
Captain Atari
Posts: 232
Joined: Wed Aug 21, 2013 8:44 am

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby AdamK » Tue Aug 29, 2017 12:39 pm

Maybe you're out of black ink?
Atari: FireBee, Falcon030 + CT60e + SuperVidel + SvEthlana, TT, 520ST + 4MB ST RAM + 8MB TT RAM + CosmosEx + SC1435, 1040STFM + UltraSatan + SM124, 1040STE 4MB ST RAM + 8MB TT RAM + CosmosEx + NetUSBee + SM144 + SC1224, 65XE + U1MB + VBXE + SIDE2, Jaguar, Lynx II, 2 x Portfolio (HPC-006)

Adam Klobukowski [adamklobukowski@gmail.com]

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Tue Aug 29, 2017 1:16 pm

LOL, nice one.
Didn't even cross my mind about that because my son is printing his home work out on the same printer.
Also if select black & white, the whole page comes out properly printed.

Not an ink or printer hardware problem.

It is a NVDI problem.... or lack of other printer drivers.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Rustynutt
Captain Atari
Captain Atari
Posts: 358
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby Rustynutt » Tue Aug 29, 2017 7:21 pm

Did you try changing to 16bit color?

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Tue Aug 29, 2017 11:24 pm

Rustynutt wrote:Did you try changing to 16bit color?


No I did not. How to do that?
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Faucon2001
Atari Super Hero
Atari Super Hero
Posts: 640
Joined: Sat Oct 26, 2013 11:19 pm
Location: Brasil
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby Faucon2001 » Tue Aug 29, 2017 11:52 pm

Is your printer a DJ 1200 or a more recent model?
Try a different Driver. Some are using RLE compression, other different flavor of PCL and it is not always working well with new printer or similar model. Generally I have reasonable results with DJ550C NVDI Driver when printing on my Laserjet color, except that colors are less dense because there is no bleeding on a laser printer compared to an inkjet.
Philippe

Firebee, Falcon, STE, Aranym Box, Hatari Pi Box.
My music http://www.philippeworld.net/
My photography http://phil-67.deviantart.com/
EasyAraMint, BeeKey and BeePi https://sites.google.com/site/emaappsarch/home

Faucon2001
Atari Super Hero
Atari Super Hero
Posts: 640
Joined: Sat Oct 26, 2013 11:19 pm
Location: Brasil
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby Faucon2001 » Tue Aug 29, 2017 11:55 pm

wongck wrote:
Rustynutt wrote:Did you try changing to 16bit color?


No I did not. How to do that?

In NVDI printer cpx, set the color output to 16M colors instead of 8 or B&W. it's in the first setup page together with resolution
Philippe

Firebee, Falcon, STE, Aranym Box, Hatari Pi Box.
My music http://www.philippeworld.net/
My photography http://phil-67.deviantart.com/
EasyAraMint, BeeKey and BeePi https://sites.google.com/site/emaappsarch/home

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Wed Aug 30, 2017 3:29 am

Faucon2001 wrote:
wongck wrote:
Rustynutt wrote:Did you try changing to 16bit color?


No I did not. How to do that?

In NVDI printer cpx, set the color output to 16M colors instead of 8 or B&W. it's in the first setup page together with resolution


But 16M colours means 16 millions colours is often called True Colour (in non-Atari world) is 24-bits, not 16-bits.
While B&W is 1 bit and 8-colours is 3-bits.

So I do not know how to select 16-bits. 16-bits is called High Colour and is 64K colours.

I am trying to print 16M colours.... that's the one that is missing the black/grey and having the issue.
For both B&W and 8-colours, the printout is as expected.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
leech
Atari Super Hero
Atari Super Hero
Posts: 851
Joined: Tue Dec 01, 2015 3:26 pm

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby leech » Wed Aug 30, 2017 5:06 am

Don't forget 32bit colour, which has the extra 8bit for alpha/transparency channel... then of course to confuse matters, you have 30bit, which is like a billion colours? 10 bit per RGB. Then I think they finally added 40bit, which is 30bit with alpha/transparency.

But the fun part? I found a pair of headphones one day in an electronics store that touted '16 million colours'. Yup, that's right, these headphones had light bars on the sides that were capable of 24bit colour...

Anyhow, this issue sounds almost like the opposite of this bug that ghostscript had for a while where it would just print solid black.

How's this for success? Though I think this is what you were trying? I just dragged the PDF over to the PHERP icon.
VDI print test.jpg
You do not have the required permissions to view the files attached to this post.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (fully upgraded (soon!))
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Wed Aug 30, 2017 5:40 am

Faucon2001 wrote:Is your printer a DJ 1200 or a more recent model?
Try a different Driver. Some are using RLE compression, other different flavor of PCL and it is not always working well with new printer or similar model. Generally I have reasonable results with DJ550C NVDI Driver when printing on my Laserjet color, except that colors are less dense because there is no bleeding on a laser printer compared to an inkjet.

The DJ1200 was the NVDI driver I used.
I cannot remember the results of using the DJ550C, but may be worst than DJ1200 as I had DJ1200 as the default.
I will need to check again the results tonight.

Ok, thanks for the explanation on the sparse coloration.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Wed Aug 30, 2017 6:54 am

leech wrote:Don't forget 32bit colour, which has the extra 8bit for alpha/transparency channel... then of course to confuse matters, you have 30bit, which is like a billion colours? 10 bit per RGB. Then I think they finally added 40bit, which is 30bit with alpha/transparency.


well the printer colour control panel does not specify the bits it is using, but one can deduce the amount of bits it is using based on the number of colours. There was no specific 16 bits and none of the number of colours correspond to 16 bits.
I tot u knew of a way to patch it or write somewhere in the config file to get it to 16 bits.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Wed Aug 30, 2017 7:02 am

leech wrote: Though I think this is what you were trying? I just dragged the PDF over to the PHERP icon.

Can you drag and drop this your printer via PHERP icon and see if it prints out "hello".
Settings are 16M colours. Please unzip the file first. Thanks. :cheers:
parse_pcl.zip
You do not have the required permissions to view the files attached to this post.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Rustynutt
Captain Atari
Captain Atari
Posts: 358
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby Rustynutt » Wed Aug 30, 2017 7:16 am

I don't remember. Know between all the bit modes, onscreen display can get hosed.

Have you tried printing a photo say from Photoline to the printer?

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Wed Aug 30, 2017 12:08 pm

No not photoline but I tried papillon and Papyrus X.... both on Mint and TOS, all same results.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
leech
Atari Super Hero
Atari Super Hero
Posts: 851
Joined: Tue Dec 01, 2015 3:26 pm

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby leech » Wed Aug 30, 2017 2:00 pm

wongck wrote:
leech wrote: Though I think this is what you were trying? I just dragged the PDF over to the PHERP icon.

Can you drag and drop this your printer via PHERP icon and see if it prints out "hello".
Settings are 16M colours. Please unzip the file first. Thanks. :cheers:
parse_pcl.zip


It doesn't print out Hello.

It firstly tells me it should be an A4 instead of Letter paper.
Then prints out

Code: Select all

User: PHSW
Host: easymint
Class: easymint
Job: PARSE_PC.PCL


I'm guessing it's not really interpreting the file?
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (fully upgraded (soon!))
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)

User avatar
leech
Atari Super Hero
Atari Super Hero
Posts: 851
Joined: Tue Dec 01, 2015 3:26 pm

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby leech » Wed Aug 30, 2017 2:04 pm

wongck wrote:No not photoline but I tried papillon and Papyrus X.... both on Mint and TOS, all same results.


How does one acquire Papyrus X these days? I am not sure if I have Photoline laying around either.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (fully upgraded (soon!))
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1021
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby TheNameOfTheGame » Wed Aug 30, 2017 5:15 pm

leech wrote:
wongck wrote:No not photoline but I tried papillon and Papyrus X.... both on Mint and TOS, all same results.


How does one acquire Papyrus X these days? I am not sure if I have Photoline laying around either.


As far as I know you can't since 16/32 shut down :?

PM sent.

Rustynutt
Captain Atari
Captain Atari
Posts: 358
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby Rustynutt » Wed Aug 30, 2017 6:28 pm

Gerhard quit supporting the TOS market years ago. He said, in an email, back in the booming days, there was a lot of "piracy", which kind of drove work off to what he now does (likely the best manipulation soft out there today, IMHO). Also, there was no decent C++ package. With emulation how, the last could likely be easily overcome. The 1st I'm sure he would question, as he's moved well past working for the love of a platform, to love of his work.
Maybe someone could approach with respect to what a "group" price might be for the source, if it still exist.

You should find Photoline in most any archive. Without the serial number, some features are limited, but still very useful. Maybe ask Uwe his opinion about passing around old S/N's :(

Wongck, kind of points to the driver, as said above.
Maybe it's updated in the new Calamus package :)
I'm tempted to put it on my Christmas list.

User avatar
leech
Atari Super Hero
Atari Super Hero
Posts: 851
Joined: Tue Dec 01, 2015 3:26 pm

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby leech » Wed Aug 30, 2017 6:38 pm

I've come close a few times to buying Calamus (not the 999 package, but the 99 one) but wanted to make sure it worked right as it requires 800x600@256 minimum. I need to figure out how to reset the demo and see if printing works. Almost bought Pagestream for Linux, but it hasn't been updated in like 6 years now and is still 32bit... and since they dropped support for TOS, I also feel less inclined

But that's going a bit off topic, I mainly wanted to see if I could print correctly as it sounds like wongck is in need of a better printer! HP LaserJet Pro M477fdn is my model.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (fully upgraded (soon!))
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Thu Aug 31, 2017 1:01 am

leech wrote:It doesn't print out Hello.

It firstly tells me it should be an A4 instead of Letter paper.
Then prints out

Code: Select all

User: PHSW
Host: easymint
Class: easymint
Job: PARSE_PC.PCL


I'm guessing it's not really interpreting the file?


Weird....
It printed out the control file for the LPD. I do not know why it is doing that.
For me, it prints out an empty page ( as I expected as there is no black from NVDI for 16M colours ) on my home HP and my office MFP.
I am also using LPR mode of PHSW.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Thu Aug 31, 2017 1:03 am

Rustynutt wrote:You should find Photoline in most any archive. Without the serial number, some features are limited, but still very useful. Maybe ask Uwe his opinion about passing around old S/N's :(


AFAIK, photoline is now freeware and you can get a proper serial for it.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 11924
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby wongck » Thu Aug 31, 2017 1:05 am

leech wrote:
wongck wrote:No not photoline but I tried papillon and Papyrus X.... both on Mint and TOS, all same results.


How does one acquire Papyrus X these days? I am not sure if I have Photoline laying around either.


I don't use Papyrus X as it is in German, I used it only for this test.
My Stuff: FB/Falcon CT63+CTPCI_ATI_RTL8139 14+512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Rustynutt
Captain Atari
Captain Atari
Posts: 358
Joined: Wed Mar 21, 2012 7:38 am
Location: Oregon
Contact:

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby Rustynutt » Thu Aug 31, 2017 1:18 am

wongck wrote:
Rustynutt wrote:You should find Photoline in most any archive. Without the serial number, some features are limited, but still very useful. Maybe ask Uwe his opinion about passing around old S/N's :(


AFAIK, photoline is now freeware and you can get a proper serial for it.


I never looked into finding it, I purchased it years ago :)

User avatar
TheNameOfTheGame
Atari God
Atari God
Posts: 1021
Joined: Mon Jul 23, 2012 8:57 pm
Location: Almost Heaven, West Virginia

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby TheNameOfTheGame » Thu Aug 31, 2017 2:11 am

wongck wrote:
leech wrote:
wongck wrote:No not photoline but I tried papillon and Papyrus X.... both on Mint and TOS, all same results.


How does one acquire Papyrus X these days? I am not sure if I have Photoline laying around either.


I don't use Papyrus X as it is in German, I used it only for this test.


Papyrus X is released in English by 16/32 systems. I bought it direct from Nick.

User avatar
leech
Atari Super Hero
Atari Super Hero
Posts: 851
Joined: Tue Dec 01, 2015 3:26 pm

Re: NVDI 5 - missing black/grey on 16M colours printout

Postby leech » Thu Aug 31, 2017 4:15 am

Photoline thread viewtopic.php?t=23553 You can download it and there is a serial at http://acp.atari.org/

Looks like an awesome program, hadn't ever heard of it before.
Atari 8Bits: 800xl, 600xl, XEGS, 800, 130xe, 130xe (fully upgraded (soon!))
Atari STs: 1040STf (broken shifter), 1040STe, Mega STe, TT030, Falcon (CT60e, SuperVidel)


Social Media

     

Return to “Applications”

Who is online

Users browsing this forum: No registered users and 2 guests