[help] trouble with creating IDE hdd partition.

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

[help] trouble with creating IDE hdd partition.

Postby atarifred » Tue Mar 14, 2017 5:54 pm

Hello.

I try several methods to format my IDE hdd for my atari STf.

Using windows 10, windows XP to create 512mb FAT16 principal partition.
Trying to make one or two logical fat16 partiton max of 1000mb.

My driver BIGDOS.PRG and IDE_7.PRG found the partitons, and sometimes not.

I use usb to ide, and internal ide of pc for partitioning, without success.

The only way i found is to drimg135 for copy a 1gb image from PP.
http://atari.8bitchip.info/DiskImgPP1.html

I never found this software too.
Image

When i use drimg, and send software on hdd prepared, sometime is become unreadable :/
The os show correct letter, but can't open the partition.

IS a simpy way to create partition ?

Thanks by advance, o'm totally disapointed
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2978
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: [help] trouble with creating IDE hdd partition.

Postby AtariZoll » Tue Mar 14, 2017 6:32 pm

All what you described indicates unreliable work. Most likely write is main problem. Is it classic hard disk or CF card ?
Famous Schrodinger's cat hypothetical experiment says that cat is dead or alive until we open box and see condition of poor animal, which deserved better logic. Cat is always in some certain state - regardless from is observer able or not to see what the state is.

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Tue Mar 14, 2017 6:47 pm

I trying booth ide and cf card.

bigdos,show the partition, in one 3.5 ide, in the 2.5, i didn't make it re-work :/

Some harddrive have worked, reput on pc for tranfert, and i cn't reread them on the atari :/

Is simple way to make it working ?
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Tue Mar 14, 2017 6:51 pm

I use an ide soldered in my 68000. Not an ultrasatan or other thing.
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Tue Mar 14, 2017 10:00 pm

Is someone has this sofware ???

Image

I think it may help me :p
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Tue Mar 14, 2017 11:30 pm

No one could help me ? i spended 50 hours for nothingtrying to :/
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

AtariZoll
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2978
Joined: Mon Feb 20, 2012 4:42 pm
Contact:

Re: [help] trouble with creating IDE hdd partition.

Postby AtariZoll » Wed Mar 15, 2017 7:52 am

I don't think that it is SW problem, so you should go on checking hardware. But that is not easy. Did you try with some Sandisk CF card ? They are most reliable with old computers.
Famous Schrodinger's cat hypothetical experiment says that cat is dead or alive until we open box and see condition of poor animal, which deserved better logic. Cat is always in some certain state - regardless from is observer able or not to see what the state is.

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Wed Mar 15, 2017 2:56 pm

I've no cf sandisk card.
The cards and hdd works in my pc or amiga.
The only things who works, it's drimg135, with an img of 1gb, with hdd 3.5p.
No problem with a 3.5 ide hdd, but impossible to put in in an stf box.
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

Maeke
Captain Atari
Captain Atari
Posts: 311
Joined: Sun Mar 13, 2016 1:54 pm

Re: [help] trouble with creating IDE hdd partition.

Postby Maeke » Wed Mar 15, 2017 6:11 pm

atarifred wrote:I've no cf sandisk card.
The cards and hdd works in my pc or amiga.
The only things who works, it's drimg135, with an img of 1gb, with hdd 3.5p.
No problem with a 3.5 ide hdd, but impossible to put in in an stf box.

Some cards WILL work on pc or amiga but NOT on atari, especially on ide adapters made for the st line, so it's not because it works on another computer that it will work on an atari.

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Wed Mar 15, 2017 7:40 pm

ok. my trouble concern more hdd than ide cf card in fact...

Hard to have an hdd works.

Can we forgot CF card please ?
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Fri Mar 17, 2017 4:42 pm

No one has a good tools for partitioning ?
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

User avatar
rian_ata
Captain Atari
Captain Atari
Posts: 269
Joined: Mon Apr 24, 2006 10:00 pm
Location: Netherlands
Contact:

Re: [help] trouble with creating IDE hdd partition.

Postby rian_ata » Sat Mar 18, 2017 12:41 am

atarifred wrote:No one has a good tools for partitioning ?


There are plenty of good tools, almost all available drivers have partitioning tools as well. If partitioning software doesn't work, maybe it is not a software problem but a hardware problem. Personally, I always use HDDrive.

Are you aware of the partition size limitations of the different TOS versions?

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Sat Mar 18, 2017 8:10 am

Yes, i use first partition as primary with 500mb max, then logical of 500mb max, max 13.
My problem is the same with only one partition of 128mb for example. MBR, and dos fat 16.

When i prepare my hdd from the pc, i've no problem with the pc.

When i put the hdd in my atari, i can't make it autoboot, and saw the partitions :/
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Tue Mar 21, 2017 5:54 pm

Hello.

No one has a cool software for partitionning ???
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

Maeke
Captain Atari
Captain Atari
Posts: 311
Joined: Sun Mar 13, 2016 1:54 pm

Re: [help] trouble with creating IDE hdd partition.

Postby Maeke » Wed Mar 22, 2017 2:21 pm

try this, with cautions: http://www.labibleatari.fr/Articles/art ... rATARI.zip

french how-to http://fr.meric.free.fr/Articles/articl ... idest.html

Be carefull, if you have more than one drive on your pc, verify the selected drive is the good one.

If you are under windows 8.1 or 10 you need a few preparation steps https://www.howtogeek.com/167723/how-to ... d-drivers/
Last edited by Maeke on Wed Mar 22, 2017 5:04 pm, edited 1 time in total.

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Wed Mar 22, 2017 3:15 pm

maeke : thanks thanks thanks
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

Maeke
Captain Atari
Captain Atari
Posts: 311
Joined: Sun Mar 13, 2016 1:54 pm

Re: [help] trouble with creating IDE hdd partition.

Postby Maeke » Wed Mar 22, 2017 5:03 pm

atarifred wrote:maeke : thanks thanks thanks

So it worked?

atarifred
Atari nerd
Atari nerd
Posts: 48
Joined: Sun Feb 05, 2017 3:25 pm

Re: [help] trouble with creating IDE hdd partition.

Postby atarifred » Wed Mar 22, 2017 8:22 pm

I'll test it tomorrow night, or Sunday night.
I downloaded the files, and I have one or two hours before me, I test.
I promise to make a comeback.
Too bad that I was not able to recover the small software in picture above.
Thanks again.
1040 STf + 4oGb IDE + RTC + TOS 4x + Gotek HxC
520 STf
1040 STe + Gotek HxC
520 STe + Gotek HxC

Maeke
Captain Atari
Captain Atari
Posts: 311
Joined: Sun Mar 13, 2016 1:54 pm

Re: [help] trouble with creating IDE hdd partition.

Postby Maeke » Wed Mar 22, 2017 9:50 pm

atarifred wrote:I'll test it tomorrow night, or Sunday night.
I downloaded the files, and I have one or two hours before me, I test.
I promise to make a comeback.
Too bad that I was not able to recover the small software in picture above.
Thanks again.

You can have it if you buy the full driver from ppera, it's cost is 10€ iirc.


Social Media

     

Return to “Applications”

Who is online

Users browsing this forum: No registered users and 3 guests