Magic 6.20 page

All about the serious stuff.

Moderators: Mug UK, Zorro 2, Moderator Team

SofiST
Atari Super Hero
Atari Super Hero
Posts: 591
Joined: Tue Apr 28, 2009 12:25 pm

Magic 6.20 page

Postby SofiST » Wed Oct 27, 2010 12:14 pm

http://atari.8bitchip.info/magic62.html

It is now complete translated to English, including keyboard, executables, core.

Shredder11
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2434
Joined: Mon Nov 26, 2007 2:23 pm
Location: West Yorkshire, United Kingdom (England)
Contact:

Re: Magic 6.20 page

Postby Shredder11 » Wed Oct 27, 2010 8:01 pm

:cheers:

User avatar
Mark_G
Atari Super Hero
Atari Super Hero
Posts: 518
Joined: Sun Feb 05, 2006 11:55 am
Location: Belgium

Re: Magic 6.20 page

Postby Mark_G » Thu Nov 04, 2010 11:38 am

Does someone tried this ?

I couldn't boot with this version of Magic. After initiation, it locked my Falcon.

I used the RAM version.

Mark

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Thu Nov 04, 2010 12:04 pm

I have MagiC phobias especially v6.x when it destroyed 2 of my HDD a decade ago.
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
Mark_G
Atari Super Hero
Atari Super Hero
Posts: 518
Joined: Sun Feb 05, 2006 11:55 am
Location: Belgium

Re: Magic 6.20 page

Postby Mark_G » Thu Nov 04, 2010 12:13 pm

On my TT030 magic5 (I guess) works very well.
On my milan, magicmilan 6.2 is also working fine.

On the Falcon, Magic locks the scsi drive, and corrupted the internal IDE-drive. I tested it on two falcons.
The second falcon is installed with Mint, and under Mint I didn't had any issues with my drives.

I've now also a broken IDE and SCSI drive. I'm still looking for replacement scsi drives of that age, and < 1GB.

Mark

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Thu Nov 04, 2010 1:24 pm

To be fair, I liked MagiC 3 which ran very well on my STFM.
I really liked MagiC 5.x as well, it had everything like FAT32 & LFN.
And therefore jumped to MagiC 6.x That was a disaster.... after it killed the 2 HDD in separate occasions.
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

SofiST
Atari Super Hero
Atari Super Hero
Posts: 591
Joined: Tue Apr 28, 2009 12:25 pm

Re: Magic 6.20 page

Postby SofiST » Thu Nov 04, 2010 2:02 pm

Killing drives permanently, or just deleting data ? SCSI drive problems, or IDE too. On Falcon only ?
I tried only with IDE drive (CF card) on Falcon.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Thu Nov 04, 2010 2:50 pm

OK, it happened years ago for me.... so it nothing to do with the modified/translated binaries from SofiST.
I'm talking about my experiences with v6.x.

Both the HDD were IDE and they were not even readable on Atari & Windows.
It may have trashed the boot sector and more....
Normally, Windows can overwrite the partition tables and you start a new.
But for both cases, it just cannot read the media at all.

It happened separately.... so the similar incident happened twice.
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Shredder11
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2434
Joined: Mon Nov 26, 2007 2:23 pm
Location: West Yorkshire, United Kingdom (England)
Contact:

Re: Magic 6.20 page

Postby Shredder11 » Thu Nov 04, 2010 3:36 pm

When you say trashed, do you mean the drives needed to be prepared for use again, i.e. re-partitioned and re-formatted or are you saying the drives had to literally thrown in the bin?

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Thu Nov 04, 2010 4:04 pm

Shredder11 wrote:When you say trashed, do you mean the drives needed to be prepared for use again, i.e. re-partitioned and re-formatted or are you saying the drives had to literally thrown in the bin?


Well, I mentioned that "It may have trashed the boot sector and more".
"may" because i really do not really know what happened.
"trashed boot sector and more".... normally disk geometry and such are written on the platter itself.
So my guess is that it overwrote these information on the boot sector. May be they are not at the boot sector... so the word "more". :wink:

Anyway, this makes the drive unreadable.... the computers (both Atari and Wintel) cannot read the HDD.
My guess is the CHS information was gone / overwritten /trashed.... by it.

There was no way to repartition or reformat them as the HDD was no recognized on both Atari Falcon & Windows.
(actually not Windows, but BIOS can't detect it).

I guess that the only way via software it can permanently damage a HDD is to overwrite important information like disk geometry and there by trashing the HDD, this in turn leave me no choice but to trash/throw the HDD into the dust bin. :mrgreen:
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Shredder11
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2434
Joined: Mon Nov 26, 2007 2:23 pm
Location: West Yorkshire, United Kingdom (England)
Contact:

Re: Magic 6.20 page

Postby Shredder11 » Thu Nov 04, 2010 4:19 pm

I see....that is what I thought you meant, so I feel like deleting all my MagiC v6 files, just incase I forget and decide to use them! 8O :cry:

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Thu Nov 04, 2010 4:28 pm

Shredder11 wrote:I see....that is what I thought you meant, so I feel like deleting all my MagiC v6 files, just incase I forget and decide to use them! 8O :cry:


Don't ! because I have not heard of another person's experience on this.
may be the issues is between my keyboard and my chair... :lol:
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

Shredder11
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2434
Joined: Mon Nov 26, 2007 2:23 pm
Location: West Yorkshire, United Kingdom (England)
Contact:

Re: Magic 6.20 page

Postby Shredder11 » Thu Nov 04, 2010 4:59 pm

Image

SofiST
Atari Super Hero
Atari Super Hero
Posts: 591
Joined: Tue Apr 28, 2009 12:25 pm

Re: Magic 6.20 page

Postby SofiST » Thu Nov 04, 2010 5:10 pm

I tried on Falcon, with SCSI drive and unmodded MAGIC.RAM - 6.20. It boots not at all. But nothing is harmed after few tries.
IDE boots fine. Maybe SCSI boot code is not good at all - and I did not mod it at all (and will not). I will put note that better not to use it with Falcon and SCSI.

However damaging hard disks so, that they are unusable is strange. There are not commands which permanently change CHS or other relevant structures. By older drives some wrong formatting may 'kill' drives, but by newer ones (last 10-15 years) format is usually disabled. I mean here low-level format of course.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Fri Nov 05, 2010 1:24 am

Like I said, I don't really know what when/where was wrong. :?: :?:
Best guess is that it overwrote some sensitive area....
My 2nd guess would be it somehow did a partial low level format,
but unlikely because it suddenly had this corruption meaning happen very fast.
Maybe low level format 1-2 critical sectors... :?: :?:

Anyway, for me I stay away from it.
Others can give it a go... because may be only my system or myself is the issue. :angel:
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
coze
Captain Atari
Captain Atari
Posts: 189
Joined: Thu Oct 16, 2008 4:10 am
Location: Tokyo
Contact:

Re: Magic 6.20 page

Postby coze » Fri Nov 05, 2010 1:49 pm

wongck wrote:
Anyway, this makes the drive unreadable.... the computers (both Atari and Wintel) cannot read the HDD.
My guess is the CHS information was gone / overwritten /trashed.... by it.


I dont think this is even possible. its more likely you had a hardware problem (a surge on the HDD voltage ?) killing the drives.

User avatar
AtariSince1989
Atari Super Hero
Atari Super Hero
Posts: 778
Joined: Sun Jan 11, 2009 1:14 pm
Location: Edinburgh, Scotland
Contact:

Re: Magic 6.20 page

Postby AtariSince1989 » Fri Nov 05, 2010 2:28 pm

SofiST wrote:http://atari.8bitchip.info/magic62.html

It is now complete translated to English, including keyboard, executables, core.

The website says "good for Steem", so I downloaded the DL current Magic 6.20 engl., unpacked the RAM folder, the MAGUE62.IMG and the contents of the folder TO_C_ROOT into the root of my HDD, but I get the error:

Offscreen-driver not found .
MCMD will restart ...
System is halted .


I'm doing anything wrong?

If on the contrary, I mount the MAGUE62.IMG I get the below screen, and I don't know what to do:
MAGUE62.IMG.jpg

Pressing CANCEL keeps showing me the same window.
You do not have the required permissions to view the files attached to this post.
- Atari 520 STe 4MB RAM + TOS 2.06 + UltraSatan
- Atari Falcon030 14MB RAM + TOS 4.04 + IDE-SD card HDD + NVRAM mod + SCSI buffer clock mod + EtherNEC
- Amstrad CPC 6128 + HxC USB Floppy Emulator
- Acorn A3010 4MB RAM + 40MB IDE HDD

Atari ST Essential software (The List)
My FTP Server: http://www.datavase.info/FTPserver (only from Midnight to 8am UK Time)
My music at http://soundcloud.com/datavase/

SofiST
Atari Super Hero
Atari Super Hero
Posts: 591
Joined: Tue Apr 28, 2009 12:25 pm

Re: Magic 6.20 page

Postby SofiST » Fri Nov 05, 2010 2:48 pm

IMG file is ROM image. And you need Pasti + hard disk image file + driver too for ROM based Magic to work.

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Fri Nov 05, 2010 4:03 pm

coze wrote:
wongck wrote:
Anyway, this makes the drive unreadable.... the computers (both Atari and Wintel) cannot read the HDD.
My guess is the CHS information was gone / overwritten /trashed.... by it.


I dont think this is even possible. its more likely you had a hardware problem (a surge on the HDD voltage ?) killing the drives.


I really hope so that it is my hardware power surge.... because I do not want others to happily use it and kills their hdd.
As I have said, I have not seen anyone else having an issue like this.... your theory may be correct.

So back to my hardware power surge problem... I am lucky that I have not experienced it again for so long, I lost count of the years it did not happen.
knock wood :)
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Fri Nov 05, 2010 4:06 pm

AtariSince1989 wrote:
SofiST wrote:http://atari.8bitchip.info/magic62.html

It is now complete translated to English, including keyboard, executables, core.

The website says "good for Steem", so I downloaded the DL current Magic 6.20 engl., unpacked the RAM folder, the MAGUE62.IMG and the contents of the folder TO_C_ROOT into the root of my HDD, but I get the error:

Offscreen-driver not found .
MCMD will restart ...
System is halted .


I'm doing anything wrong?

If on the contrary, I mount the MAGUE62.IMG I get the below screen, and I don't know what to do:
MAGUE62.IMG.jpg

Pressing CANCEL keeps showing me the same window.


It's trying to load the desktop... MagXdesk is the desktop.
I liked this desktop... colour icons, fast, background transfer, VFAT, LFN, the look with Winframe .... man it was better than the then Teradesk.
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
Mark_G
Atari Super Hero
Atari Super Hero
Posts: 518
Joined: Sun Feb 05, 2006 11:55 am
Location: Belgium

Re: Magic 6.20 page

Postby Mark_G » Fri Nov 05, 2010 11:00 pm

Offscreen-driver not found .
MCMD will restart ...
System is halted .


I got the same problem on my Falcon.

Mark

User avatar
wongck
Ultimate Atarian
Ultimate Atarian
Posts: 12706
Joined: Sat May 03, 2008 2:09 pm
Location: Far East
Contact:

Re: Magic 6.20 page

Postby wongck » Sat Nov 06, 2010 3:59 am

Mark_G wrote:
Offscreen-driver not found .
MCMD will restart ...
System is halted .

I got the same problem on my Falcon.
Mark


IIRC, you need to install from the setup (or what ever they named it).
It uses it's own VDI and they are found normally under the GEMSYS folder.
It's efficient and fast better than the TOS versions.
I cannot remember what the filenames are now.... :(
My Stuff: FB/Falcon CT63 CTPCI ATI RTL8139 USB 512MB 30GB HDD CF HxC_SD/ TT030 68882 4+32MB 520MB Nova/ 520STFM 4MB Tos206 SCSI
Shared SCSI Bus:ScsiLink ethernet, 9GB HDD,SD-reader @ http://phsw.atari.org
My Atari stuff for sale - click here for list

User avatar
Mark_G
Atari Super Hero
Atari Super Hero
Posts: 518
Joined: Sun Feb 05, 2006 11:55 am
Location: Belgium

Re: Magic 6.20 page

Postby Mark_G » Sat Nov 06, 2010 10:35 am

Yesterday, I've installed Magic 6.2 from the setup on a falcon and it works good (till now).

The other falcon has a strange behaviour, after some time the cursor or mouse pointer starts to flicker fast.
So another machine to check out.

Mark

SofiST
Atari Super Hero
Atari Super Hero
Posts: 591
Joined: Tue Apr 28, 2009 12:25 pm

Re: Magic 6.20 page

Postby SofiST » Mon Nov 08, 2010 2:24 pm

Updated DL-s on page. Now included image files with original and modded (for twisted IDE) boot.
+ there is image file of hard disk with preinstalled Magic 6.20 and hard disk driver, with 2 partitions. Short DL. May try in Steem too.

Shredder11
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2434
Joined: Mon Nov 26, 2007 2:23 pm
Location: West Yorkshire, United Kingdom (England)
Contact:

Re: Magic 6.20 page

Postby Shredder11 » Mon Nov 08, 2010 2:55 pm

I tried to download the file but maybe it is named differently on your server or something else? The current filename link is mag62wd.rar


Social Media

     

Return to “Applications”

Who is online

Users browsing this forum: No registered users and 1 guest