Mister not Booting up

https://github.com/MiSTer-devel/Main_MiSTer/wiki

Moderators: Mug UK, Zorro 2, Greenious, spiny, Sorgelig, Moderator Team

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Mister not Booting up

Postby Mlaurito » Sat Oct 05, 2019 8:03 am

Hello guys, hope someone can assist me.

In shorts when I put an sd card properly formatted with the Mister setup tool, the green and 3v leds lights up but nothing happens, I see the tj45 lighting up but no power to the usb otg hub either.

Yes I have tried 5 different cards already, including the original one, with different cores, the de 10 nano works fine with the original Linux img (tried also the newer one with good results).

Tried already different hdmi cables, monitors and cores but It seems like is getting stuck before that.

No orange light whatsovere when using a Mister sd prepped card.

Noticed a person on the forum having this issue and he had success by replacing the PSU, I tried a spare one I had at home, it's weaker than the original one and shows the same exact results.

Dip switches are in correct position.

I'm lost please help :)

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sat Oct 05, 2019 2:32 pm

Ah tried also 3 different HDMI cables, and with no hub plugged in :oops:

GoingDown
Atariator
Atariator
Posts: 27
Joined: Sun Jan 20, 2019 7:20 am

Re: Mister not Booting up

Postby GoingDown » Sat Oct 05, 2019 7:28 pm

Do you have any addon boards (sdram, I/O board)? If yes, try to remove them.

Also, you could try menu core if you haven't already.

Next thing would be is to define MiSTer.ini settings for screen resolution and refresh rate.

And finally maybe you have something amiss on computer you use for configuring the SD card. After card has been created, you may try to verify its contents.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sat Oct 05, 2019 8:02 pm

GoingDown wrote:Do you have any addon boards (sdram, I/O board)? If yes, try to remove them.

Also, you could try menu core if you haven't already.

Next thing would be is to define MiSTer.ini settings for screen resolution and refresh rate.

And finally maybe you have something amiss on computer you use for configuring the SD card. After card has been created, you may try to verify its contents.


Thanks for the reply, tried creating the sd on two different pcs (albeit for one I used the internal sd slot being a Surface Pro).

No additional boards are installed.

Tried different resolution already, each time I put a Mister prepped card I get no orange light at all.

What do you mean by menu core ? Tried different menu files with no joy.

Can I ask you what you see in terms of leds on your device if you just prep a card plug it in and turn on with nothing else atttached (no hdmi no otg no addons no rj45) attached ?

dhester
Retro freak
Retro freak
Posts: 11
Joined: Tue Dec 06, 2016 10:12 pm

Re: Mister not Booting up

Postby dhester » Sat Oct 05, 2019 8:48 pm

Make sure you are using mister cores not mist cores. I made this mistake at first, I put the right ones on the sd card then it worked.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sat Oct 05, 2019 9:08 pm

LoL why would I sorry

djmartins
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 121
Joined: Wed Nov 21, 2018 10:26 pm

Re: Mister not Booting up

Postby djmartins » Sat Oct 05, 2019 11:57 pm

Have you ever gotten MiSTer to boot up on this board?
If not, look for posts about the default positions of some of the board switches which
can cause this problem and make sure they are set where they should be set.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 8:26 am

As you can see from the original post dipswitches have been checked, which is the default position, it wouldn't read the sd card for the Terasic image otherwise.

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 5269
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Mister not Booting up

Postby Sorgelig » Sun Oct 06, 2019 9:22 am

connect USB console - there you may get more clues to what's happening.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 9:32 am

Sorgelig wrote:connect USB console - there you may get more clues to what's happening.


Thank you master, I thought it would be a good way to start looking at things, can you point me to some documentation on commands to use and the likes ? I only found a page with only basic info, thanks a lot

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 9:54 am

Ok so it seems a good start would be installing the uart drivers on windows, setting up Putty (which I use for other means already) and analyzing the bootlog after I have tried to boot while using this connection.

I hope I can get it to show anything, I am afraid is hanging even before booting up.

Will do the same with the Linux Img but that it is working without issues.

If you have any other tip let mw know, will try this evening and will report back my findings, thank you once again.

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 5269
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Mister not Booting up

Postby Sorgelig » Sun Oct 06, 2019 12:24 pm

99.9% problem in SD card. probably not properly formatted.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 12:24 pm

Here I am:

Linux all good can access to root

Mister- U-Boot 2017.03+ (May 23 2018 - 19:09:48 +0800)

Watchdog enabled
DRAM: 1 GiB


Gets stuck here

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 12:25 pm

Sorgelig wrote:99.9% problem in SD card. probably not properly formatted.


Tried 5 different cards, 2 different usb adapters and 2 pcs tho...

Creation under Linux is deprecated? I could try and setup a hackintosh otherwise...

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 5269
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Mister not Booting up

Postby Sorgelig » Sun Oct 06, 2019 12:38 pm

Mlaurito wrote:Here I am:

Linux all good can access to root

Mister- U-Boot 2017.03+ (May 23 2018 - 19:09:48 +0800)

Watchdog enabled
DRAM: 1 GiB


Gets stuck here

So, it's definitely SD card problem.
Probably your windows blocks something and doesn't let the installer to finish format and copy all required files.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 1:00 pm

Sorgelig wrote:
Mlaurito wrote:Here I am:

Linux all good can access to root

Mister- U-Boot 2017.03+ (May 23 2018 - 19:09:48 +0800)

Watchdog enabled
DRAM: 1 GiB


Gets stuck here

So, it's definitely SD card problem.
Probably your windows blocks something and doesn't let the installer to finish format and copy all required files.


Ok, fair enough, quite a weird behaviour, between tonight and tomorrow I will try to setup a hackintosh machine, want also try to format the sd card via and Android phone.

It might be a lot to ask, but would be possible to have a full sd image of a basic card done with something like macrium reflect in order to maintain partition and filesystem structure ? I understand if you don't have time, thanks for the moment and I will update the thread with my findings.

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 5269
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: Mister not Booting up

Postby Sorgelig » Sun Oct 06, 2019 1:20 pm

Mlaurito wrote:want also try to format the sd card via and Android phone.

sd card needs special partition to boot. No idea what will you do in android.

Mlaurito wrote:It might be a lot to ask, but would be possible to have a full sd image of a basic card done with something like macrium reflect in order to maintain partition and filesystem structure ? I understand if you don't have time, thanks for the moment and I will update the thread with my findings.

MiSTer is community project. So you are free to provide a better card installer using pre-made image which will work fine with any SD card size.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 1:30 pm

Sorgelig wrote:
Mlaurito wrote:want also try to format the sd card via and Android phone.

sd card needs special partition to boot. No idea what will you do in android.

Mlaurito wrote:It might be a lot to ask, but would be possible to have a full sd image of a basic card done with something like macrium reflect in order to maintain partition and filesystem structure ? I understand if you don't have time, thanks for the moment and I will update the thread with my findings.

MiSTer is community project. So you are free to provide a better card installer using pre-made image which will work fine with any SD card size.


As soon as get this thing working, I will look into it ;)

Threepwood
Atari maniac
Atari maniac
Posts: 78
Joined: Thu Jan 10, 2019 10:06 am

Re: Mister not Booting up

Postby Threepwood » Sun Oct 06, 2019 2:09 pm

Try formatting an SD-Card with Rufus as exFAT, it can properly format them and delete all partitions that might be on the SD: https://rufus.ie

Then try the MiSTer setup tool again. Make sure both tools run as administrator and when windows complains about an unformatted partition when you are done, ignore it. The SD will contain one unreadable partition and one exFAT partition where you find all the MiSTer stuff.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 3:13 pm

Will do but I tried wiping all the partitions with 3 different softwares already (including WDM and a partition tool), just tried using an old win7 machine (not supported I know but it finished the job) and another image found in the the forum and burned with balena etcher and stil no joy:

U-Boot SPL 2017.03+ (May 23 2018 - 19:09:48)
Trying to boot from MMC1


U-Boot 2017.03+ (May 23 2018 - 19:09:48 +0800)

Watchdog enabled
DRAM: 1 GiB

U-Boot SPL 2017.03+ (May 23 2018 - 19:09:48)
Trying to boot from MMC1


U-Boot 2017.03+ (May 23 2018 - 19:09:48 +0800)

Watchdog enabled
DRAM: 1 GiB

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 4:14 pm

I also used Diskpart "clean" which I found in the past the best at clearing all partitions even on corrupted sds

GoingDown
Atariator
Atariator
Posts: 27
Joined: Sun Jan 20, 2019 7:20 am

Re: Mister not Booting up

Postby GoingDown » Sun Oct 06, 2019 4:16 pm

Mlaurito wrote:
Sorgelig wrote:99.9% problem in SD card. probably not properly formatted.


Tried 5 different cards, 2 different usb adapters and 2 pcs tho...

Creation under Linux is deprecated? I could try and setup a hackintosh otherwise...


Here is link for SD card creation under Linux:
viewtopic.php?f=117&t=36571&p=371836&hilit=linux#p371836

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 4:46 pm

GoingDown wrote:
Mlaurito wrote:
Sorgelig wrote:99.9% problem in SD card. probably not properly formatted.


Tried 5 different cards, 2 different usb adapters and 2 pcs tho...

Creation under Linux is deprecated? I could try and setup a hackintosh otherwise...


Here is link for SD card creation under Linux:
viewtopic.php?f=117&t=36571&p=371836&hilit=linux#p371836


Appreciated! Will report back and if still failing this will go back for a replacement ! Thanks again to everyone will make sure to support the project :cheers:

Threepwood
Atari maniac
Atari maniac
Posts: 78
Joined: Thu Jan 10, 2019 10:06 am

Re: Mister not Booting up

Postby Threepwood » Sun Oct 06, 2019 4:47 pm

Mlaurito wrote:Will do but I tried wiping all the partitions with 3 different softwares already (including WDM and a partition tool), just tried using an old win7 machine (not supported I know but it finished the job) and another image found in the the forum and burned with balena etcher and stil no joy:


Hm, do you use an antivirus? If yes, try deactivating that for the setup.

Mlaurito
Atariator
Atariator
Posts: 27
Joined: Mon Jul 22, 2019 9:07 pm

Re: Mister not Booting up

Postby Mlaurito » Sun Oct 06, 2019 5:00 pm

Threepwood wrote:
Mlaurito wrote:Will do but I tried wiping all the partitions with 3 different softwares already (including WDM and a partition tool), just tried using an old win7 machine (not supported I know but it finished the job) and another image found in the the forum and burned with balena etcher and stil no joy:


Hm, do you use an antivirus? If yes, try deactivating that for the setup.


Nope I even disable all the realtime monitoring from Defender, tomorrow I'll be able to give you an update after I have tried at least Linux, might do it even tonight if I have the strength to setup a docker on my Freebsd server


Return to “MiSTer”

Who is online

Users browsing this forum: MattE888 and 7 guests