HDMI audio : monitor has to be switched off then on

https://github.com/MiSTer-devel/Main_MiSTer/wiki

Moderators: Mug UK, Zorro 2, Greenious, spiny, Sorgelig, Moderator Team

mahen
Captain Atari
Captain Atari
Posts: 219
Joined: Mon Aug 26, 2013 3:11 pm
Location: France

HDMI audio : monitor has to be switched off then on

Postby mahen » Fri Feb 08, 2019 2:50 pm

Hi ! I'm really sorry if this bug was reported before. I made a search on the forum.

When using the MiSTer with a Iiyama HDMI monitor (quite a few years old), in HDMI mode, I noticed that I frequently have no sound. Sound gets back when turning the monitor off and on.

It happens frequently from the very beginning when using the Minimig core.
It also happens for instance with the Genesis core. i.e. : in Turrican 3, there are some resolution switched. I get sound when the logo is displayed then there is a resolution switch and I get no more audio : I have to turn off & on the monitor to get it back.

I tried the "disable dvi" script to no avail.

Do you people have any idea ? Of course I could work around this by buying the IO board and using the analog output...
Cheers !
Amiga user non-stop since 1993 ;-)
Win 1997-2001 / MorphOS 2002-2005 / Linux since 2005

Hewhoisred
Atari freak
Atari freak
Posts: 51
Joined: Sun Dec 09, 2018 6:53 pm

Re: HDMI audio : monitor has to be switched off then on

Postby Hewhoisred » Fri Feb 08, 2019 5:15 pm

HDMI audio just doesn't work quite right with some monitors/tvs. Some work, some don't. My Samsung TV works fine, my ASUS 144hz monitor... no sound on most but not all cores. It is a known, long standing issue. Analog sound from and IO board will for sure work. I know, because that's how mitigated the issue for myself.

User avatar
Nextric
Retro freak
Retro freak
Posts: 16
Joined: Wed Aug 23, 2017 10:29 am

Re: HDMI audio : monitor has to be switched off then on

Postby Nextric » Mon Feb 11, 2019 1:39 pm

I have the same problem in a Asus monitor with Zx Spectrum core. The only solution by me, use the analog output.

JamesF
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 120
Joined: Sat Dec 15, 2018 6:46 am

Re: HDMI audio : monitor has to be switched off then on

Postby JamesF » Mon Feb 11, 2019 2:27 pm

Please try the latest SNES core and report, it has new HDMI audio code.
If it works fine, this audio code should be implemented in all cores soon.

Also, try using vsync_adjust=0

User avatar
Nextric
Retro freak
Retro freak
Posts: 16
Joined: Wed Aug 23, 2017 10:29 am

Re: HDMI audio : monitor has to be switched off then on

Postby Nextric » Mon Feb 11, 2019 9:00 pm

For me, the latest SNES core work perfect.


Return to “MiSTer”

Who is online

Users browsing this forum: jemismyname, solo20 and 4 guests