ZX Spectrum Core

https://github.com/MiSTer-devel/Main_MiSTer/wiki

Moderators: Mug UK, Zorro 2, spiny, Greenious, Sorgelig, Moderator Team

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Thu Nov 21, 2019 4:47 pm

As of version 19.09.26 (included), I have noticed that the protagonist of the game Sir Fred climb pending in a very strange way, as if tired. It happens both by operating it from keyboard or joystick. The rest of movements in plain, jumps and others is normal.

In the following videos you can see first, as you would do normally, and in the next one as you do now.

https://youtu.be/xo-bF0SQEb0
Climb pending correctly
(ver. 19.09.11 and earlier)


https://youtu.be/8FOKAMYvtwA
Climb pending incorrectly
(Ver. 19.09.26 and later)

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6036
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: ZX Spectrum Core

Postby Sorgelig » Thu Nov 21, 2019 5:19 pm

I plan to release update with fixed slacks. May be it will fix the problem.

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Mon Dec 23, 2019 10:54 pm

Sorgelig wrote:I plan to release update with fixed slacks. May be it will fix the problem.


Ok. The last update fixed this problem, but it's also true that I changed my memory module.

Now I have a new memory module with a new SDRAM chip mounted on an official XS v2.2 board that work perfectly in all cores I except in this one and I tell you the problem: The load of files TAP or TZX not work, and the audio loading does not work either. Instead of loading it is heard as a continuous sound and the border is kept blank in all three cases.

I have tried with previous versions and the same thing happens, I guess it will have to do with the latest firmware settings for this particular core.

Thank you for your great work.

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6036
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: ZX Spectrum Core

Postby Sorgelig » Tue Dec 24, 2019 3:42 am

I've tried tap and tzx - didn't find the problem.

What steps to reproduce the problem?

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Tue Dec 24, 2019 8:59 am

Sorgelig wrote:I've tried tap and tzx - didn't find the problem.

What steps to reproduce the problem?


Yes, it doesn't happen to everyone.

I Follow the same steps as always:

I select TAP or TZX file and write LOAD "" or I choose LOAD in the menu of 128K ROMs.

The same thing happens to me in audio uploads.

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Tue Dec 24, 2019 9:09 am

I've realized that what fail is the LOAD command:

Watch the video:
https://youtu.be/f9YSft65x1A

Do you hear the purr?

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6036
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: ZX Spectrum Core

Postby Sorgelig » Tue Dec 24, 2019 11:50 am

Can you try Spectrum 128K/+2 mode?

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Tue Dec 24, 2019 12:32 pm

Sorgelig wrote:Can you try Spectrum 128K/+2 mode?


It happens with all modes and settings. In the previous releases too.

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Wed Dec 25, 2019 9:22 am

I just want to add two things:

All other cores (as well as the other options of this one) work perfectly with my configuration.

The memory module I have is mounted on an XS v2.2 PCB with SDRAM ALLIANCE AS4C32M16SB-7TCN.

Thanks and Merry Christmas.

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6036
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: ZX Spectrum Core

Postby Sorgelig » Wed Dec 25, 2019 9:50 pm

Why i'm not surprising it's 64MB module?

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Wed Dec 25, 2019 11:49 pm

Sorgelig wrote:Why i'm not surprising it's 64MB module?


But is an official PCB XS v2.2 and also does not give any problem in any other core.
On the other hand, the new memtest does not throw errors from 150Hhz.

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6036
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: ZX Spectrum Core

Postby Sorgelig » Thu Dec 26, 2019 8:34 am

There is at least another user who has weird behaviour on ZX core with 64MB module (although non-official one). But he has problem with 48K mode while 128K mode works.
So i have no idea why.
Generally speaking i don't recommend 64MB module - they have high rate of problems. I recommend either 32MB or 128MB.

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Thu Dec 26, 2019 11:03 am

Sorgelig wrote:There is at least another user who has weird behaviour on ZX core with 64MB module (although non-official one). But he has problem with 48K mode while 128K mode works.
So i have no idea why.
Generally speaking i don't recommend 64MB module - they have high rate of problems. I recommend either 32MB or 128MB.


I understand it.

But also understand that I am not going to change module just because a part of this core does not work.

I think there must still be something "different" in this core that does not work totally well.

vanfanel
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 127
Joined: Tue Oct 09, 2018 10:19 pm
Location: Salamanca, España

Re: ZX Spectrum Core

Postby vanfanel » Thu Dec 26, 2019 2:09 pm

I had problems with the 48k games until I updated the ROM from the github repo.

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Fri Dec 27, 2019 7:20 am

vanfanel wrote:I had problems with the 48k games until I updated the ROM from the github repo.


The shots don't go there.
We have tested that ROM and others with the same result.

Thanks anyway for the idea.

vanfanel
Obsessive compulsive Atari behavior
Obsessive compulsive Atari behavior
Posts: 127
Joined: Tue Oct 09, 2018 10:19 pm
Location: Salamanca, España

Re: ZX Spectrum Core

Postby vanfanel » Fri Dec 27, 2019 11:52 am

the80scomputers wrote:The shots don't go there.


Do you mean "los tiros no van por ahí"?? I can immediately tell you are spanish like me :lol:

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Fri Dec 27, 2019 4:42 pm

vanfanel wrote:
the80scomputers wrote:The shots don't go there.


Do you mean "los tiros no van por ahí"?? I can immediately tell you are spanish like me :lol:


True, it seems a little known expression outside our language.

Surely this expression is better understood: "You're barking up the wrong tree" :lol:

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6036
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: ZX Spectrum Core

Postby Sorgelig » Fri Dec 27, 2019 8:32 pm

Try latest metest

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Sat Dec 28, 2019 12:27 am

Sorgelig wrote:Try latest metest



Yes. It works stable up to 160MHz that starts to fail (is Ok, although with the previous memtest it only failed at 167MHz).

This core needs to run 100Mhz, it's tremendous for a core of a 8 bit computer that ran at 3.5Mhz!

I honestly think that this core what it really needs is a great debugging for a good release, need a little miracle like the ones you do from time to time.

Happy new year, genius.

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6036
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: ZX Spectrum Core

Postby Sorgelig » Sat Dec 28, 2019 2:29 pm

I have no idea what can be done to fix your problem. If i could reproduce it on my MiSTer, then i would look into, but alas it works fine for me.

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Sat Dec 28, 2019 5:24 pm

Sorgelig wrote:I have no idea what can be done to fix your problem. If i could reproduce it on my MiSTer, then i would look into, but alas it works fine for me.


I understand perfectly that it is complicated.

More data:

- Same module and same fault in another De10-Nano.
- After a while in on, sometimes it does not fail.

Do you think that the problem could be corrected by changing the capacitors?
What is their optimal value (XS v2.1)? The ones he has are 0.1uf

ZX Spectrum is my favorite 8 bit system, I got rid of ZX-UNO, I hope I don't have to look for it again :(

Sorgelig
Ultimate Atarian
Ultimate Atarian
Posts: 6036
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: ZX Spectrum Core

Postby Sorgelig » Sat Dec 28, 2019 5:55 pm

64MB modules are unstable. It most likely needs 4-layer PCB. I don't recommend 64MB modules in general.

I've tested XSD PCB with one chip so it works as 64MB. It seems to work ok, but it's not 100% confirmed.

User avatar
the80scomputers
Atari User
Atari User
Posts: 41
Joined: Sun Oct 06, 2019 8:29 am

Re: ZX Spectrum Core

Postby the80scomputers » Sun Dec 29, 2019 9:02 am

I see no reason to change memory module, everything worked fine.

I don't know the changes that were introduced after version 20190711 but
the core is broke for me, therefore, I will keep this versión until some better ZX Spectrum port comes out.

Thank you very much.

Ldaborc
Retro freak
Retro freak
Posts: 16
Joined: Fri Nov 23, 2018 3:03 pm

Re: ZX Spectrum Core

Postby Ldaborc » Fri Mar 20, 2020 7:27 am

ZX-SPECTRUM Next can be done on MiSTer?
If I could, I would have done it myself! 8)

Chris23235
Captain Atari
Captain Atari
Posts: 157
Joined: Thu Aug 07, 2014 6:52 pm

Re: ZX Spectrum Core

Postby Chris23235 » Fri Mar 20, 2020 9:10 am

Ldaborc wrote:ZX-SPECTRUM Next can be done on MiSTer?


Look here:

viewtopic.php?f=117&t=38476


Return to “MiSTer”

Who is online

Users browsing this forum: illegalprime and 5 guests