Page 1 of 1

MicroCosmos - ICD - HDUTIL issues

Posted: Thu Sep 21, 2017 9:13 pm
by ScreamingJoeBlade
I have a Mega STE and a MicroCosmo.

I tried partitioning an SD with a copy of ICD 6.5.5. on the A Floppy that I loaded off of Jookie's site. Couldn't format the drive without running ICDBoot first (It should be running already if the floppy is in the drive no?) After partitioning the drive I tried running HDUtil - but it says I need a copy of ICD 6.5.2 or newer. I tried running ICDBoot again - it tells me it is already running... I Try HDUtil again - get same message about running 6.5.2 or newer - Any suggestions?

Re: MicroCosmos - ICD - HDUTIL issues

Posted: Thu Sep 21, 2017 10:03 pm
by Atarieterno
Hello;
I do not have microCosmos, but I have CosmosEx.
I assume you know that the internal ACSI-SCSI adapter without modification does not support more than 1 Gby of capacity; if you connect it through the external ACSI port you do not have that limitation.
My experience is as follows: ICD drivers are good but are not updated for more modern devices and do not allow the exchange of information with other platforms (for example with a PC).
My problems were ended when I bought some more modern drivers, you have at your disposal those of Peter Putnik and those of Uwe Seimet, both with good prices and I believe that also participate in this forum.

http://atari.8bitchip.info/pphdr.php

http://hddriver.seimet.de/en/

Re: MicroCosmos - ICD - HDUTIL issues

Posted: Thu Sep 21, 2017 11:16 pm
by Estrayk
ScreamingJoeBlade wrote:I have a Mega STE and a MicroCosmo.

I tried partitioning an SD with a copy of ICD 6.5.5. on the A Floppy that I loaded off of Jookie's site. Couldn't format the drive without running ICDBoot first (It should be running already if the floppy is in the drive no?) After partitioning the drive I tried running HDUtil - but it says I need a copy of ICD 6.5.2 or newer. I tried running ICDBoot again - it tells me it is already running... I Try HDUtil again - get same message about running 6.5.2 or newer - Any suggestions?


Use this disk:
https://mega.nz/#!OAdz1AQQ!UcPr6Y1WS8la ... sf39wyEE2Y

Run ICDBOOT.PRG
Run ICDFMT.PRG - (dont select PARTITION!, just select FORMAT )
Run HDUTIL.PRG - select BOOT

Re: MicroCosmos - ICD - HDUTIL issues

Posted: Wed Sep 27, 2017 2:09 pm
by ScreamingJoeBlade
[quote]
Use this disk:
https://mega.nz/#!OAdz1AQQ!UcPr6Y1WS8la ... sf39wyEE2Y

Run ICDBOOT.PRG
Run ICDFMT.PRG - (dont select PARTITION!, just select FORMAT )
Run HDUTIL.PRG - select BOOT[quote]

As I originally posted I was using that version of ICD. And I was using it per the instructions on Jookie's page (which are pretty much the same as yours) HDUTIL.PRG was not recognizing ICDBOOT.PRG.

The problem was fixed by using a no name smaller sized (2gb) microSD card. Worked with no problems.

So now I have a Kingston & a Lexar microsd cards that I have to find other purpose / homes for.