Cosmos Ex no longer detected?

News, questions and bugs reports about CosmosEx by Jookie. Now we have a Raspberry Pi in our machines!

Moderators: Jookie, Moderator Team

Retro freak
Retro freak
Posts: 15
Joined: Wed May 21, 2014 2:46 am

Cosmos Ex no longer detected?

Postby eebuckeye » Mon Nov 23, 2015 3:37 am

I updated my CE to the latest version the other day with no issues in fact I used it after I updated it with no problem. I also use the ppera driver which has been working fine.

I moved files around on my CE SD partitions using my Win XP machine that was updated to see multiple partitions on the SD card. I then used the CE on my ST with no issues. I then renamed my partitions from Hard Disk to other names so I know where files were saved (such as A-CL as the name instead of Hard Disk). After I renamed the partitions I saved the desktop.

Next time I booted no drives (including floppy drives) appeared on the TOS 1.4 desktop. It was completely blank but the menu at the top worked fine like normal.

I thought maybe the Desktop file on the CE SD card (1st partition) was corrupt so I deleted it on my Win XP machine. Now when I boot the Cosmos EX I no longer see the white CE boot screen load before TOS appears and none of my drives other than floppy appear on the desktop. I tried to copy the ppera driver back to the Cosmos EX partition but the program does not detect any hard drives attached. I did run the CE config program from a floppy and it shows the Cosmos EX with no problems and it seems to be configured correctly still (to my knowledge). I have ACSI ID 0 set to SD which did not change but I can not get anything to work.

What should I do to get the Cosmos EX working again? I see it boots ok as the blue lights blink as expected on the CE and the CE config program recognizes it with no issue.

Please help! Thank you!

User avatar
Hardware Guru
Hardware Guru
Posts: 1245
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia

Re: Cosmos Ex no longer detected?

Postby Jookie » Mon Nov 23, 2015 6:57 am

Hello Brad,

this might be due to lot of changes made to support the SCSI interface - changes made in the last half year. I mentioned in the update thread that the updates are not yet recommended for older CE devices, but as I see things happened...

I need few more days to test it on older CE and possibly fix the issue(s).


Social Media


Return to “CosmosEx”

Who is online

Users browsing this forum: No registered users and 3 guests