CosmosEx network not working - and how to solve it...

News, questions and bugs reports about CosmosEx by Jookie. Now we have a Raspberry Pi in our machines!

Moderators: Jookie, Moderator Team

User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1245
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

CosmosEx network not working - and how to solve it...

Postby Jookie » Wed Jul 30, 2014 1:41 am

Hello all,

as this is an issue which many of you have hit with the device, I'm writing a short info / how to here how to resolve the issue, so if anyone else will have the trouble, he can find this easily...

The problem with the network not working happens when you have CosmosEx Main App version with date before 2014-07-27 (it was fixed with that date), and you did save network configuration using the ce_config.prg. The whole problem is that one line is missing in a config file telling linux to start the network, and here's how to fix it.

If you are bit OK with linux and vi editor you can do the following:
- get your CosmosEx device, connect it to TV using HDMI (connector on the side) and use some USB keyboard and USB power supply (phone charger?) to get it working on that TV
- log in - user: root, password: ce
- using vi editor edit the /etc/network/interfaces file like this:
vi /etc/network/interfaces

...and add a line saying:
auto eth0

(I guess the line position in the file doesn't matter that much, so just put it as the first line of the file).
- save the file by writing
:wq [enter key]
(this means write and quit)

- write 'sync' and hit enter, wait until it returns to command line

Now you can turn off your device, it should start the network automatically on the power on, so connect it to ST, start 'ce_conf.prg' and do the udpate, that should solve the other problems too.

If editing in vi is a problem but you have your ST near to your TV, instead of editing the file you can do just:
ifup eth0

...and that will start the network, but this isn't permanent so it works only until you turn off the device. So then (without turning off the device) start the ST, do the update, and in the 'ce_conf.prg' go to network settings screen and press 'Save' button - this will save the new /etc/network/interfaces file which will contain that 'auto eth0' line...

You can achieve similar results by taking out the SD card out of Raspberry Pi, writing the image to the SD card and then doing the update, but this is easier if you do have a TV and USB keyboard around...

If you decide to write the original image to the Raspberry Pi SD card, you need to take out the SD card, and possibly also revert Hans and Franz firmware to the initial version, and this is how you do it: http://www.atari-forum.com/viewtopic.php?f=103&t=26753#p255842
(there will be a script to do that for you, but for now there isn't one).

User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1245
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

Re: CosmosEx network not working - and how to solve it...

Postby Jookie » Mon Aug 11, 2014 5:00 am

One last thing - I guess the easier but temporary solution can be done without the TV connected through HDMI, like this:
- turn on the device with USB keyboard connected, wait like 30 seconds or so
- type 'root' on the keyboard, press enter, wait 3 seconds
- type 'ce' on the keyboard, press enter, wait 3 seconds
- type 'ifup eth0' on the keyboard, press enter, wait 3 seconds

Now the network should be running, so do the software update of CosmosEx by running 'ce_conf.prg', then go to the network settings and press 'Save' - to save the updated (fixed) network settings file. From that time the network should work...

User avatar
DrCoolZic
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2144
Joined: Mon Oct 03, 2005 7:03 pm
Location: France
Contact:

Re: CosmosEx network not working - and how to solve it...

Postby DrCoolZic » Tue Sep 30, 2014 10:46 am

Jookie wrote:One last thing - I guess the easier but temporary solution can be done without the TV connected through HDMI, like this:
- turn on the device with USB keyboard connected, wait like 30 seconds or so
- type 'root' on the keyboard, press enter, wait 3 seconds
- type 'ce' on the keyboard, press enter, wait 3 seconds
- type 'ifup eth0' on the keyboard, press enter, wait 3 seconds

Now the network should be running, so do the software update of CosmosEx by running 'ce_conf.prg', then go to the network settings and press 'Save' - to save the updated (fixed) network settings file. From that time the network should work...

I thought keyboard inputs where redirected to the Atari through the IKBD injector?

User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1245
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

Re: CosmosEx network not working - and how to solve it...

Postby Jookie » Tue Sep 30, 2014 11:24 am

DrCoolZic wrote:I thought keyboard inputs where redirected to the Atari through the IKBD injector?


Hard to say - some people have resolved issues using this, some couldn't get it working. The keyboard input shouldn't be completely redirected to IKBD injector, and with normal linux and normal PC the keyboard input can be read in multiple apps at once (when the input device event file is open)...

User avatar
DrCoolZic
Fuji Shaped Bastard
Fuji Shaped Bastard
Posts: 2144
Joined: Mon Oct 03, 2005 7:03 pm
Location: France
Contact:

Re: CosmosEx network not working - and how to solve it...

Postby DrCoolZic » Tue Sep 30, 2014 4:54 pm

Jookie wrote:
DrCoolZic wrote:I thought keyboard inputs where redirected to the Atari through the IKBD injector?


Hard to say - some people have resolved issues using this, some couldn't get it working. The keyboard input shouldn't be completely redirected to IKBD injector, and with normal linux and normal PC the keyboard input can be read in multiple apps at once (when the input device event file is open)...

??? not sure I understand
What you have just described (connect as root on USB KB) does it work or not?
Is this dependant whether the IKBD injector is installed or not?

User avatar
Jookie
Hardware Guru
Hardware Guru
Posts: 1245
Joined: Wed Feb 04, 2004 6:54 pm
Location: Kosice, Slovakia
Contact:

Re: CosmosEx network not working - and how to solve it...

Postby Jookie » Wed Oct 01, 2014 12:35 am

DrCoolZic wrote:??? not sure I understand
What you have just described (connect as root on USB KB) does it work or not?
Is this dependant whether the IKBD injector is installed or not?


If I remember correctly, I tried it when I wrote that (almost 2 months ago), and it worked. Then some people wrote that they fixed stuff like that - on TV with USB keyboard. And some people wrote, that the USB keyboard doesn't work for them, so they can't fix it this way. So I've just took my CosmosEx to my TV (now, again), connected HDMI, powered the device from USB port of TV, had the USB keyboard there from the start, and it worked:
http://joo.kie.sk/cosmosex/cosmosex_on_tv.jpg

I have no idea why it isn't working for some people, and the USB keyboard input shouldn't be completely forwarded to ST as more than one app in linux may open the keyboard device, and thus the Main App running on the device shouldn't block the USB keyboard...


Social Media

     

Return to “CosmosEx”

Who is online

Users browsing this forum: No registered users and 2 guests